(address . guix-patches@gnu.org)
This program currently lacks version number everywhere - in pkgconfig,
in CLI and in GUI, because it is generated by a script that needs git
and updating shebang. This patch fixes the problem.
From c066b30a8f1afff37deb54d7ed571d99b059f619 Mon Sep 17 00:00:00 2001
Message-ID: <c066b30a8f1afff37deb54d7ed571d99b059f619.1723204072.git.mail@pisemsky.site>
From: Evgeny Pisemsky <mail@pisemsky.site>
Date: Fri, 9 Aug 2024 14:40:05 +0300
Subject: [PATCH] gnu: gerbv: Fix missing version.
* gnu/packages/engineering.scm (gerbv): Fix missing version.
[source]: Change indentation.
[arguments]: Patch version generator shebang.
[native-inputs]: Add git.
Change-Id: I29a38fff03127d9ce2b5e04ca638dacfc3720125
---
gnu/packages/engineering.scm | 30 +++++++++++++++++++-----------
1 file changed, 19 insertions(+), 11 deletions(-)
Toggle diff (58 lines)
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index d5d72a0c85..697ceff59f 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -27,7 +27,7 @@
;;; Copyright © 2021 Ivan Gankevich <i.gankevich@spbu.ru>
;;; Copyright © 2021, 2022 Petr Hodina <phodina@protonmail.com>
;;; Copyright © 2021 Foo Chuan Wei <chuanwei.foo@hotmail.com>
-;;; Copyright © 2022 Evgeny Pisemsky <mail@pisemsky.site>
+;;; Copyright © 2022, 2024 Evgeny Pisemsky <mail@pisemsky.site>
;;; Copyright © 2022 Olivier Dion <olivier.dion@polymtl.ca>
;;; Copyright © 2022 Peter Polidoro <peter@polidoro.io>
;;; Copyright © 2022 Malte Frank Gerdes <malte.f.gerdes@gmail.com>
@@ -833,22 +833,30 @@ (define-public gerbv
(package
(name "gerbv")
(version "2.10.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/gerbv/gerbv")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "06bcm5zw7whsnnmfld3gl2j907lxc68gnsbzr2pc4w6qc923rgmj"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gerbv/gerbv")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "06bcm5zw7whsnnmfld3gl2j907lxc68gnsbzr2pc4w6qc923rgmj"))))
(build-system gnu-build-system)
(arguments
- '(#:configure-flags '("CFLAGS=-fcommon")))
+ (list
+ #:configure-flags '(list "CFLAGS=-fcommon")
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-version-generator
+ (lambda _
+ (substitute* "utils/git-version-gen.sh"
+ (("/bin/bash")
+ (which "bash"))))))))
(native-inputs (list autoconf
automake
desktop-file-utils
gettext-minimal
+ git
`(,glib "bin")
libtool
pkg-config))
base-commit: 20dbf225f332ccc707578263ed710dcf2a8fb78e
--
2.45.2