* gnu/packages/networking.scm (yggdrasil): Update to 0.5.7.
[propagated-inputs]: Add go-nhooyr-io-websocket. Remove a duplicate of
go-github-com-hjson-hjson-go. Sort the inputs alphabetically.
Change-Id: I68d0e4d21fc39eea21fd3a4fb89004d0bd04388d
---
gnu/packages/networking.scm | 46 ++++++++++++++++++-------------------
1 file changed, 23 insertions(+), 23 deletions(-)
Toggle diff (78 lines)
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 91aaccf06d..96743afa83 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -4608,7 +4608,7 @@ (define-public ngtcp2
(define-public yggdrasil
(package
(name "yggdrasil")
- (version "0.5.6")
+ (version "0.5.7")
(source
(origin
(method git-fetch)
@@ -4619,7 +4619,7 @@ (define-public yggdrasil
(recursive? #t)))
(file-name (git-file-name name version))
(sha256
- (base32 "1wcvqk45p1k165bd32dc3hl73r0i6g14rxxkjxfr9x2d8410l91f"))
+ (base32 "0dsca3208mi221ayq3a2rikf20yphalxswsh97r4maxv69x1ka44"))
(patches (search-patches "yggdrasil-extra-config.patch"))))
(build-system go-build-system)
(arguments
@@ -4646,32 +4646,32 @@ (define-public yggdrasil
"github.com/yggdrasil-network/yggdrasil-go/cmd/yggdrasilctl"
"github.com/yggdrasil-network/yggdrasil-go/cmd/genkeys"))))))))
(propagated-inputs
- (list go-golang-zx2c4-com-wireguard
- go-golang-org-x-text
- go-golang-org-x-net
- go-golang-org-x-crypto
- go-golang-org-x-tools
- go-golang-org-x-sys
- go-netns
- go-netlink
+ (list go-github-com-arceliar-ironwood
+ go-github-com-arceliar-phony
go-github-com-bits-and-blooms-bitset
go-github-com-bits-and-blooms-bloom
- go-github-com-quic-go-quic-go
+ go-github-com-cheggaaa-pb-v3
+ go-github-com-fatih-color
+ go-github-com-gologme-log
+ go-github-com-hashicorp-go-syslog
go-github-com-hjson-hjson-go
- go-github-com-olekukonko-tablewriter
- go-github-com-mitchellh-mapstructure
- go-github-com-mattn-go-runewidth
- go-github-com-mattn-go-isatty
- go-github-com-mattn-go-colorable
go-github-com-kardianos-minwinsvc
- go-github-com-hjson-hjson-go
- go-github-com-hashicorp-go-syslog
- go-github-com-gologme-log
- go-github-com-fatih-color
- go-github-com-cheggaaa-pb-v3
+ go-github-com-mattn-go-colorable
+ go-github-com-mattn-go-isatty
+ go-github-com-mattn-go-runewidth
+ go-github-com-mitchellh-mapstructure
+ go-github-com-olekukonko-tablewriter
+ go-github-com-quic-go-quic-go
go-github-com-vividcortex-ewma
- go-github-com-arceliar-phony
- go-github-com-arceliar-ironwood))
+ go-golang-org-x-crypto
+ go-golang-org-x-net
+ go-golang-org-x-sys
+ go-golang-org-x-text
+ go-golang-org-x-tools
+ go-golang-zx2c4-com-wireguard
+ go-netlink
+ go-netns
+ go-nhooyr-io-websocket))
(home-page "https://yggdrasil-network.github.io/blog.html")
(synopsis
"Experiment in scalable routing as an encrypted IPv6 overlay network")
--
2.45.2