[PATCH] Add: rofi-emoji.

  • Open
  • quality assurance status badge
Details
One participant
  • Wamm K. D.
Owner
unassigned
Submitted by
Wamm K. D.
Severity
normal
W
W
Wamm K. D. wrote on 7 Aug 01:41 +0200
(address . guix-patches@gnu.org)(name . Wamm K. D.)(address . jaft.r@outlook.com)
MW4PR84MB1371F57A251A1F6EBA99E6D399BF2@MW4PR84MB1371.NAMPRD84.PROD.OUTLOOK.COM
* gnu/packages/xdisorg.scm (rofi-emoji): New variable.
---
gnu/packages/xdisorg.scm | 39 ++++++++++++++++++++++++++++++++++++++-
1 file changed, 38 insertions(+), 1 deletion(-)

Toggle diff (59 lines)
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 4c12835b24..bb95304a1f 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -55,7 +55,7 @@
;;; Copyright © 2022 John Kehayias <john.kehayias@protonmail.com>
;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
;;; Copyright © 2022 Derek Chuank <derekchuank@outlook.com>
-;;; Copyright © 2022, 2023 Wamm K. D. <jaft.r@outlook.com>
+;;; Copyright © 2022, 2023, 2024 Wamm K. D. <jaft.r@outlook.com>
;;; Copyright © 2022 Tobias Kortkamp <tobias.kortkamp@gmail.com>
;;; Copyright © 2023 Yovan Naumovski <yovan@gorski.stream>
;;; Copyright © 2023 Jake Leporte <jakeleporte@outlook.com>
@@ -2102,6 +2102,43 @@ (define-public rofi-calc
natural language input and provide results.")
(license license:expat)))
+(define-public rofi-emoji
+ (package
+ (name "rofi-emoji")
+ (version "3.4.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url (string-append "https://github.com/Mange/" name "/"))
+ (commit (string-append "v" version))))
+ (sha256 (base32
+ "0bga0gj948l2xpril7gklm78ngs4l50g44k3iwrmw1sg5din0y34"))))
+ (build-system gnu-build-system)
+ (arguments (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'provide-output-instead-of-rofi
+ (lambda _
+ (substitute* "configure.ac"
+ (("\\[rofi_PLUGIN_INSTALL_DIR]=\".*")
+ (string-append "[rofi_PLUGIN_INSTALL_DIR]=\""
+ #$output
+ "/lib/rofi/\"\n")))))
+ (add-after 'provide-output-instead-of-rofi
+ 'patch-adapter-script-xdotool
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "clipboard-adapter.sh"
+ (("xdotool")
+ (search-input-file inputs "/bin/xdotool"))))))))
+ (native-inputs (list autoconf automake libtool pkg-config))
+ (inputs (list glib cairo xdotool))
+ (propagated-inputs (list rofi))
+ (synopsis "Emoji-selector plugin for Rofi")
+ (description "@code{rofi-emoji} is an emoji-selector plugin for Rofi that
+copies the selected emoji to the clipboard and can insert it into the current
+program window.")
+ (home-page "https://github.com/Mange/rofi-emoji")
+ (license license:expat)))
+
(define-public tint2
(package
(name "tint2")
--
2.45.2
W
W
Wamm K. D. wrote on 7 Aug 02:04 +0200
[PATCH] Add: rofi-emoji-wayland.
(address . 72500@debbugs.gnu.org)(name . Wamm K. D.)(address . jaft.r@outlook.com)
MW4PR84MB137110798C5D602AD4F087AA99B82@MW4PR84MB1371.NAMPRD84.PROD.OUTLOOK.COM
* gnu/packages/xdisorg.scm (rofi-emoji-wayland): New variable.
---
gnu/packages/xdisorg.scm | 19 +++++++++++++++++++
1 file changed, 19 insertions(+)

Toggle diff (32 lines)
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index bb95304a1f..cfcccb3e81 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -2139,6 +2139,25 @@ (define-public rofi-emoji
(home-page "https://github.com/Mange/rofi-emoji")
(license license:expat)))
+(define-public rofi-emoji-wayland
+ (package/inherit rofi-emoji
+ (name "rofi-emoji-wayland")
+ (arguments (substitute-keyword-arguments (package-arguments rofi-emoji)
+ ((#:phases phases)
+ #~(modify-phases #$phases
+ (replace 'patch-adapter-script-xdotool
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "clipboard-adapter.sh"
+ (("wtype") (search-input-file inputs
+ "/bin/wtype")))))))))
+ (inputs (modify-inputs (package-inputs rofi-emoji)
+ (replace "xdotool" wtype)))
+ (propagated-inputs (modify-inputs (package-propagated-inputs rofi-emoji)
+ (replace "rofi" rofi-wayland)))
+ (description (string-append
+ (package-description rofi-pass)
+ "\nThis package provides Wayland support by default."))))
+
(define-public tint2
(package
(name "tint2")
--
2.45.2
J
(name . 72500@debbugs.gnu.org)(address . 72500@debbugs.gnu.org)
MW4PR84MB1371821CA6791B5690B0679199B82@MW4PR84MB1371.NAMPRD84.PROD.OUTLOOK.COM
Sending these both to the same bug since the Wayland version depends on the first patch.
I don't think they're so drastically different as to require two separate issue numbers but let me know if that's preferred and I can open a new one for this patch.
On Tuesday, August 6, 2024 at 07:05:04 PM CDT, Wamm K. D. <jaft.r@outlook.com> wrote:
* gnu/packages/xdisorg.scm (rofi-emoji-wayland): New variable.
---
gnu/packages/xdisorg.scm | 19 +++++++++++++++++++
1 file changed, 19 insertions(+)

Toggle diff (32 lines)
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index bb95304a1f..cfcccb3e81 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -2139,6 +2139,25 @@ (define-public rofi-emoji
    (home-page "https://github.com/Mange/rofi-emoji")
    (license license:expat)))
+(define-public rofi-emoji-wayland
+  (package/inherit rofi-emoji
+    (name "rofi-emoji-wayland")
+    (arguments (substitute-keyword-arguments (package-arguments rofi-emoji)
+                ((#:phases phases)
+                  #~(modify-phases #$phases
+                      (replace 'patch-adapter-script-xdotool
+                        (lambda* (#:key inputs #:allow-other-keys)
+                          (substitute* "clipboard-adapter.sh"
+                            (("wtype") (search-input-file inputs
+                                                          "/bin/wtype")))))))))
+  (inputs (modify-inputs (package-inputs rofi-emoji)
+            (replace "xdotool" wtype)))
+  (propagated-inputs (modify-inputs (package-propagated-inputs rofi-emoji)
+                      (replace "rofi" rofi-wayland)))
+  (description (string-append
+                (package-description rofi-pass)
+                "\nThis package provides Wayland support by default."))))
+
(define-public tint2
  (package
    (name "tint2")
--
2.45.2
Attachment: file
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 72500@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 72500
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch