(address . guix-patches@gnu.org)(name . Wamm K. D.)(address . jaft.r@outlook.com)
* gnu/packages/xdisorg.scm (rofi-emoji): New variable.
---
gnu/packages/xdisorg.scm | 39 ++++++++++++++++++++++++++++++++++++++-
1 file changed, 38 insertions(+), 1 deletion(-)
Toggle diff (59 lines)
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 4c12835b24..bb95304a1f 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -55,7 +55,7 @@
;;; Copyright © 2022 John Kehayias <john.kehayias@protonmail.com>
;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
;;; Copyright © 2022 Derek Chuank <derekchuank@outlook.com>
-;;; Copyright © 2022, 2023 Wamm K. D. <jaft.r@outlook.com>
+;;; Copyright © 2022, 2023, 2024 Wamm K. D. <jaft.r@outlook.com>
;;; Copyright © 2022 Tobias Kortkamp <tobias.kortkamp@gmail.com>
;;; Copyright © 2023 Yovan Naumovski <yovan@gorski.stream>
;;; Copyright © 2023 Jake Leporte <jakeleporte@outlook.com>
@@ -2102,6 +2102,43 @@ (define-public rofi-calc
natural language input and provide results.")
(license license:expat)))
+(define-public rofi-emoji
+ (package
+ (name "rofi-emoji")
+ (version "3.4.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url (string-append "https://github.com/Mange/" name "/"))
+ (commit (string-append "v" version))))
+ (sha256 (base32
+ "0bga0gj948l2xpril7gklm78ngs4l50g44k3iwrmw1sg5din0y34"))))
+ (build-system gnu-build-system)
+ (arguments (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'provide-output-instead-of-rofi
+ (lambda _
+ (substitute* "configure.ac"
+ (("\\[rofi_PLUGIN_INSTALL_DIR]=\".*")
+ (string-append "[rofi_PLUGIN_INSTALL_DIR]=\""
+ #$output
+ "/lib/rofi/\"\n")))))
+ (add-after 'provide-output-instead-of-rofi
+ 'patch-adapter-script-xdotool
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "clipboard-adapter.sh"
+ (("xdotool")
+ (search-input-file inputs "/bin/xdotool"))))))))
+ (native-inputs (list autoconf automake libtool pkg-config))
+ (inputs (list glib cairo xdotool))
+ (propagated-inputs (list rofi))
+ (synopsis "Emoji-selector plugin for Rofi")
+ (description "@code{rofi-emoji} is an emoji-selector plugin for Rofi that
+copies the selected emoji to the clipboard and can insert it into the current
+program window.")
+ (home-page "https://github.com/Mange/rofi-emoji")
+ (license license:expat)))
+
(define-public tint2
(package
(name "tint2")
--
2.45.2