[PATCH] gnu: podman: Update to 5.2.0.

  • Done
  • quality assurance status badge
Details
One participant
  • Tomas Volf
Owner
unassigned
Submitted by
Tomas Volf
Severity
normal

Debbugs page

Tomas Volf wrote 7 months ago
(address . guix-patches@gnu.org)(name . Tomas Volf)(address . ~@wolfsden.cz)
e2f52571d9d5cb60bf8d6822f8871d3ed555b9e3.1722972159.git.~@wolfsden.cz
Podman now requires the new kernel mount API, introducing a dependency on
Linux Kernel v5.2 or higher.

* gnu/packages/containers.scm (podman): Update to 5.2.0.

Change-Id: I5e4f2834aef1f5f390321863181ffd7cae236da3
---
gnu/packages/containers.scm | 8 +++++---
1 file changed, 5 insertions(+), 3 deletions(-)

Toggle diff (37 lines)
diff --git a/gnu/packages/containers.scm b/gnu/packages/containers.scm
index f56bbc1567..a9d6c1afdf 100644
--- a/gnu/packages/containers.scm
+++ b/gnu/packages/containers.scm
@@ -464,7 +464,7 @@ (define-public catatonit
(define-public podman
(package
(name "podman")
- (version "5.1.2")
+ (version "5.2.0")
(source
(origin
(method git-fetch)
@@ -472,7 +472,7 @@ (define-public podman
(url "https://github.com/containers/podman")
(commit (string-append "v" version))))
(sha256
- (base32 "1v0qqzfl0nqkqmqimv89nrggb7n1ryhqpdi8v7yn2c7m0dm8xq91"))
+ (base32 "1gza3fbwij4qjblrjx0gg7i4h12kkacws3hi3bsifmscxcwnpgs5"))
(file-name (git-file-name name version))))
(build-system gnu-build-system)
(arguments
@@ -572,7 +572,9 @@ (define-public podman
@code{docker-compose} packages.
To get @code{podman machine} working, install @code{qemu-minimal}, and
-@code{openssh} packages.")
+@code{openssh} packages.
+
+Requires kernel version >= 5.2.")
(license license:asl2.0)))
(define-public podman-compose

base-commit: fe7cadd7998bf0f7fc3825a5097d0815a9abe871
--
2.45.2
Tomas Volf wrote 7 months ago
control message for bug #72498
(address . control@debbugs.gnu.org)
bc316de4b4d61ff73db30c8efb46805b@wolfsden.cz
close 72498
quit
?
Your comment

This issue is archived.

To comment on this conversation send an email to 72498@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 72498
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help