[PATCH] gnu: Add onigmo.

  • Open
  • quality assurance status badge
Details
One participant
  • gemmaro
Owner
unassigned
Submitted by
gemmaro
Severity
normal
G
G
gemmaro wrote on 6 Aug 12:42 +0200
(address . guix-patches@gnu.org)(name . gemmaro)(address . gemmaro.dev@gmail.com)
e9458fcd94ed43d7d22965df8af528bb974d6ac8.1722940968.git.gemmaro.dev@gmail.com
* gnu/packages/textutils.scm (onigmo): New variable.

Change-Id: I7f21f549ec6aff0daf580f441a23dd91be1bb860
---
gnu/packages/textutils.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index 7deea364d8..55b2e7d676 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -590,6 +590,35 @@ (define-public pfff
as existing hashing techniques, with provably negligible risk of collisions.")
(license license:bsd-3)))
+(define-public onigmo
+ (package
+ (name "onigmo")
+ (version "6.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/k-takata/Onigmo")
+ (commit (string-append "Onigmo-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0m6z61w8b4y8yk63sj9q8jm8a2v4ncrx258k96bn71nmji7rjnq3"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'check 'check-python
+ (lambda _
+ (invoke "make" "pytest"))))))
+ (native-inputs (list autoconf automake libtool ruby python-2))
+ (home-page "https://github.com/k-takata/Onigmo")
+ (synopsis "Regular expression library forked from Oniguruma")
+ (description
+ "Onigmo is a regular expression library forked from Oniguruma. It
+focuses to support new expressions like @code{\\K}, @code{\\R},
+@code{(?(cond)yes|no)} and so on.")
+ (license license:bsd-2)))
+
(define-public oniguruma
(package
(name "oniguruma")

base-commit: 6689a96ce86497299bd29f183b744116fd2d6e32
--
2.45.2
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 72493@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 72493
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch