Kaelyn Takata wrote 7 months ago
(address . guix-patches@gnu.org)(name . Kaelyn Takata)(address . kaelyn.alexi@protonmail.com)
* gnu/packages/inkscape.scm (inkscape): Fix build on i686.
Change-Id: Id4b11ac7aa725a8a55d04bca221319201e488940
---
gnu/packages/inkscape.scm | 21 ++++++++++++++++-----
1 file changed, 16 insertions(+), 5 deletions(-)
Toggle diff (50 lines)
diff --git a/gnu/packages/inkscape.scm b/gnu/packages/inkscape.scm
index 8d8dac4fa8..224caa34cf 100644
--- a/gnu/packages/inkscape.scm
+++ b/gnu/packages/inkscape.scm
@@ -204,6 +204,13 @@ (define-public inkscape/stable
(("add_pdfinput_test\\(font-(spacing|style) 1 draw-all" all)
(string-append "#" all))))))
'())
+ #$@(if (target-x86-32?)
+ '((add-after 'unpack 'fix-32bit-size_t-format
+ (lambda _
+ ;; Fix an error due to format type mismatch with 32-bit size_t.
+ (substitute* "testfiles/src/visual-bounds-test.cpp"
+ (("%lu") "%u")))))
+ '())
(add-after 'unpack 'set-home
;; Mute Inkscape warnings during tests.
(lambda _
@@ -239,7 +246,15 @@ (define-public inkscape/stable
"cli_export-ps-level_3_check_output"
"cli_export-ps-level_3_content_check_output"
"cli_export-ps-level_2_content_check_output"
- "cli_export-ps-level_2_check_output")))
+ "cli_export-ps-level_2_check_output"
+ ;; These fail on i686 but not x86-64
+ #$@(if (target-x86-32?)
+ '("cli_pdfinput-font-spacing_check_output"
+ "cli_pdfinput-font-style_check_output"
+ "cli_pdfinput-latex_check_output"
+ "cli_pdfinput-multi-page-sample_check_output"
+ "test_lpe")
+ '()))))
(invoke "make" "-j" job-count "tests")
(invoke "ctest" "-j" job-count
"--output-on-error"
@@ -340,10 +355,6 @@ (define-public inkscape
#~(delete "-DWITH_IMAGE_MAGICK=OFF" #$flags))
((#:phases phases)
#~(modify-phases #$phases
- (replace 'check
- ;; Re-instate the tests disabled in inskcape/stable, now that
- ;; their ImageMagick requirement is satisfied.
- (assoc-ref %standard-phases 'check))
(replace 'wrap-program
;; Ensure Python is available at runtime.
(lambda _
base-commit: baad95b19a24401cad8bee7290e5dbf3b3f38287
--
2.45.2