[PATCH] Add r_numero

  • Open
  • quality assurance status badge
Details
One participant
  • Tor-björn Claesson
Owner
unassigned
Submitted by
Tor-björn Claesson
Severity
normal
T
T
Tor-björn Claesson wrote on 4 Aug 13:36 +0200
87zfpstt8p.fsf@gmail.com
Hello team R!

Please find attached a patch to add the Numero package from CRAN.

The resulting built package contains some javascript, but I think this is specific to
Numeros drawing of cluster maps, and not something that could be packaged
as an external dependency.
I'm happy to submit this to guix-science instead, if this is a problem.

Best regards,
Tor-björn Claesson
From a17c17e88aed7667e7c68529fffaaaa3b27c0e5c Mon Sep 17 00:00:00 2001
From: Torb <tclaesson@gmail.com>
Date: Sun, 4 Aug 2024 14:15:36 +0300
Subject: [PATCH] gnu: Add r-numero.

* gnu/packages/cran.scm (r-numero): New variable.

Change-Id: I35c4f5505cfd19037788b6bc1a1f24ad8a4b5cac
---
gnu/packages/cran.scm | 24 +++++++++++++++++++++++-
1 file changed, 23 insertions(+), 1 deletion(-)

Toggle diff (51 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 32ee25e1ae..d6e251ab01 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -38,6 +38,7 @@
;;; Copyright © 2022-2024 Navid Afkhami <navid.afkhami@mdc-berlin.de>
;;; Copyright © 2022 Greg Hogan <code@greghogan.com>
;;; Copyright © 2024 Marco Baggio <guix@mawumag.com>
+;;; Copyright © 2024 Tor-björn Claesson <tclaesson@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -98,7 +99,7 @@ (define-module (gnu packages cran)
#:use-module (gnu packages pdf)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
- #:use-module (gnu packages pulseaudio) ;libsndfile
+ #:use-module (gnu packages pulseaudio) ;libsndfile
#:use-module (gnu packages protobuf)
#:use-module (gnu packages python)
#:use-module (gnu packages python-xyz)
@@ -1551,6 +1552,27 @@ (define-public r-googlesheets4
can read and write both the metadata and the cell data in a Sheet.")
(license license:expat)))
+(define-public r-numero
+ (package
+ (name "r-numero")
+ (version "1.9.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "Numero" version))
+ (sha256
+ (base32 "04pf6x7qmgkfyj98c23maxcvlwwwfw6jas7l72xp0713lyndjl15"))))
+ (build-system r-build-system)
+ (propagated-inputs (list r-rcpp))
+ (native-inputs (list r-knitr r-rmarkdown))
+ (home-page "https://cran.r-project.org/package=Numero")
+ (synopsis "Statistical framework to define subgroups in complex datasets")
+ (description
+ "The package includes the necessary functions to construct
+a self-organizing map of data, to evaluate the statistical signifcance of the
+observed data patterns, and to visualize the results.")
+ (license license:gpl2+)))
+
(define-public r-pma
(package
(name "r-pma")
--
2.45.2
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 72459@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 72459
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch