[PATCH] gnu: Add guile-web-driver-ng.

  • Done
  • quality assurance status badge
Details
3 participants
  • Andreas Enge
  • Nicolas Graves
  • Artyom V. Poptsov
Owner
unassigned
Submitted by
Artyom V. Poptsov
Severity
normal

Debbugs page

Artyom V. Poptsov wrote 7 months ago
(address . guix-patches@gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
335a5330f725ed94944eee6238f406932212ceb4.1722712264.git.poptsov.artyom@gmail.com
* gnu/packages/guile-xyz.scm (guile-web-driver-ng): New variable.

Change-Id: I97f979ccbfe1d9f4e43b7f9a5730e092e36129a0
---
gnu/packages/guile-xyz.scm | 44 ++++++++++++++++++++++++++++++++++++++
1 file changed, 44 insertions(+)

Toggle diff (59 lines)
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 3ce4f6a8d6..29b2f40968 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -4914,6 +4914,50 @@ (define-public guile2.2-webutils
(propagated-inputs
(list guile2.2-irregex guile2.2-gcrypt))))
+(define-public guile-web-driver-ng
+ (package
+ (name "guile-web-driver-ng")
+ (version "1.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/artyom-poptsov/guile-web-driver-ng")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0saljgf3kj3p9b1mk5211s8np2vwkzf072xp6j2xnc10vdn891ja"))))
+ (build-system gnu-build-system)
+ (native-inputs (list autoconf
+ automake
+ pkg-config
+ texinfo
+ ;; needed when cross-compiling.
+ guile-lib
+ guile-json-4
+ guile-gnutls
+ guile-3.0))
+ (propagated-inputs (list guile-json-4 guile-gnutls guile-lib guile-3.0
+ inetutils))
+ (arguments
+ (list
+ #:phases #~(modify-phases %standard-phases
+ (delete 'strip))))
+ (home-page "https://github.com/artyom-poptsov/guile-web-driver-ng")
+ (synopsis "Web driver (Selenium) client for Guile")
+ (description
+ "This is a web-driver, or Selenium 2, client. It's purpose is to automate
+browsers, specifically for automatic web server testing. Chrome or Firefox can be
+used as the automated browsers, or it can connect to arbitrary server providing
+webdriver interface. The client implements most of the WebDriver
+@url{https://www.w3.org/TR/webdriver2/, specification}.
+
+@code{guile-web-driver-ng} also provides a proxy implemented as a Guile module. If
+configured, the proxy can intercept and modify HTTP/HTTPS traffic (for example, add,
+delete and replace HTTP headers) which is useful for Selenium WebDriver as it does
+not provide a way to change the headers on its own.")
+ (license license:gpl3+)))
+
(define-public guile-lens
(let ((commit "14b15d07255f9d3f55d40a3b750d13c9ee3a154f")
(revision "0"))

base-commit: b20956651a53a8f23828fdeb6945e1a31e6997a8
--
2.45.2
Nicolas Graves wrote 7 months ago
QA review for 72449
875xs1ets2.fsf@ngraves.fr
user guix
usertag 72449 + reviewed-looks-good
thanks

Guix QA review form submission:
LGTM.

Items marked as checked: Lint warnings, Package builds, Commit messages, New package licenses, New package tests, New package synopsis and descriptions

--
Best regards,
Nicolas Graves
Andreas Enge wrote 7 months ago
Close
(address . 72449-done@debbugs.gnu.org)
ZscOxTNG-sd4uekK@jurong
Thanks for the patch and the review, I have just pushed it.

Andreas
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 72449@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 72449
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help