Hi Nicolas,
On Sun, 04 Aug 2024 05:04:37 +0800,
Nicolas Graves via Guix-patches via wrote:
Toggle quote (33 lines)
>
> * gnu/packages/python-xyz.scm (python-pyclibrary): New variable.
>
> Change-Id: Ib4d1bf9f265fc1935c432d8e4ed3e9704f03ba70
> ---
> gnu/packages/python-xyz.scm | 26 ++++++++++++++++++++++++++
> 1 file changed, 26 insertions(+)
>
> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
> index d09c16b73e..9dc941ca84 100644
> --- a/gnu/packages/python-xyz.scm
> +++ b/gnu/packages/python-xyz.scm
> @@ -25937,6 +25937,32 @@ (define-public python-setuptools-rust
> Rust Python extensions implemented with @code{PyO3} or @code{rust-cpython}.")
> (license license:expat)))
>
> +(define-public python-pyclibrary
> + (package
> + (name "python-pyclibrary")
> + (version "0.2.2")
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/MatthieuDartiailh/pyclibrary")
> + (commit version)))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32 "0scnfk0dr8za1m7k1ml74dr8sg570sgs3hmis7fl27s2h1dbsapk"))))
> + (build-system pyproject-build-system)
> + (arguments
> + (list #:tests? #f)) ; XXX: 1/3rd of tests are failing, find out why.
Can you find out why these tests are failing? From the output it looks serious
to me.
Toggle quote (16 lines)
> + (native-inputs (list python-pytest))
> + (propagated-inputs (list python-pyparsing-2.4.7))
> + (home-page "http://github.com/MatthieuDartiailh/pyclibrary")
> + (synopsis "Wrap dynamic libraries in Python")
> + (description "This package provides a library to make wrapping dynamic
> +libraries in Python less cumbersome and more user friendly. It includes a
> +pure-Python C parser and an automation library that uses C header file
> +definitions to simplify the use of C bindings.")
> + (license license:expat)))
> +
> (define-public python-pyclipper
> (package
> (name "python-pyclipper")
> --
> 2.45.2