[PATCH 0/2] Add dlpack, python-pyclibrary.

  • Open
  • quality assurance status badge
Details
One participant
  • Nicolas Graves
Owner
unassigned
Submitted by
Nicolas Graves
Severity
normal
N
N
Nicolas Graves wrote on 3 Aug 01:13 +0200
(address . guix-patches@gnu.org)(address . ngraves@ngraves.fr)
20240802231617.8650-1-ngraves@ngraves.fr
These packages are used in the following pull request in nonguix:

Nicolas Graves (2):
gnu: Add dlpack.
gnu: Add python-pyclibrary.

gnu/packages/machine-learning.scm | 34 +++++++++++++++++++++++++++++++
gnu/packages/python-xyz.scm | 26 +++++++++++++++++++++++
2 files changed, 60 insertions(+)

--
2.45.2
N
N
Nicolas Graves wrote on 3 Aug 23:04 +0200
[PATCH 1/2] gnu: Add dlpack.
(address . 72432@debbugs.gnu.org)(address . ngraves@ngraves.fr)
20240803210441.7297-1-ngraves@ngraves.fr
* gnu/packages/machine-learning.scm (dlpack): New variable.

Change-Id: I9223e5c3b8f8317f88954cfdaccdfa11a51b7167
---
gnu/packages/machine-learning.scm | 34 +++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 4c5b713cbf..600e111594 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -133,6 +133,40 @@ (define-module (gnu packages machine-learning)
#:use-module (gnu packages xorg)
#:use-module (ice-9 match))
+(define-public dlpack
+ (package
+ (name "dlpack")
+ (version "0.8")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dmlc/dlpack")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1jmfvdrx8dn9b0ksm04ixha0jnrk35ip796qg98kfz6g7niw5ir1"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:tests? #f)) ; no tests.
+ (home-page "https://github.com/dmlc/dlpack")
+ (synopsis "In Memory Tensor Structure")
+ (description "This package provides an open in-memory tensor structure for
+sharing tensors among frameworks. DLPack enables
+@itemize
+@item Easier sharing of operators between deep learning frameworks.
+@item Easier wrapping of vendor level operator implementations, allowing
+collaboration when introducing new devices/ops.
+@item Quick swapping of backend implementations, like different version of
+BLAS
+@item For final users,this could bring more operators, and possibility of
+mixing usage between frameworks.
+@end itemize
+
+This package does not intend to implement Tensor and Ops, but instead use this
+as common bridge to reuse tensor and ops across frameworks.")
+ (license license:asl2.0)))
+
(define-public fasttext
(package
(name "fasttext")
--
2.45.2
N
N
Nicolas Graves wrote on 3 Aug 23:04 +0200
[PATCH 2/2] gnu: Add python-pyclibrary.
(address . 72432@debbugs.gnu.org)(address . ngraves@ngraves.fr)
20240803210441.7297-2-ngraves@ngraves.fr
* gnu/packages/python-xyz.scm (python-pyclibrary): New variable.

Change-Id: Ib4d1bf9f265fc1935c432d8e4ed3e9704f03ba70
---
gnu/packages/python-xyz.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d09c16b73e..9dc941ca84 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -25937,6 +25937,32 @@ (define-public python-setuptools-rust
Rust Python extensions implemented with @code{PyO3} or @code{rust-cpython}.")
(license license:expat)))
+(define-public python-pyclibrary
+ (package
+ (name "python-pyclibrary")
+ (version "0.2.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/MatthieuDartiailh/pyclibrary")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0scnfk0dr8za1m7k1ml74dr8sg570sgs3hmis7fl27s2h1dbsapk"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list #:tests? #f)) ; XXX: 1/3rd of tests are failing, find out why.
+ (native-inputs (list python-pytest))
+ (propagated-inputs (list python-pyparsing-2.4.7))
+ (home-page "http://github.com/MatthieuDartiailh/pyclibrary")
+ (synopsis "Wrap dynamic libraries in Python")
+ (description "This package provides a library to make wrapping dynamic
+libraries in Python less cumbersome and more user friendly. It includes a
+pure-Python C parser and an automation library that uses C header file
+definitions to simplify the use of C bindings.")
+ (license license:expat)))
+
(define-public python-pyclipper
(package
(name "python-pyclipper")
--
2.45.2
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 72432@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 72432
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch