[PATCH] gnu: easyeffects: Update to 7.1.7

  • Done
  • quality assurance status badge
Details
2 participants
  • Christopher Baines
  • Nikita Domnitskii
Owner
unassigned
Submitted by
Nikita Domnitskii
Severity
normal

Debbugs page

Nikita Domnitskii wrote 7 months ago
(address . guix-patches@gnu.org)
9feebd35a00c09dff292472fd22b1dfd03daf78b.1722613882.git.nikita@domnitskii.me
---
gnu/packages/audio.scm | 20 +++++++++++---------
1 file changed, 11 insertions(+), 9 deletions(-)

Toggle diff (65 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index b728220e1f..1e27777459 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -47,6 +47,7 @@
;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2023 Parnikkapore <poomklao@yahoo.com>
;;; Copyright © 2024 hapster <o.rojon@posteo.net>
+;;; Copyright © 2024 Nikita Domnitskii <nikita@domnitskii.me>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -6540,7 +6541,7 @@ (define-public cubeb
(define-public easyeffects
(package
(name "easyeffects")
- (version "7.0.1") ; later version require gtk 4.10
+ (version "7.1.7")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -6548,10 +6549,11 @@ (define-public easyeffects
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0c49yd4dfh7qarq5h651dgxdbs71is4pp1sl8r0gfswqji6bv39w"))))
+ (base32 "19r8pzlhdn7jp7lggxv3c74xbr48hwmz234rl600fnqhygpixg6b"))))
(build-system meson-build-system)
(native-inputs
(list `(,glib "bin") ;for glib-compile-resources
+ gcc-12 ; fails to build with gcc-11
gettext-minimal
itstool
pkg-config))
@@ -6572,19 +6574,19 @@ (define-public easyeffects
pango
pipewire
rnnoise
- speex
speexdsp
tbb
- zita-convolver))
+ zita-convolver
+ soundtouch))
;; Propagating these allows EasyEffects to find the plugins via their
;; search-path specification
(propagated-inputs
- (list calf
- lsp-plugins
- lv2
+ (list lv2
+ calf
+ `(,lsp-plugins "lv2")
mda-lv2
- rubberband
- zam-plugins))
+ zam-plugins
+ ladspa))
(arguments
`(#:glib-or-gtk? #t
#:phases

--
Best Regards,
Nikita Domnitskii
Christopher Baines wrote 7 months ago
(name . Nikita Domnitskii via Guix-patches via)(address . guix-patches@gnu.org)
87bk1kpyt0.fsf@cbaines.net
Nikita Domnitskii via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (4 lines)
> ---
> gnu/packages/audio.scm | 20 +++++++++++---------
> 1 file changed, 11 insertions(+), 9 deletions(-)

I filled in the commit message and pushed this to master as
e936d8a1d8b16ec19228072de27e9c4dac254598.

Thanks,

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmbHJItfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XcLXQ//Ufb8eQqcyaCGlUOvbBYuJmos5RR9QUB0
v9H54izq7bfhyVxLqcmYZaHcf1koQCvbPoQXsUp7i+nX9atjCd4VdD2uqmM2590U
0+b+9Hijx15GgTA8gcoQPEBlCR2XXldezxQJJcGP4jL7bVu0FRDagEekNV/7jct1
RRbqk8HBsGkvJTMLA7DQZgQruxBLrbjY+ZLkx8j8ObzsMNJwCK7dE3fVye8CpRU8
6JtzTj/c85R0dx4sLM4Q9XyMtFFOwr6tLu4odDtWUuOzn5mEZFMUyY94eAV76niz
2x3dJeoecRO+eG6DGxrv2qNMMyVWS+CJb67FhzZPWaluJ8d+ADowyolhfYn6Ez+y
WXR1EgBYc47Ys9Ql3kENe20S3PipZEnzIRs0P7ZiYR0u85vvrnWfFQVkhJUQPwhT
IhDsGhi3xvL+5exIbrr3EZsYyeQhQ0LBqqoPn62f7l64JE7bQxu9u2QOHp25hUaA
ci9lmRgJkTpdmjsrW6kvxjuyWMeFhjd3W+m5yuD6dMa+TCzET11FTtmifM/8cBlF
LAgiJBbEA0Uai+Ai/bM7KWKpyZKrD5Fr89NBoOSvRUibUhc5wcWjM1hAepSGf2PI
eAH+s6ZGSzwfak9y8lXY3h0T1HNCOQBVqUQoWcAu+R2gF7jCuUI6jIRRofPAy2co
PO8X0XrCX5M=
=CkJ8
-----END PGP SIGNATURE-----

?
Your comment

This issue is archived.

To comment on this conversation send an email to 72424@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 72424
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help