[PATCH] gnu: stress-ng: Don't stress test when building for riscv64-linux.

  • Done
  • quality assurance status badge
Details
One participant
  • Christopher Baines
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal

Debbugs page

Christopher Baines wrote 7 months ago
(address . guix-patches@gnu.org)
956fbdbc94316ecf38291152781775c8c81fc11c.1722592299.git.mail@cbaines.net
As this seems to cause instability on the VisionFive 2 systems at least.

* gnu/packages/admin.scm (stress-ng)[arguments]: Set #:tests? to #f on
riscv64.

Change-Id: I0d7f3081793e1a286cf2644e9218516c9fda56d5
---
gnu/packages/admin.scm | 6 +++++-
1 file changed, 5 insertions(+), 1 deletion(-)

Toggle diff (21 lines)
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 113b8e2481..51e1085e9f 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -2593,7 +2593,11 @@ (define-public stress-ng
(base32 "1z9vjn2131iv3pwrh04z6r5ygi1qgad5bi3jhghcvc3v1b4k5ran"))))
(build-system gnu-build-system)
(arguments
- (list #:make-flags
+ ;; XXX The test suite seems to cause instability on the VisionFive 2
+ ;; build machines, maybe it's stressing them as intended but this is
+ ;; unhelpful
+ (list #:tests? (not (target-riscv64?))
+ #:make-flags
#~(list (string-append "CC=" #$(cc-for-target))
(string-append "BINDIR=" #$output "/bin")
;; XXX Really: MAN1DIR, or man pages won't be found.

base-commit: 56d3d04a442b52097e523dcfebf60ff5bf82bcfd
--
2.45.2
Christopher Baines wrote 7 months ago
(address . 72418-done@debbugs.gnu.org)
877ccnz6tk.fsf@cbaines.net
Christopher Baines <mail@cbaines.net> writes:

Toggle quote (10 lines)
> As this seems to cause instability on the VisionFive 2 systems at least.
>
> * gnu/packages/admin.scm (stress-ng)[arguments]: Set #:tests? to #f on
> riscv64.
>
> Change-Id: I0d7f3081793e1a286cf2644e9218516c9fda56d5
> ---
> gnu/packages/admin.scm | 6 +++++-
> 1 file changed, 5 insertions(+), 1 deletion(-)

Pushed to master as 7ad2bf9ded3ba14c355a67a03fda664fa3f97db4.
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAma4k7dfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9Xe0xg//TckV3s6SeizWqBQ3wUjICiOaXu4GHAMv
GTCGoeJvZnUFLlb0hGfmf2IS9XI/PEJWAh0Qg5IgAWexQ8Jj97vYErOKg8/RqTng
ZY1LQdIohtjACeh4xfN7O22YrNO0ssyV0eWqPbhecr2A7rCGtVTXqd5YSvhAwt/l
0KiyEbLz8DEiHJsOLpI1z7fRaeSv/O6phwwRxiWLXloaYjKFBHxlarVcaKddqR9M
TFL/NEW9aSV0R0u6SmAVohSUpux/TnblYdTLgqGGwZG5g02JtTM8foN+Zb+paTOP
NUykN0dRdOfzuMGWjDKoNGA6a1EYoJDUtCmCXaThHEqI6I7NVEnGxRT+jZ0WjfgA
EfU/qTzOLERqxfLofAOaUUqD4ukni+NnosI/HHORyx9EYR61B2uhNB7XhsS5myxa
DESnDz58Onk3c63kCnGdaWZOxBnXx8b1rXRZULYDesC9CgdlJZ/1RYdN6cZQq6Kg
t6gHYrnSaTAjp+VhUt7YA7BiLPREYAHpubkY2CM+mrcVXzx1Qs6ayxIt7dOCiui+
pJO3HE33Ke9SoAReDYe/ErmalclUDTCGN2PvtpQgn3I0GV3STMn/BHTInjF5Ii32
b2g+OqID4+9id3BnY8nyMLJ9nnD2hrrwnU9DOdeiY6ERnI5SvLNyw8ll0BSVbJwH
RchaeCRqAlo=
=eXrt
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 72418@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 72418
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help