Christopher Baines wrote 7 months ago
(address . guix-patches@gnu.org)
As this seems to cause instability on the VisionFive 2 systems at least.
* gnu/packages/admin.scm (stress-ng)[arguments]: Set #:tests? to #f on
riscv64.
Change-Id: I0d7f3081793e1a286cf2644e9218516c9fda56d5
---
gnu/packages/admin.scm | 6 +++++-
1 file changed, 5 insertions(+), 1 deletion(-)
Toggle diff (21 lines)
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 113b8e2481..51e1085e9f 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -2593,7 +2593,11 @@ (define-public stress-ng
(base32 "1z9vjn2131iv3pwrh04z6r5ygi1qgad5bi3jhghcvc3v1b4k5ran"))))
(build-system gnu-build-system)
(arguments
- (list #:make-flags
+ ;; XXX The test suite seems to cause instability on the VisionFive 2
+ ;; build machines, maybe it's stressing them as intended but this is
+ ;; unhelpful
+ (list #:tests? (not (target-riscv64?))
+ #:make-flags
#~(list (string-append "CC=" #$(cc-for-target))
(string-append "BINDIR=" #$output "/bin")
;; XXX Really: MAN1DIR, or man pages won't be found.
base-commit: 56d3d04a442b52097e523dcfebf60ff5bf82bcfd
--
2.45.2