[PATCH] gnu: git: Update to 2.46.0.

  • Done
  • quality assurance status badge
Details
2 participants
  • ashish.is
  • Simon Tournier
Owner
unassigned
Submitted by
ashish.is
Severity
normal
A
A
ashish.is wrote on 1 Aug 22:43 +0200
(address . guix-patches@gnu.org)(name . Ashish SHUKLA)(address . ashish.is@lostca.se)
9fd24d24fe7fb757b5cbaada596ebfaa4d0bf8ab.1722545003.git.ashish.is@lostca.se
From: Ashish SHUKLA <ashish.is@lostca.se>

* gnu/packages/version-control.scm (git): Update to 2.46.0.

Change-Id: I5fec92073d4f3ec0edb9686cca0c3696d9e338ef
---
gnu/packages/version-control.scm | 7 ++++---
1 file changed, 4 insertions(+), 3 deletions(-)

Toggle diff (42 lines)
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 9f67237d5d..5e9cc8cf59 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -53,6 +53,7 @@
;;; Copyright © 2023 Josselin Poiret <dev@jpoiret.xyz>
;;; Copyright © 2024 Hilton Chain <hako@ultrarare.space>
;;; Copyright © 2024 Suhail Singh <suhail@bayesians.ca>
+;;; Copyright © 2024 Ashish SHUKLA <ashish.is@lostca.se>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -243,14 +244,14 @@ (define git-cross-configure-flags
(define-public git
(package
(name "git")
- (version "2.45.2")
+ (version "2.46.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://kernel.org/software/scm/git/git-"
version ".tar.xz"))
(sha256
(base32
- "1nws1vjgj54sv32wxl1h3n1jkcpabqv7a605hhafsby0n5zfigsi"))))
+ "15bzq9m6c033qiz5q5gw1nqw4m452vvqax30wbms6z4bl9i384kz"))))
(build-system gnu-build-system)
(native-inputs
`(("native-perl" ,perl)
@@ -270,7 +271,7 @@ (define-public git
version ".tar.xz"))
(sha256
(base32
- "1pqrp46kwbxycqld39027ph1cvkq9am156y3sswn6w2khsg30f09"))))
+ "1lvvhzypllbyd8j6m0p9qgd3gqg10gch9s7lqif8vr9n80fqn4fw"))))
;; For subtree documentation.
("asciidoc" ,asciidoc)
("docbook2x" ,docbook2x)

base-commit: 2b4e3c9847dce02e371ff4dce615789fdfd101fa
--
2.46.0
A
A
ashish.is wrote on 5 Sep 14:40 +0200
[PATCH v2] gnu: git: Update to 2.46.0
(address . 72413@debbugs.gnu.org)(name . Ashish SHUKLA)(address . ashish.is@lostca.se)
06c46998ea7ce45165fe6663868d4aaf883a55f2.1725540023.git.ashish.is@lostca.se
From: Ashish SHUKLA <ashish.is@lostca.se>

* gnu/packages/version-control.scm (git-minimal): Update to 2.46.0.
(git)[arguments]<phases>{install-man-pages} Update hash for the
git-manpages.

Change-Id: I686825ffba828e88e37ff156fab23fd43155d210
---
This revised patch works with current HEAD, esp. with the issue 73034
which fixes git-send-email.

gnu/packages/version-control.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (34 lines)
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 1db783b731..b8aa1ee0da 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -248,14 +248,14 @@ (define git-cross-configure-flags
(define-public git-minimal
(package
(name "git-minimal")
- (version "2.45.2")
+ (version "2.46.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://kernel.org/software/scm/git/git-"
version ".tar.xz"))
(sha256
(base32
- "1nws1vjgj54sv32wxl1h3n1jkcpabqv7a605hhafsby0n5zfigsi"))))
+ "15bzq9m6c033qiz5q5gw1nqw4m452vvqax30wbms6z4bl9i384kz"))))
(build-system gnu-build-system)
(arguments
(list
@@ -692,7 +692,7 @@ (define-public git
".tar.xz"))
(sha256
(base32
- "1pqrp46kwbxycqld39027ph1cvkq9am156y3sswn6w2khsg30f09"))))))))))))
+ "1lvvhzypllbyd8j6m0p9qgd3gqg10gch9s7lqif8vr9n80fqn4fw"))))))))))))
(native-inputs
(modify-inputs (package-native-inputs git-minimal)
;; For subtree documentation.

base-commit: 20b1613484f512649f919d89285e981998592497
--
2.46.0
S
S
Simon Tournier wrote on 5 Sep 17:37 +0200
Re: [bug#72413] [PATCH] gnu: git: Update to 2.46.0.
(name . Ashish SHUKLA)(address . ashish.is@lostca.se)
87r09yi024.fsf@gmail.com
Hi,

On Thu, 01 Aug 2024 at 20:43, "ashish.is--- via Guix-patches" via <guix-patches@gnu.org> wrote:

Toggle quote (2 lines)
> * gnu/packages/version-control.scm (git): Update to 2.46.0.

Closing because part of the version 3 of series #73034 [1].


Cheers,
simon
Closed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 72413@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 72413
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch