(address . guix-patches@gnu.org)
* gnu/packages/xfce.scm (orage) [arguments]: Add fix-tzdata-path phase.
[inputs]: Add tzdata.
Change-Id: I7eee01c931a87ec3fefa157e8ebfa7d794a72757
---
gnu/packages/xfce.scm | 18 +++++++++++++++++-
1 file changed, 17 insertions(+), 1 deletion(-)
Toggle diff (46 lines)
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 825b175140..91ba5ef3cd 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -16,6 +16,7 @@
;;; Copyright © 2020, 2021, 2022 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2021, 2022 Brendan Tildesley <mail@brendan.scot>
;;; Copyright © 2021 André A. Gomes <andremegafone@gmail.com>
+;;; Copyright © 2024 Keisuke Kurosawa <k.kurochan9630@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1369,13 +1370,28 @@ (define-public orage
(base32
"1v5385hps6jgcw1ky9vl7w7iryp0rzxz6s4lx72rz8yg4sdv84v3"))))
(build-system gnu-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-tzdata-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "src/tz_zoneinfo_read.c"
+ (("/usr/share/zoneinfo")
+ (search-input-directory inputs "share/zoneinfo"))))))))
(native-inputs
(list
`(,glib "bin") ; for dbus-binding-tool
intltool
pkg-config))
(inputs
- (list dbus-glib gtk+-2 libical libnotify libxfce4ui popt xfce4-panel))
+ (list tzdata ;; For fix-tzdata-path phase only.
+ dbus-glib
+ gtk+-2
+ libical
+ libnotify
+ libxfce4ui
+ popt
+ xfce4-panel))
(home-page "https://www.xfce.org/projects/")
(synopsis "Simple calendar application with reminders")
(description
base-commit: 01d4363168ed10ea223047f7a7b83201f161ec0b
--
2.45.2