[PATCH] gnu: orage: Fix tzdata path.

  • Open
  • quality assurance status badge
Details
3 participants
  • 宋文武
  • Keisuke Kurosawa
  • Ludovic Courtès
Owner
unassigned
Submitted by
Keisuke Kurosawa
Severity
normal

Debbugs page

Keisuke Kurosawa wrote 7 months ago
(address . guix-patches@gnu.org)
1faeb89b9533528bd88e92fa91cc4c8226f17210.1722495449.git.k.kurochan9630@gmail.com
* gnu/packages/xfce.scm (orage) [arguments]: Add fix-tzdata-path phase.
[inputs]: Add tzdata.

Change-Id: I7eee01c931a87ec3fefa157e8ebfa7d794a72757
---
gnu/packages/xfce.scm | 18 +++++++++++++++++-
1 file changed, 17 insertions(+), 1 deletion(-)

Toggle diff (46 lines)
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 825b175140..91ba5ef3cd 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -16,6 +16,7 @@
;;; Copyright © 2020, 2021, 2022 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2021, 2022 Brendan Tildesley <mail@brendan.scot>
;;; Copyright © 2021 André A. Gomes <andremegafone@gmail.com>
+;;; Copyright © 2024 Keisuke Kurosawa <k.kurochan9630@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1369,13 +1370,28 @@ (define-public orage
(base32
"1v5385hps6jgcw1ky9vl7w7iryp0rzxz6s4lx72rz8yg4sdv84v3"))))
(build-system gnu-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-tzdata-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "src/tz_zoneinfo_read.c"
+ (("/usr/share/zoneinfo")
+ (search-input-directory inputs "share/zoneinfo"))))))))
(native-inputs
(list
`(,glib "bin") ; for dbus-binding-tool
intltool
pkg-config))
(inputs
- (list dbus-glib gtk+-2 libical libnotify libxfce4ui popt xfce4-panel))
+ (list tzdata ;; For fix-tzdata-path phase only.
+ dbus-glib
+ gtk+-2
+ libical
+ libnotify
+ libxfce4ui
+ popt
+ xfce4-panel))
(home-page "https://www.xfce.org/projects/")
(synopsis "Simple calendar application with reminders")
(description

base-commit: 01d4363168ed10ea223047f7a7b83201f161ec0b
--
2.45.2
宋文武 wrote 7 months ago
(name . Keisuke Kurosawa)(address . k.kurochan9630@gmail.com)(name . Zhu Zihao)(address . all_but_last@163.com)(address . 72408@debbugs.gnu.org)
87zfpwpj19.fsf@envs.net
Keisuke Kurosawa <k.kurochan9630@gmail.com> writes:

Toggle quote (33 lines)
> * gnu/packages/xfce.scm (orage) [arguments]: Add fix-tzdata-path phase.
> [inputs]: Add tzdata.
>
> Change-Id: I7eee01c931a87ec3fefa157e8ebfa7d794a72757
> ---
> gnu/packages/xfce.scm | 18 +++++++++++++++++-
> 1 file changed, 17 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
> index 825b175140..91ba5ef3cd 100644
> --- a/gnu/packages/xfce.scm
> +++ b/gnu/packages/xfce.scm
> @@ -16,6 +16,7 @@
> ;;; Copyright © 2020, 2021, 2022 Michael Rohleder <mike@rohleder.de>
> ;;; Copyright © 2021, 2022 Brendan Tildesley <mail@brendan.scot>
> ;;; Copyright © 2021 André A. Gomes <andremegafone@gmail.com>
> +;;; Copyright © 2024 Keisuke Kurosawa <k.kurochan9630@gmail.com>
> ;;;
> ;;; This file is part of GNU Guix.
> ;;;
> @@ -1369,13 +1370,28 @@ (define-public orage
> (base32
> "1v5385hps6jgcw1ky9vl7w7iryp0rzxz6s4lx72rz8yg4sdv84v3"))))
> (build-system gnu-build-system)
> + (arguments
> + (list #:phases
> + #~(modify-phases %standard-phases
> + (add-after 'unpack 'fix-tzdata-path
> + (lambda* (#:key inputs #:allow-other-keys)
> + (substitute* "src/tz_zoneinfo_read.c"
> + (("/usr/share/zoneinfo")
> + (search-input-directory inputs "share/zoneinfo"))))))))

Ideally it should support get it via 'TZDIR' environment variable, since
the tzdata package is updated periodically. Could you give a try for a
patch to use 'TZDIR', which also can be submit to its xfce upstream?

Thanks.
Ludovic Courtès wrote 6 months ago
control message for bug #72408
(address . control@debbugs.gnu.org)
87r09oiyki.fsf@gnu.org
tags 72408 + moreinfo
quit
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 72408@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 72408
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help