[PATCH] gnu: Add fennel-ls.

  • Open
  • quality assurance status badge
Details
3 participants
  • sydney goose
  • Ludovic Courtès
  • Nicolas Graves
Owner
unassigned
Submitted by
sydney goose
Severity
normal
S
S
sydney goose wrote on 31 Jul 08:27 +0200
(address . guix-patches@gnu.org)
CAE0SKk2+oAXBLxr5K3dqUA1y_Tpt9345LtogS8y1EEyBgVc_bQ@mail.gmail.com
* gnu/packages/fennel.scm (fennel-ls): New variable.
Attachment: file
From 00dc141d99539ab9aec01d5adf43b0fafb1f32f4 Mon Sep 17 00:00:00 2001
Message-ID: <00dc141d99539ab9aec01d5adf43b0fafb1f32f4.1722407043.git.lomiskiam@gmail.com>
From: crumbtoo <crumb@duck.com>
Date: Wed, 31 Jul 2024 00:13:52 -0600
Subject: [PATCH] gnu: Add fennel-ls.

* gnu/packages/fennel.scm (fennel-ls): New variable.

Change-Id: Id8a465f2c549f07f014ad9f65af2837e8e18e6d0
---
gnu/packages/lua.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/lua.scm b/gnu/packages/lua.scm
index 1e583b59b3..0be9914e65 100644
--- a/gnu/packages/lua.scm
+++ b/gnu/packages/lua.scm
@@ -1397,6 +1397,37 @@ (define-public fennel
system.")
(license license:expat)))
+(define-public fennel-ls
+ (package
+ (name "fennel-ls")
+ (version "0.1.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://git.sr.ht/~xerool/fennel-ls/archive/"
+ version ".tar.gz"))
+ (sha256
+ (base32 "0nb3yclv9v2mwcnam5djvhg0vgmdsk0gavbvq1ar5v2j0m9pzr7f"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:test-target "test"
+ #:phases #~(modify-phases %standard-phases
+ (delete 'configure)
+ (add-after 'build 'patch-fennel-ls
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "fennel-ls"
+ (("/usr/bin/env .*lua")
+ (search-input-file inputs "/bin/lua"))))))
+ #:make-flags #~(list (string-append "PREFIX="
+ (assoc-ref %outputs "out")))))
+ (inputs (list lua-5.4 fennel))
+ (home-page "https://git.sr.ht/~xerool/fennel-ls")
+ (license license:expat)
+ (synopsis "Provides intelligent editing features for Fennel files")
+ (description "A language server for Fennel. Provides intelligent editing
+features for Fennel files.")))
+
(define-public antifennel
(package
(version "0.2.0")

base-commit: f59c4126827af3d2041d49f1d0a8ce12b41470cf
--
2.45.2
N
N
Nicolas Graves wrote on 15 Aug 16:32 +0200
878qwxeu1q.fsf@ngraves.fr
On 2024-07-31 00:27, sydney goose wrote:

Toggle quote (10 lines)
> * gnu/packages/fennel.scm (fennel-ls): New variable.

> + (source
> + (origin
> + (method url-fetch)
> + (uri (string-append "https://git.sr.ht/~xerool/fennel-ls/archive/"
> + version ".tar.gz"))
> + (sha256
> + (base32 "0nb3yclv9v2mwcnam5djvhg0vgmdsk0gavbvq1ar5v2j0m9pzr7f"))))

Is there a reason why we use archives rather than git fetching here?
Otherwise I would advise against, given the codebase is small.
This would probably also solve the two following lints:

fennel-ls@0.1.3: the source file name should contain the package name
fennel-ls@0.1.3: no updater for fennel-ls

Toggle quote (18 lines)
> + (build-system gnu-build-system)
> + (arguments
> + (list
> + #:test-target "test"
> + #:phases #~(modify-phases %standard-phases
> + (delete 'configure)
> + (add-after 'build 'patch-fennel-ls
> + (lambda* (#:key inputs #:allow-other-keys)
> + (substitute* "fennel-ls"
> + (("/usr/bin/env .*lua")
> + (search-input-file inputs "/bin/lua"))))))
> + #:make-flags #~(list (string-append "PREFIX="
> + (assoc-ref %outputs "out")))))
> + (inputs (list lua-5.4 fennel))
> + (home-page "https://git.sr.ht/~xerool/fennel-ls")
> + (license license:expat)
> + (synopsis "Provides intelligent editing features for Fennel files")

Nitpick/proposition : "A language server for Fennel"

Toggle quote (3 lines)
> + (description "A language server for Fennel. Provides intelligent editing
> +features for Fennel files.")))

Nitpick/proposition : "This package provides a language server for
Fennel that provides intelligent editing features for Fennel files."

Otherwise LGTM. Please send an updated patch ;)

--
Best regards,
Nicolas Graves
L
L
Ludovic Courtès wrote on 28 Aug 16:25 +0200
control message for bug #72397
(address . control@debbugs.gnu.org)
87bk1clo6h.fsf@gnu.org
tags 72397 + moreinfo
quit
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 72397@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 72397
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch