Fix reproducible build for readymedia

  • Done
  • quality assurance status badge
Details
2 participants
  • Vagrant Cascadian
  • Z572
Owner
unassigned
Submitted by
Vagrant Cascadian
Severity
normal

Debbugs page

Vagrant Cascadian wrote 7 months ago
(address . guix-patches@gnu.org)
87r0batqek.fsf@wireframe
The attached patch should fix build reproducibility issues of
"readymedia" by avoiding embedding the running kernel version of the
build machine.

This was one of the examples used in the Reproducible Builds patch
session On July 11th!


live well,
vagrant
From e40dc4bc9633a44fc10ea49007618a41fa598d99 Mon Sep 17 00:00:00 2001
From: Vagrant Cascadian <vagrant@reproducible-builds.org>
Date: Wed, 3 Jul 2024 14:00:34 -0700
Subject: [PATCH] gnu: readymedia: Fix reproducible build.

* gnu/packages/upnp.scm (readymedia)[configure-flags]: Avoid embedding kernel
version.
---
gnu/packages/upnp.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (18 lines)
diff --git a/gnu/packages/upnp.scm b/gnu/packages/upnp.scm
index aab68a6414..5514b3632b 100644
--- a/gnu/packages/upnp.scm
+++ b/gnu/packages/upnp.scm
@@ -150,7 +150,8 @@ (define-public readymedia
(base32 "1al04jx72bxwqch1nv9lx536mb6pvj7pgnqzy6lm32q6xa114yr2"))))
(build-system gnu-build-system)
(arguments
- `(#:configure-flags '("--with-os-name=Linux") ; uname -s
+ `(#:configure-flags '("--with-os-name=Linux" ; uname -s
+ "--with-os-version=") ; uname -r
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-source

base-commit: 2aa0127d4e3d2363c04caab88137b070b6cf1318
--
2.39.2
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCZql2EwAKCRDcUY/If5cW
qrLAAPwMTPGAHbdoFLLJXz2lOEQO+CBBXEFIjV7UFLnO/Og43wD9HCZetp+6SB1h
/yQqgFWJv9fE4SFzYWerri6CYCBKFgQ=
=R432
-----END PGP SIGNATURE-----

Z572 wrote 7 months ago
(name . Vagrant Cascadian)(address . vagrant@reproducible-builds.org)(address . 72387-done@debbugs.gnu.org)
87plqsw82w.fsf@iscas.ac.cn
Vagrant Cascadian <vagrant@reproducible-builds.org> writes:

Toggle quote (41 lines)
> The attached patch should fix build reproducibility issues of
> "readymedia" by avoiding embedding the running kernel version of the
> build machine.
>
> This was one of the examples used in the Reproducible Builds patch
> session On July 11th!
>
> https://libreplanet.org/wiki/Group:Guix/PatchReviewSessions2024
>
> live well,
> vagrant
>
> [2. text/x-diff; 0001-gnu-readymedia-Fix-reproducible-build.patch]
> From e40dc4bc9633a44fc10ea49007618a41fa598d99 Mon Sep 17 00:00:00 2001
> From: Vagrant Cascadian <vagrant@reproducible-builds.org>
> Date: Wed, 3 Jul 2024 14:00:34 -0700
> Subject: [PATCH] gnu: readymedia: Fix reproducible build.
>
> * gnu/packages/upnp.scm (readymedia)[configure-flags]: Avoid embedding kernel
> version.
> ---
> gnu/packages/upnp.scm | 3 ++-
> 1 file changed, 2 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/upnp.scm b/gnu/packages/upnp.scm
> index aab68a6414..5514b3632b 100644
> --- a/gnu/packages/upnp.scm
> +++ b/gnu/packages/upnp.scm
> @@ -150,7 +150,8 @@ (define-public readymedia
> (base32 "1al04jx72bxwqch1nv9lx536mb6pvj7pgnqzy6lm32q6xa114yr2"))))
> (build-system gnu-build-system)
> (arguments
> - `(#:configure-flags '("--with-os-name=Linux") ; uname -s
> + `(#:configure-flags '("--with-os-name=Linux" ; uname -s
> + "--with-os-version=") ; uname -r
> #:phases
> (modify-phases %standard-phases
> (add-after 'unpack 'patch-source
>
> base-commit: 2aa0127d4e3d2363c04caab88137b070b6cf1318

Thanks, push, close.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEfr6klGDOXiwIdX/bO1qpk+Gi3/AFAmarsBcACgkQO1qpk+Gi
3/DvsQ//ZEtCeFcKD/yxc58rviNbvrd+GpJHbx2zaj1q9mxQ8wa1ju+2xs1BXKbV
7P6ykJN+qp28c4yDgRPGZHMi5H6A7QBuyEQU02LukYsebDsOjQ+yRKE2WmlXm6Mo
MSbydHLSUtZs9BxUnIAJY99RaYstMs6On5emlM9y/c2NI3T+PiofCvAbHDeuUMXJ
Mg0keLRohUbO+r/gaRCnEJ36D4zC59X7mWveBWO8UB8YKcfQQ2tJC+8C7eDjxpVl
dxB3V6QlhJIszfpcFN4qpzFVfgovTvXPnIYPGyh3ko8ugGYosZBEt4/K0BW8OyIN
MTO+09+vkmJWKtwfpLYskraBjsNCKxl0PmAsa6CrZyDcunbh4SZ+kOCGc4sBa33s
u1bQEXuiAY5szk/JxMQSHSWvWzXVWBJN8btbZawLBNCeDwhPxyUe0NZXg47NTHUh
UBQDVm+icNpqvXq4Jsxk4AXNJbYUnb0h068ild3RgoyDzbDfGKxhga8YysProqXW
tSwn0Z0GnUuzP01G9Xuk6BbI9R6SoufiiWSf+7DmZBxUSafb3qO2goWDOjQaZa5S
hxWMk0O0gMuelIutb8Sb3+vUBJXoDv+GNjlTJXBIh9hPDrPQ3YXRNfu5E8tm9prC
wGDDSfr5VuBrER1z02JtyPQTka1yKJ8ctm7mIq6nSXDUBCnFMtg=
=3Shp
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 72387@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 72387
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help