guix system reconfigure hangs indefinitely after displaying "guix system: bootloader successfully installed on "(/dev/sda)"?

  • Open
  • quality assurance status badge
Details
One participant
  • Oleander
Owner
unassigned
Submitted by
Oleander
Severity
normal
O
O
Oleander wrote on 29 Jul 17:26 +0200
(name . bug-guix)(address . bug-guix@gnu.org)
0P2Fg-c8HTUWhRRaOq0vkMLT_Nkvkrdd6Ocs_WGbp2RImUoLsYhT7Txatb2yKzKU1j6IlqzVRFynszjhq2s07KSRP_LpzPS-WMTwk8wXAGk=@protonmail.com
Hi Guix,

sorry for reopening this but after a few guix system reconfigure, the issue I reported here: https://issues.guix.gnu.org/72187has come back again.

My system config:

(use-modules
(gnu) (gnu system))
(use-service-modules
dbus desktop networking sound ssh xorg)
(use-package-modules
admin certs glib pulseaudio screen ssh wm)

(operating-system
(host-name "t420")
(timezone "Europe/Rome")
(locale "en_US.utf8")

(keyboard-layout (keyboard-layout "us"))

(bootloader
(bootloader-configuration
(bootloader grub-bootloader)
(terminal-outputs '(console))
(targets '("/dev/sda"))
(keyboard-layout keyboard-layout)))

;; Specify a mapped device for the encrypted root partition.
;; The UUID is that returned by 'cryptsetup luksUUID'.
(mapped-devices
(list (mapped-device
(source (uuid "c8a8dbf9-9c67-4029-aa59-d5b46840c3f3"))
(targets (list "guix"))
(type luks-device-mapping))))

(file-systems
(append
(list (file-system
(device (file-system-label "guix"))
(mount-point "/")
(type "ext4")
(dependencies mapped-devices)))
%base-file-systems))

(swap-devices
(list
(swap-space (target "/swapfile"))))

(users
(cons (user-account
(name "oleander")
(comment "")
(group "users")
(home-directory "/home/oleander")
(supplementary-groups '("wheel" "netdev"
"audio" "video" "input")))
%base-user-accounts))

;; System-wide packages.
(packages
(append
(list
dbus
openssh-sans-x
pulseaudio
screen
swaylock-effects
wpa-supplicant)
%base-packages))

(services
(cons*
(service alsa-service-type
(alsa-configuration
(pulseaudio? #t)))
(service dbus-root-service-type)
(service elogind-service-type)
(service openssh-service-type
(openssh-configuration
(openssh openssh-sans-x)
(port-number 22)
(password-authentication? #f)
(permit-root-login 'prohibit-password)
(authorized-keys
`(("oleander" ,(local-file "/home/oleander/.ssh/authorized_keys"))))))
(service ntp-service-type
(ntp-configuration
(servers (map (lambda (server)
(ntp-server (address server)))
'("0.europe.pool.ntp.org"
"1.europe.pool.ntp.org"
"2.europe.pool.ntp.org"
"3.europe.pool.ntp.org")))))
(service polkit-service-type)
(service screen-locker-service-type
(screen-locker-configuration
(name "swaylock")
(program (file-append swaylock-effects "/bin/swaylock"))
(using-pam? #t)
(using-setuid? #f)))
(service static-networking-service-type
(list (static-networking
(addresses
(list (network-address
(device "wlp1s0")
(value "192.168.1.37/24"))))
(routes
(list (network-route
(destination "default")
(gateway "192.168.1.1"))))
(name-servers '("1.1.1.1" "1.0.0.1"))))
(service wpa-supplicant-service-type
(wpa-supplicant-configuration
(config-file (local-file "/home/oleander/src/guix/wpa_supplicant.conf"))
(interface "wlp1s0")))
(modify-services %base-services
(mingetty-service-type config =>
(mingetty-configuration
(inherit config)
;; Automatically log in as "oleander".
(auto-login "oleander")
;; Work-around to fix "Error in service module"
(login-pause? #t))))))

;; Allow resolution of '.local' host names with mDNS.
(name-service-switch %mdns-host-lookup-nss))
Thank you!
Attachment: file
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 72354@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 72354
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch