[PATCH] gnu: skopeo: Update to 1.16.0.

  • Done
  • quality assurance status badge
Details
2 participants
  • Zheng Junjie
  • Tomas Volf
Owner
unassigned
Submitted by
Tomas Volf
Severity
normal

Debbugs page

Tomas Volf wrote 7 months ago
(address . guix-patches@gnu.org)(name . Tomas Volf)(address . ~@wolfsden.cz)
81c13e3d988c12ae65e05d11313161d1e5722838.1722246239.git.~@wolfsden.cz
* gnu/packages/virtualization.scm (skopeo): Update to 1.16.0.
[arguments]<#:phases>: Delete the `cc-to-gcc' phase.

Change-Id: I35a91219c3c920f37f496df6322ae1e40fa1ccc3
---
gnu/packages/virtualization.scm | 19 ++-----------------
1 file changed, 2 insertions(+), 17 deletions(-)

Toggle diff (49 lines)
diff --git a/gnu/packages/virtualization.scm b/gnu/packages/virtualization.scm
index 061748bb4a..6932086b0d 100644
--- a/gnu/packages/virtualization.scm
+++ b/gnu/packages/virtualization.scm
@@ -2321,7 +2321,7 @@ (define-public umoci
(define-public skopeo
(package
(name "skopeo")
- (version "1.15.2")
+ (version "1.16.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -2330,7 +2330,7 @@ (define-public skopeo
(file-name (git-file-name name version))
(sha256
(base32
- "13y1fmv78hh5ycm7xlsg851y17s223q13b9srksnq6jcwgprqkm8"))))
+ "1vjhi4xvb3vdz9nm627bymih9nil1xm4m5zcmx088d76dnqm3l1k"))))
(build-system gnu-build-system)
(native-inputs
(list go-1.21
@@ -2370,22 +2370,7 @@ (define-public skopeo
;; Required for detecting btrfs in hack/btrfs* due to bug in GNU
;; Make <4.4 causing CC not to be propagated into $(shell ...)
;; calls. Can be removed once we update to >4.3.
- ;;
- ;; This techically does nothing *now*, but after upstream
- ;; issue[1] is solved and 'cc-to-gcc phase is removed, it will
- ;; start being required.
- ;; 1: https://github.com/containers/skopeo/issues/2278
(setenv "CC" #$(cc-for-target))))
- (add-after 'unpack 'cc-to-gcc
- (lambda _
- (for-each (lambda (file)
- (substitute* file
- (("^cc( -.*)" all rest)
- (string-append "\"$CC\"" rest))))
- '("hack/btrfs_tag.sh"
- "hack/btrfs_installed_tag.sh"
- "hack/libdm_tag.sh"
- "hack/libsubid_tag.sh"))))
(add-after 'install 'wrap-skopeo
(lambda _
(wrap-program (string-append #$output "/bin/skopeo")

base-commit: b45cfc2fac5a0a368f16b7f049a0a4ff3bfb2421
--
2.45.2
Zheng Junjie wrote 7 months ago
(name . Tomas Volf)(address . ~@wolfsden.cz)(address . 72350-done@debbugs.gnu.org)
87mslzxn3s.fsf@iscas.ac.cn
Tomas Volf <~@wolfsden.cz> writes:

Toggle quote (56 lines)
> * gnu/packages/virtualization.scm (skopeo): Update to 1.16.0.
> [arguments]<#:phases>: Delete the `cc-to-gcc' phase.
>
> Change-Id: I35a91219c3c920f37f496df6322ae1e40fa1ccc3
> ---
> gnu/packages/virtualization.scm | 19 ++-----------------
> 1 file changed, 2 insertions(+), 17 deletions(-)
>
> diff --git a/gnu/packages/virtualization.scm b/gnu/packages/virtualization.scm
> index 061748bb4a..6932086b0d 100644
> --- a/gnu/packages/virtualization.scm
> +++ b/gnu/packages/virtualization.scm
> @@ -2321,7 +2321,7 @@ (define-public umoci
> (define-public skopeo
> (package
> (name "skopeo")
> - (version "1.15.2")
> + (version "1.16.0")
> (source (origin
> (method git-fetch)
> (uri (git-reference
> @@ -2330,7 +2330,7 @@ (define-public skopeo
> (file-name (git-file-name name version))
> (sha256
> (base32
> - "13y1fmv78hh5ycm7xlsg851y17s223q13b9srksnq6jcwgprqkm8"))))
> + "1vjhi4xvb3vdz9nm627bymih9nil1xm4m5zcmx088d76dnqm3l1k"))))
> (build-system gnu-build-system)
> (native-inputs
> (list go-1.21
> @@ -2370,22 +2370,7 @@ (define-public skopeo
> ;; Required for detecting btrfs in hack/btrfs* due to bug in GNU
> ;; Make <4.4 causing CC not to be propagated into $(shell ...)
> ;; calls. Can be removed once we update to >4.3.
> - ;;
> - ;; This techically does nothing *now*, but after upstream
> - ;; issue[1] is solved and 'cc-to-gcc phase is removed, it will
> - ;; start being required.
> - ;; 1: https://github.com/containers/skopeo/issues/2278
> (setenv "CC" #$(cc-for-target))))
> - (add-after 'unpack 'cc-to-gcc
> - (lambda _
> - (for-each (lambda (file)
> - (substitute* file
> - (("^cc( -.*)" all rest)
> - (string-append "\"$CC\"" rest))))
> - '("hack/btrfs_tag.sh"
> - "hack/btrfs_installed_tag.sh"
> - "hack/libdm_tag.sh"
> - "hack/libsubid_tag.sh"))))
> (add-after 'install 'wrap-skopeo
> (lambda _
> (wrap-program (string-append #$output "/bin/skopeo")
>
> base-commit: b45cfc2fac5a0a368f16b7f049a0a4ff3bfb2421

push, close.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEfr6klGDOXiwIdX/bO1qpk+Gi3/AFAmaorccACgkQO1qpk+Gi
3/Dhig/+JU8jJRi7hMY+WonKwr7hbTLDTZrqbkw+UUVNZhtwC3IubYdx3ceMilE2
u/Q6++D0nHZe5dsIeRo1Hc/B9/1F0h/1kQIXMCIYxh5fkwsuEIXreXnAl47sTFiX
fKnKnhHrUBBsgnUzHV3t3IEMl+kIi4rAElwHzyi0gdK0FNDjX3zePra8HriCL8WH
W9XjaUcOCIGq152cGAaojNj7WCqsLzBOhZI9NFEGR/nrIwIo6+M0eIqWMFTAq6zz
gHVvZD+hPqo2IJ/b0/7h+ERSnVLF2nezfEAnakbFJltfPi/4Mq8H7I4Uy5Ma1LuM
BzIvr0f3RWGyPDkoLx4nturOo+ZDqfkH7k06HWnSPQACInxYPstpxjxzn1Ja9wLL
MASWOj/baxl6OMbVQwQFMWzcMN2ypL9Xkj3x5S/EUgrjJR7fkQf0hVfQgwHnNWuW
7X9WgOzE6T0QIjZUiySSyGlwj6xSYxhV0zidf1XENEwabBvblPfna7VKn9uZOuTm
q/y3vcbZ9eHrbrM1PehRhC17oAF+5gggkpOIlh7iQYLoyTkU7qmtY1D6ivmLSdvk
Eg77NQMZPlHv9tqpWWIiSujXcaXCGxMRFUP69f28oueP//X/9S9prDbrUxpoNtr8
KWPK69VmxuMmPG4GCXJMe4mmkiD13qE+jtTbek4SaNKu6j7K2Cs=
=2pwK
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 72350@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 72350
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help