[PATCH] gnu: xpra: Update to 6.1.0

  • Done
  • quality assurance status badge
Details
3 participants
  • Andy Tai
  • Christopher Baines
  • Zheng Junjie
Owner
unassigned
Submitted by
Andy Tai
Severity
normal
A
A
Andy Tai wrote on 28 Jul 06:34 +0200
(address . guix-patches@gnu.org)(name . Andy Tai)(address . atai@atai.org)
7fb3e4467339bb60ccf54eb1ad9ae90afb1fc725.1722141217.git.atai@atai.org
* gnu/packages/xorg.scm (xpra): Update to 6.1.0.
* gnu/packages/patches/xpra-6.0-install_libs.patch: Update for xpra 6.1.0.

Change-Id: I38dab99fbb369ab7e8daf2795dc37aa1a36a63de
---
gnu/packages/patches/xpra-6.0-install_libs.patch | 10 +++++-----
gnu/packages/xorg.scm | 4 ++--
2 files changed, 7 insertions(+), 7 deletions(-)

Toggle diff (63 lines)
diff --git a/gnu/packages/patches/xpra-6.0-install_libs.patch b/gnu/packages/patches/xpra-6.0-install_libs.patch
index c608b519f4..0ec2aee288 100644
--- a/gnu/packages/patches/xpra-6.0-install_libs.patch
+++ b/gnu/packages/patches/xpra-6.0-install_libs.patch
@@ -4,19 +4,19 @@ This workaround for Gentoo interferes with our use of --no-compile during
the 'install stage.
diff --git a/setup.py b/setup.py
-index 4f066fa8bf..14a9ed65ed 100755
+index be7a3758e8..28dc1be191 100755
--- a/setup.py
+++ b/setup.py
-@@ -760,8 +760,6 @@ if modules_ENABLED:
+@@ -953,8 +953,6 @@ if modules_ENABLED:
# Utility methods for building with Cython
- def do_add_cython_ext(*args, **kwargs):
+ def do_add_cython_ext(*args, **kwargs) -> None:
- if "--no-compile" in sys.argv and not ("build" in sys.argv and "install" in sys.argv):
- return
if not cython_ENABLED:
raise ValueError(f"cannot build {args}: cython compilation is disabled")
if cython_tracing_ENABLED:
-@@ -1971,9 +1969,6 @@ else:
+@@ -2175,9 +2173,6 @@ else:
if root_prefix.endswith("/usr"):
# ie: "/" or "/usr/src/rpmbuild/BUILDROOT/xpra-0.18.0-0.20160513r12573.fc23.x86_64/"
root_prefix = root_prefix[:-4]
@@ -26,7 +26,7 @@ index 4f066fa8bf..14a9ed65ed 100755
print(f" root_prefix={root_prefix!r}")
build_xpra_conf(root_prefix)
-@@ -2116,13 +2111,6 @@ else:
+@@ -2320,13 +2315,6 @@ else:
if uinput_ENABLED:
add_data_files("lib/udev/rules.d/", ["fs/lib/udev/rules.d/71-xpra-virtual-pointer.rules"])
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 6b953ef152..bdce6174ff 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -6158,7 +6158,7 @@ (define-public xcompmgr
(define-public xpra
(package
(name "xpra")
- (version "6.0.2")
+ (version "6.1.0")
(source
(origin
(method git-fetch)
@@ -6167,7 +6167,7 @@ (define-public xpra
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "176qxrksgr07jhrlny3zxybnvf091kxkfmfnv9ci3h2k1nbwqh2x"))
+ (base32 "1x1ld2p3q47irqq6p1b3rd9ffbi7kvgxyvfmgi0skfin17b2aqx4"))
(patches (search-patches "xpra-6.0-systemd-run.patch"
"xpra-6.0-install_libs.patch"))))
(build-system python-build-system)

base-commit: 46a64c7fdd057283063aae6df058579bb07c4b6a
--
2.34.1
A
Z
Z
Zheng Junjie wrote on 30 Jul 08:19 +0200
Re: [bug#72330] [PATCH] gnu: xpra: Update to 6.1.0
(name . Andy Tai)(address . atai@atai.org)(address . 72330@debbugs.gnu.org)
87le1jz9j2.fsf@iscas.ac.cn
Andy Tai <atai@atai.org> writes:

Toggle quote (2 lines)
> * gnu/packages/xorg.scm (xpra): Update to 6.1.0.
> * gnu/packages/patches/xpra-6.0-install_libs.patch: Update for xpra 6.1.0.
^^^ maybe rename this file to 6.1 ?.
Toggle quote (68 lines)
>
> Change-Id: I38dab99fbb369ab7e8daf2795dc37aa1a36a63de
> ---
> gnu/packages/patches/xpra-6.0-install_libs.patch | 10 +++++-----
> gnu/packages/xorg.scm | 4 ++--
> 2 files changed, 7 insertions(+), 7 deletions(-)
>
> diff --git a/gnu/packages/patches/xpra-6.0-install_libs.patch b/gnu/packages/patches/xpra-6.0-install_libs.patch
> index c608b519f4..0ec2aee288 100644
> --- a/gnu/packages/patches/xpra-6.0-install_libs.patch
> +++ b/gnu/packages/patches/xpra-6.0-install_libs.patch
> @@ -4,19 +4,19 @@ This workaround for Gentoo interferes with our use of --no-compile during
> the 'install stage.
>
> diff --git a/setup.py b/setup.py
> -index 4f066fa8bf..14a9ed65ed 100755
> +index be7a3758e8..28dc1be191 100755
> --- a/setup.py
> +++ b/setup.py
> -@@ -760,8 +760,6 @@ if modules_ENABLED:
> +@@ -953,8 +953,6 @@ if modules_ENABLED:
> # Utility methods for building with Cython
>
> - def do_add_cython_ext(*args, **kwargs):
> + def do_add_cython_ext(*args, **kwargs) -> None:
> - if "--no-compile" in sys.argv and not ("build" in sys.argv and "install" in sys.argv):
> - return
> if not cython_ENABLED:
> raise ValueError(f"cannot build {args}: cython compilation is disabled")
> if cython_tracing_ENABLED:
> -@@ -1971,9 +1969,6 @@ else:
> +@@ -2175,9 +2173,6 @@ else:
> if root_prefix.endswith("/usr"):
> # ie: "/" or "/usr/src/rpmbuild/BUILDROOT/xpra-0.18.0-0.20160513r12573.fc23.x86_64/"
> root_prefix = root_prefix[:-4]
> @@ -26,7 +26,7 @@ index 4f066fa8bf..14a9ed65ed 100755
> print(f" root_prefix={root_prefix!r}")
> build_xpra_conf(root_prefix)
>
> -@@ -2116,13 +2111,6 @@ else:
> +@@ -2320,13 +2315,6 @@ else:
> if uinput_ENABLED:
> add_data_files("lib/udev/rules.d/", ["fs/lib/udev/rules.d/71-xpra-virtual-pointer.rules"])
>
> diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
> index 6b953ef152..bdce6174ff 100644
> --- a/gnu/packages/xorg.scm
> +++ b/gnu/packages/xorg.scm
> @@ -6158,7 +6158,7 @@ (define-public xcompmgr
> (define-public xpra
> (package
> (name "xpra")
> - (version "6.0.2")
> + (version "6.1.0")
> (source
> (origin
> (method git-fetch)
> @@ -6167,7 +6167,7 @@ (define-public xpra
> (commit (string-append "v" version))))
> (file-name (git-file-name name version))
> (sha256
> - (base32 "176qxrksgr07jhrlny3zxybnvf091kxkfmfnv9ci3h2k1nbwqh2x"))
> + (base32 "1x1ld2p3q47irqq6p1b3rd9ffbi7kvgxyvfmgi0skfin17b2aqx4"))
> (patches (search-patches "xpra-6.0-systemd-run.patch"
> "xpra-6.0-install_libs.patch"))))
> (build-system python-build-system)
>
> base-commit: 46a64c7fdd057283063aae6df058579bb07c4b6a
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEfr6klGDOXiwIdX/bO1qpk+Gi3/AFAmaohgEACgkQO1qpk+Gi
3/BxYQ/+OP/Kweb29vwXThqCv27m8f1T+rvRxmiEx5wt2quyA3oKwgdlDw5BwBl8
YIPZUgDCEncSGw4mx9e0pDYtSMdUx45cdLlj8V3iOJQR8Ca/N4muu8w0SpF/y8b5
+vGyjjo9QAZJSxj4tkHJFa8YFB+3zJ5s+20Kk8GCnHdggmSGe+qnDGo5GyTlB+Nl
Sm/3teLw3QDHnw5PH2Kmri7fPJ4dFZbDak/k12xmoa+9PE9S92PCP0tRSk46ng55
skzA2B3ismiFf8v66iztGYR4MyqUfkFZFpqCBzTeVRJMtt7DkYK2iW+Y/xIkx8jN
9Fzo8FBLTETZCadh8BsMjbFyn2qxBezG/tzQgZ01oiyxvIEMXvWbxmrkB7xdqw7B
aSzlGqo3/C4PFp2pyyjXM2LdkL1bmhhFVUchmC52N8YN6NmaskFToPeXbiN4lKQ9
gDhskhzKUjpU1WVfjqnP54vRlnx66E9OWYCOSSmetygQfs4vnfx+LEWmwXe8gBfB
AWzg143fF2RwYWvPUcILr2+0YBHyhcQAPkgYOjUDvE58vop1kWpKyJs3yCWI2Qzx
+CyfDbyEZm8/PB/S0UG5mGIhPsdNhdnGewgbwUrdu3652yiUnAdsn1wRhgAxCi5p
rsTM1rFH+ty3RaY4wzlD0+1AXgdnMJ0GKhkGvrCmIK1BxCgzuVw=
=oWJG
-----END PGP SIGNATURE-----

A
A
Andy Tai wrote on 3 Aug 06:37 +0200
[PATCH v2] gnu: xpra: Update to 6.1.0
(name . Andy Tai)(address . atai@atai.org)
cef2ec334ccda6d774cc31925d905f2b982e3116.1722659780.git.atai@atai.org
* gnu/packages/xorg.scm (xpra): Update to 6.1.0.
[source](origin): Update patch file name.
* gnu/packages/patches/xpra-6.0-install_libs.patch: Delete.
* gnu/packages/patches/xpra-6.1-install_libs.patch: New file.
* gnu/local.mk: Unregister deleted file and register new file.

Change-Id: I38dab99fbb369ab7e8daf2795dc37aa1a36a63de
---
gnu/local.mk | 2 +-
...-install_libs.patch => xpra-6.1-install_libs.patch} | 10 +++++-----
gnu/packages/xorg.scm | 6 +++---
3 files changed, 9 insertions(+), 9 deletions(-)
rename gnu/packages/patches/{xpra-6.0-install_libs.patch => xpra-6.1-install_libs.patch} (90%)

Toggle diff (82 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index 6d2b14e72d..28953b76de 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -2266,7 +2266,7 @@ dist_patch_DATA = \
%D%/packages/patches/xplanet-1.3.1-libimage_gif.c.patch \
%D%/packages/patches/xplanet-1.3.1-xpUtil-Add2017LeapSecond.cpp.patch \
%D%/packages/patches/xpra-6.0-systemd-run.patch \
- %D%/packages/patches/xpra-6.0-install_libs.patch \
+ %D%/packages/patches/xpra-6.1-install_libs.patch \
%D%/packages/patches/xsane-fix-memory-leak.patch \
%D%/packages/patches/xsane-fix-pdf-floats.patch \
%D%/packages/patches/xsane-fix-snprintf-buffer-length.patch \
diff --git a/gnu/packages/patches/xpra-6.0-install_libs.patch b/gnu/packages/patches/xpra-6.1-install_libs.patch
similarity index 90%
rename from gnu/packages/patches/xpra-6.0-install_libs.patch
rename to gnu/packages/patches/xpra-6.1-install_libs.patch
index c608b519f4..0ec2aee288 100644
--- a/gnu/packages/patches/xpra-6.0-install_libs.patch
+++ b/gnu/packages/patches/xpra-6.1-install_libs.patch
@@ -4,19 +4,19 @@ This workaround for Gentoo interferes with our use of --no-compile during
the 'install stage.
diff --git a/setup.py b/setup.py
-index 4f066fa8bf..14a9ed65ed 100755
+index be7a3758e8..28dc1be191 100755
--- a/setup.py
+++ b/setup.py
-@@ -760,8 +760,6 @@ if modules_ENABLED:
+@@ -953,8 +953,6 @@ if modules_ENABLED:
# Utility methods for building with Cython
- def do_add_cython_ext(*args, **kwargs):
+ def do_add_cython_ext(*args, **kwargs) -> None:
- if "--no-compile" in sys.argv and not ("build" in sys.argv and "install" in sys.argv):
- return
if not cython_ENABLED:
raise ValueError(f"cannot build {args}: cython compilation is disabled")
if cython_tracing_ENABLED:
-@@ -1971,9 +1969,6 @@ else:
+@@ -2175,9 +2173,6 @@ else:
if root_prefix.endswith("/usr"):
# ie: "/" or "/usr/src/rpmbuild/BUILDROOT/xpra-0.18.0-0.20160513r12573.fc23.x86_64/"
root_prefix = root_prefix[:-4]
@@ -26,7 +26,7 @@ index 4f066fa8bf..14a9ed65ed 100755
print(f" root_prefix={root_prefix!r}")
build_xpra_conf(root_prefix)
-@@ -2116,13 +2111,6 @@ else:
+@@ -2320,13 +2315,6 @@ else:
if uinput_ENABLED:
add_data_files("lib/udev/rules.d/", ["fs/lib/udev/rules.d/71-xpra-virtual-pointer.rules"])
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 6b953ef152..6825474a6a 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -6158,7 +6158,7 @@ (define-public xcompmgr
(define-public xpra
(package
(name "xpra")
- (version "6.0.2")
+ (version "6.1.0")
(source
(origin
(method git-fetch)
@@ -6167,9 +6167,9 @@ (define-public xpra
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "176qxrksgr07jhrlny3zxybnvf091kxkfmfnv9ci3h2k1nbwqh2x"))
+ (base32 "1x1ld2p3q47irqq6p1b3rd9ffbi7kvgxyvfmgi0skfin17b2aqx4"))
(patches (search-patches "xpra-6.0-systemd-run.patch"
- "xpra-6.0-install_libs.patch"))))
+ "xpra-6.1-install_libs.patch"))))
(build-system python-build-system)
(inputs
(list bash-minimal ; for wrap-program

base-commit: b20956651a53a8f23828fdeb6945e1a31e6997a8
--
2.34.1
A
C
C
Christopher Baines wrote on 11 Aug 12:33 +0200
Re: [bug#72330] [PATCH v2] gnu: xpra: Update to 6.1.0
(name . Andy Tai)(address . atai@atai.org)(address . 72330-done@debbugs.gnu.org)
87frrbz6ux.fsf@cbaines.net
Andy Tai <atai@atai.org> writes:

Toggle quote (14 lines)
> * gnu/packages/xorg.scm (xpra): Update to 6.1.0.
> [source](origin): Update patch file name.
> * gnu/packages/patches/xpra-6.0-install_libs.patch: Delete.
> * gnu/packages/patches/xpra-6.1-install_libs.patch: New file.
> * gnu/local.mk: Unregister deleted file and register new file.
>
> Change-Id: I38dab99fbb369ab7e8daf2795dc37aa1a36a63de
> ---
> gnu/local.mk | 2 +-
> ...-install_libs.patch => xpra-6.1-install_libs.patch} | 10 +++++-----
> gnu/packages/xorg.scm | 6 +++---
> 3 files changed, 9 insertions(+), 9 deletions(-)
> rename gnu/packages/patches/{xpra-6.0-install_libs.patch => xpra-6.1-install_libs.patch} (90%)

Thanks, I've pushed this to master as
8b943673a15a337c48c71cecad18d9eb68143d95.

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAma4k4ZfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9Xe0Ug//YEbcXjH/cDj3oJdfluGe7fBQ/+Ql69Yw
9p18YDod9l8yaAI9KDtdgV3BUakdDfYsdclhrUYKcryeLtdZ4NdHUksLeQDu4qUS
anJ/WxN7ePfQGSJeQulIVwgnKdUCI9id1hkJsc/MGFffaYKv04+8y92xUt9QKJ8X
nggTTbWvBcMidAxjmNdH9c/mWmtcPPBWUBqnkhSC/SRWevpiKNn5n+eRvq1F69YV
mnNFDvCT+nP3RcDQtsXGN5LcZYrbA2m/tlQ+VpGGO7k3mfEpSPazZnhl0t8VcBbq
mBV6O5Us0nlHPeWV9i8mIKcybEzOqvRkeiEA30nkiphbAFN/TmO75Q0KQ1HbKJog
Q+4FFhqSjl8H/7rDqM3SAVRMultG7lY3fRwCH8E5D7G6moAHc6utqFVvQlc73cn5
2qaUW3ZUhCVclkZbr9hHSrkaeQRFBkdhVmNDBPr//gflcyonNVqHDm2ZJ7qh0LIN
VUhbTGGP+LsjdiO3BKBbEh7Fsj3H+sreW/NnNf9yK43KgvG854LOav4bxT3aWv52
mE/o+jV4EguaA2QBhDfqI6zQY5q0ga1jyMtiSJJsxBudBvPbX4FLOrcx6AtkrquF
DPCGZAhwDxft8fiYTwaKKMIHggNQyJ5uJRE/oCqUgfHK6aQNim1Kqf9d9xYY59zO
2k/AaZ/tYHA=
=ucUF
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 72330@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 72330
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch