[PATCH] gnu: Add git-tools.

  • Done
  • quality assurance status badge
Details
2 participants
  • ???
  • Suhail Singh
Owner
unassigned
Submitted by
Suhail Singh
Severity
normal
S
S
Suhail Singh wrote on 25 Jul 21:34 +0200
(name . Guix-patches mailing list)(address . guix-patches@gnu.org)
adfbb9861401c8eaa0daac0d442212118de56176.1721935647.git.suhail@bayesians.ca
* gnu/packages/version-control.scm (git-tools): Add git-tools v2022.12.

Change-Id: I0ac65c24f787714fe0ef234fce639c6ec561600d
---
gnu/packages/version-control.scm | 41 ++++++++++++++++++++++++++++++++
1 file changed, 41 insertions(+)

Toggle diff (63 lines)
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index cf7f7b0ad8..09309c8439 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -52,6 +52,7 @@
;;; Copyright © 2023 Steve George <steve@futurile.net>
;;; Copyright © 2023 Josselin Poiret <dev@jpoiret.xyz>
;;; Copyright © 2024 Hilton Chain <hako@ultrarare.space>
+;;; Copyright © 2024 Suhail Singh <suhail@bayesians.ca>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -830,6 +831,46 @@ (define-public git-cal
to GitHub contributions calendar.")
(license license:expat)))
+(define-public git-tools
+ (package
+ (name "git-tools")
+ (version "2022.12")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/MestreLion/git-tools")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0s8x74ggcr6nqzplr0jfzp3cavq0nmdm35hqywzs2bbq75i1mijd"))))
+ (build-system copy-build-system)
+ (arguments
+ `(#:install-plan '(("git-branches-rename" "bin/git-branches-rename")
+ ("git-clone-subset" "bin/git-clone-subset")
+ ("git-find-uncommitted-repos"
+ "bin/git-find-uncommitted-repos")
+ ("git-rebase-theirs" "bin/git-rebase-theirs")
+ ("git-restore-mtime" "bin/git-restore-mtime")
+ ("git-strip-merge" "bin/git-strip-merge")
+ ("./man1/" "share/man/man1"
+ #:include-regexp (".*\\.1$")))))
+ (inputs (list bash-minimal git-minimal python-minimal))
+ (home-page "https://github.com/MestreLion/git-tools")
+ (synopsis "Assorted git-related scripts and tools")
+ (description "@code{git-tools} is a collection of bash and python scripts.
+Specifically, it includes the following tools:
+
+@itemize
+@item @code{git-branches-rename}
+@item @code{git-clone-subset}
+@item @code{git-find-uncommitted-repos}
+@item @code{git-rebase-theirs}
+@item @code{git-restore-mtime}
+@item @code{git-strip-merge}
+@end itemize")
+ (license license:gpl3)))
+
(define-public xdiff
(let ((revision "0")
(commit "a137bc7ee6c76618ed1737c257548eaa10ac0089"))

base-commit: 03062c7a9fd74d625639e1a325e9cb58d1cd74e3
--
2.45.2
S
S
Suhail Singh wrote on 26 Jul 01:26 +0200
[PATCH v2] gnu: Add git-tools.
(address . 72299@debbugs.gnu.org)
073c93709b52c4683873da7da088d5af25ed1552.1721949854.git.suhail@bayesians.ca
* gnu/packages/version-control.scm (git-tools): New variable.

Change-Id: I0ac65c24f787714fe0ef234fce639c6ec561600d
---
gnu/packages/version-control.scm | 41 ++++++++++++++++++++++++++++++++
1 file changed, 41 insertions(+)

Toggle diff (63 lines)
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index cf7f7b0ad8..09309c8439 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -52,6 +52,7 @@
;;; Copyright © 2023 Steve George <steve@futurile.net>
;;; Copyright © 2023 Josselin Poiret <dev@jpoiret.xyz>
;;; Copyright © 2024 Hilton Chain <hako@ultrarare.space>
+;;; Copyright © 2024 Suhail Singh <suhail@bayesians.ca>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -830,6 +831,46 @@ (define-public git-cal
to GitHub contributions calendar.")
(license license:expat)))
+(define-public git-tools
+ (package
+ (name "git-tools")
+ (version "2022.12")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/MestreLion/git-tools")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0s8x74ggcr6nqzplr0jfzp3cavq0nmdm35hqywzs2bbq75i1mijd"))))
+ (build-system copy-build-system)
+ (arguments
+ `(#:install-plan '(("git-branches-rename" "bin/git-branches-rename")
+ ("git-clone-subset" "bin/git-clone-subset")
+ ("git-find-uncommitted-repos"
+ "bin/git-find-uncommitted-repos")
+ ("git-rebase-theirs" "bin/git-rebase-theirs")
+ ("git-restore-mtime" "bin/git-restore-mtime")
+ ("git-strip-merge" "bin/git-strip-merge")
+ ("./man1/" "share/man/man1"
+ #:include-regexp (".*\\.1$")))))
+ (inputs (list bash-minimal git-minimal python-minimal))
+ (home-page "https://github.com/MestreLion/git-tools")
+ (synopsis "Assorted git-related scripts and tools")
+ (description "@code{git-tools} is a collection of bash and python scripts.
+Specifically, it includes the following tools:
+
+@itemize
+@item @code{git-branches-rename}
+@item @code{git-clone-subset}
+@item @code{git-find-uncommitted-repos}
+@item @code{git-rebase-theirs}
+@item @code{git-restore-mtime}
+@item @code{git-strip-merge}
+@end itemize")
+ (license license:gpl3)))
+
(define-public xdiff
(let ((revision "0")
(commit "a137bc7ee6c76618ed1737c257548eaa10ac0089"))

base-commit: 03062c7a9fd74d625639e1a325e9cb58d1cd74e3
--
2.45.2
S
S
Suhail Singh wrote on 30 Jul 07:05 +0200
[PATCH v3] gnu: Add git-tools.
(address . 72299@debbugs.gnu.org)
e6e9fa52e7ff318272373dc0d24836f7d3a28490.1722315805.git.suhail@bayesians.ca
* gnu/packages/version-control.scm (git-tools): New variable.

Change-Id: I0ac65c24f787714fe0ef234fce639c6ec561600d
---
gnu/packages/version-control.scm | 47 ++++++++++++++++++++++++++++++++
1 file changed, 47 insertions(+)

Toggle diff (69 lines)
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index cf7f7b0ad8..d5887f3fbc 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -52,6 +52,7 @@
;;; Copyright © 2023 Steve George <steve@futurile.net>
;;; Copyright © 2023 Josselin Poiret <dev@jpoiret.xyz>
;;; Copyright © 2024 Hilton Chain <hako@ultrarare.space>
+;;; Copyright © 2024 Suhail Singh <suhail@bayesians.ca>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -830,6 +831,52 @@ (define-public git-cal
to GitHub contributions calendar.")
(license license:expat)))
+(define-public git-tools
+ (package
+ (name "git-tools")
+ (version "2022.12")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/MestreLion/git-tools")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0s8x74ggcr6nqzplr0jfzp3cavq0nmdm35hqywzs2bbq75i1mijd"))))
+ (build-system copy-build-system)
+ (arguments
+ `(#:install-plan '(("git-branches-rename" "bin/git-branches-rename")
+ ("git-clone-subset" "bin/git-clone-subset")
+ ("git-find-uncommitted-repos"
+ "bin/git-find-uncommitted-repos")
+ ("git-rebase-theirs" "bin/git-rebase-theirs")
+ ("git-restore-mtime" "bin/git-restore-mtime")
+ ("git-strip-merge" "bin/git-strip-merge")
+ ("./man1/" "share/man/man1"
+ #:include-regexp (".*\\.1$")))))
+ (inputs (list bash-minimal git-minimal python-minimal))
+ (home-page "https://github.com/MestreLion/git-tools")
+ (synopsis "Assorted git-related scripts and tools")
+ (description
+ "@code{git-tools} is a collection of bash and python scripts.
+Specifically, it includes the following tools:
+
+@itemize
+@item @code{git-branches-rename}: Batch rename branches with a matching prefix
+to another prefix
+@item @code{git-clone-subset}: Clone a subset of a git repository
+@item @code{git-find-uncommitted-repos}: Recursively list repositories in the
+given directory(ies) that have uncommitted changes
+@item @code{git-rebase-theirs}: Resolve rebase conflicts and failed
+cherry-picks by favoring \"theirs\" version
+@item @code{git-restore-mtime}: Restore modification time of files based on
+the date of the most recent commit that modified them
+@item @code{git-strip-merge}: A git-merge wrapper that deletes files on a
+\"foreign\" branch before merging
+@end itemize")
+ (license license:gpl3+)))
+
(define-public xdiff
(let ((revision "0")
(commit "a137bc7ee6c76618ed1737c257548eaa10ac0089"))

base-commit: 03062c7a9fd74d625639e1a325e9cb58d1cd74e3
--
2.45.2
?
(name . Suhail Singh)(address . suhailsingh247@gmail.com)(address . 72299-done@debbugs.gnu.org)
87sevq77ot.fsf@envs.net
Suhail Singh <suhailsingh247@gmail.com> writes:

Toggle quote (4 lines)
> * gnu/packages/version-control.scm (git-tools): New variable.
>
> Change-Id: I0ac65c24f787714fe0ef234fce639c6ec561600d

Pushed to master as commit dae712644d05723999c80a518b5f15d78ae317f2,
thank you!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 72299@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 72299
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch