‘guix pack -RR’ doesn’t support provide “fakechroot” engine for script
(address . bug-guix@gnu.org)
Assume a manifest like this:
Toggle snippet (18 lines)
(use-modules (guix))
(define program
(program-file "hello" #~(display "hello")))
(define package-tree
(computed-file "package-with-script"
#~(let ((bin (string-append #$output "/bin")))
(mkdir #$output)
(mkdir bin)
(copy-file #$program (string-append bin "/hello")))))
(manifest (list (manifest-entry
(name "hello")
(version "0")
(item package-tree))))
Passing it to ‘guix pack -RR -m’ yields a bundle where the “fakechroot”
execution engine is not supported for the ‘bin/hello’ script.
The explanation is in a TODO in (guix scripts pack):
(define (elf-loader-compile-flags program)
;; Return the cpp flags defining macros for the ld.so/fakechroot
;; wrapper of PROGRAM.
#$(if fakechroot?
;; TODO: Handle scripts by wrapping their interpreter.
#~(if (elf-file? program)
…
'())
#~'()))
I’m not entirely sure how to address it.
One workaround is to add ‘bash-minimal’ to the pack:
guix pack -RR bash-minimal …
… and then, on the target machine, to run Bash first:
GUIX_EXECUTION_ENGINE=fakechroot ./bin/sh -c ./bin/the-script
Ludo’.