[PATCH] gnu: Add sshguard.

  • Done
  • quality assurance status badge
Details
2 participants
  • ashish.is
  • Nicolas Goaziou
Owner
unassigned
Submitted by
ashish.is
Severity
normal
A
A
ashish.is wrote on 24 Jul 11:17 +0200
(address . guix-patches@gnu.org)(name . Ashish SHUKLA)(address . ashish.is@lostca.se)
3fa9d07b28c72ff84fed0a14931a35ed4f65188f.1721812638.git.ashish.is@lostca.se
From: Ashish SHUKLA <ashish.is@lostca.se>

* gnu/packages/admin.scm (sshguard): New variable.

Change-Id: I551771ff49af3e852322f2518f0758494aaedee3
---
gnu/packages/admin.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 113b8e2481..b5cfa25c62 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -6345,3 +6345,26 @@ (define-public rdfind
their content instead of their file names. It is useful for compressing
backup directories or just finding duplicate files.")
(license license:gpl2+)))
+
+(define-public sshguard
+ (package
+ (name "sshguard")
+ (version "2.4.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://bitbucket.org/sshguard/sshguard.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256 (base32 "1dkijr287zpwdz1bjdchxzmwf1sk6vzpkycz1skm25lkaba6nd9r"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ (list autoconf automake bison flex python-docutils))
+
+ (home-page "https://sshguard.net/")
+ (synopsis "Daemon to blocks SSH brute-force attacks")
+ (description "sshguard protects hosts from brute-force attacks against SSH and
+other services. It aggregates system logs and blocks repeat offenders using one of
+several firewall backends.")
+ (license license:isc)))

base-commit: d007b64356764f49677c78d82643f1125b5353b7
--
2.45.2
N
N
Nicolas Goaziou wrote on 20 Aug 10:53 +0200
(address . 72269-done@debbugs.gnu.org)(address . ashish.is@lostca.se)
87frqzo9sb.fsf@nicolasgoaziou.fr
Hello,

Toggle quote (4 lines)
> From: Ashish SHUKLA <ashish.is@lostca.se>
>
> * gnu/packages/admin.scm (sshguard): New variable.

Applied. Thank you.

Regards,
--
Nicolas Goaziou
Closed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 72269@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 72269
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch