[PATCH 0/2] gnu: Add cliphist

  • Done
  • quality assurance status badge
Details
2 participants
  • Sharlatan Hellseher
  • spencerpeters
Owner
unassigned
Submitted by
spencerpeters
Severity
normal
S
S
spencerpeters wrote on 23 Jul 03:50 +0200
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
2Xh3jxR4X-H20Km1eJ-UuepUFnzSjrrXIHERqcpL9aQBFgsJ8G5do6exhFd4uwKtGstaSQoB55L-_RIfB14_mLinHVdNVm1htiX07F1QdwM=@protonmail.com
This patch set adds the Wayland clipboard manager cliphist as well as the go
package go-go-senan-xyz-flagconf as a dependency.

Spencer Peters (2):
* gnu/packages/golang-xyz.scm (go-go-senan-xyz-flagconf): New
variable.
* gnu/packages/xdisorg.scm (cliphist): New variable.

gnu/packages/golang-xyz.scm | 29 ++++++++++++++++++++++++++++
gnu/packages/xdisorg.scm | 38 +++++++++++++++++++++++++++++++++++++
2 files changed, 67 insertions(+)

base-commit: b70893b5c2168a4d3a7f6a497fb36608900c83ae
--
2.45.2
Attachment: file
S
S
spencerpeters wrote on 23 Jul 03:56 +0200
[PATCH 1/2] gnu: Add go-go-senan-xyz-flagconf.
(name . 72247@debbugs.gnu.org)(address . 72247@debbugs.gnu.org)
cLHb2hSV-sIHjD2LQsk5OvNq74Xey7wwmzigmCbOZr9X3SFgkZiDg3Y1dtNMBDG79wg7GKIQp843-bc5nshGoHLwPUUlgQnAMjTo-kLuv-k=@protonmail.com
From: Spencer Peters <spencerpeters@protonmail.com>

* gnu/packages/golang-xyz.scm (go-go-senan-xyz-flagconf): New variable.

Change-Id: Iaa14ace540e82405876ad48e807d246f9fbdd00a
---
gnu/packages/golang-xyz.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 9931911e32..8cdef56b7b 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -37,6 +37,7 @@
;;; Copyright © 2024 Jesse Eisses <jesse@eisses.email>
;;; Copyright © 2024 Troy Figiel <troy@troyfigiel.com>
;;; Copyright © 2024 Luis Higino <luishenriquegh2701@gmail.com>
+;;; Copyright © 2024 Spencer Peters <spencerpeters@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -5027,6 +5028,34 @@ (define-public go-go-etcd-io-bbolt
Postgres or MySQL.")
(license license:expat)))

+(define-public go-go-senan-xyz-flagconf
+ (package
+ (name "go-go-senan-xyz-flagconf")
+ (version "0.1.9")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sentriz/flagconf")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1rms7hj1cdi5gfyhf1am1f8c4lq9ll4ashqi87yc6aq93gqgkag0"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ ;; Won't build with any version less than 1.20
+ #:go go-1.22
+ #:import-path "go.senan.xyz/flagconf"))
+ (propagated-inputs (list go-github-com-rogpeppe-go-internal
+ go-golang-org-x-sys go-golang-org-x-tools))
+ (home-page "https://go.senan.xyz/flagconf")
+ (synopsis "Extensions to Go's flag package")
+ (description
+ "Flagconf provides extensions to Go's flag package to support prefixed
+environment variables and a simple config file format.")
+ (license license:expat)))
+
(define-public go-go-uber-org-atomic
(package
(name "go-go-uber-org-atomic")
--
2.45.2
Attachment: file
S
S
spencerpeters wrote on 23 Jul 03:57 +0200
[PATCH 2/2] * gnu/packages/xdisorg.scm (cliphist): New variable.
(name . 72247@debbugs.gnu.org)(address . 72247@debbugs.gnu.org)
euLr-KplaJ9wwObJtkWdE1NnScXBCDz6x64K_8M_zlPM9A5oAtoSNUBsNG3E3JeHTSQX5-cz1e2tEKxtfbWIgyZN5lKuEdiUM42BtHerQy8=@protonmail.com
From: Spencer Peters <spencerpeters@protonmail.com>
* gnu/packages/xdisorg.scm (cliphist): New variable.

Change-Id: I33d71b9739158101638b66827592d1c3cbb1b443
---
gnu/packages/xdisorg.scm | 38 ++++++++++++++++++++++++++++++++++++++
1 file changed, 38 insertions(+)

Toggle diff (60 lines)
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 4c12835b24..cdd196e35d 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -63,6 +63,7 @@
;;; Copyright © 2022 Mehmet Tekman <mtekman89@gmail.com>
;;; Copyright © 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
;;; Copyright © 2024 Igor Goryachev <igor@goryachev.org>
+;;; Copyright © 2024 Spencer Peters <spencerpeters@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -116,6 +117,8 @@ (define-module (gnu packages xdisorg)
#:use-module (gnu packages gl)
#:use-module (gnu packages gl)
#:use-module (gnu packages glib)
+ #:use-module (gnu packages golang)
+ #:use-module (gnu packages golang-build)
#:use-module (gnu packages golang-xyz)
#:use-module (gnu packages gnome)
#:use-module (gnu packages gtk)
@@ -3852,3 +3855,38 @@ (define-public xxkb
accepts events from XKB. That means that it will work with the existing
setup of your X Server without any modifications.")
(license license:artistic2.0)))
+
+(define-public cliphist
+ (package
+ (name "cliphist")
+ (version "0.5.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sentriz/cliphist")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1cbhrw9vk8c0in9yyhlp0k9rldgjwbcj00d7vqh69p3igznhdgsk"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:go go-1.22
+ #:import-path "go.senan.xyz/cliphist"))
+ (inputs (list go-github-com-rogpeppe-go-internal
+ go-go-etcd-io-bbolt
+ go-go-senan-xyz-flagconf
+ go-golang-org-x-image
+ go-golang-org-x-sys
+ go-golang-org-x-tools
+ wl-clipboard
+ xdg-utils))
+ (synopsis "Clipboard history manager for wayland with support for images")
+ (description
+ "A Wayland clipboard history manager. It can write clipboard changes to a
+history file, recall history with any picker which accepts input from
+stdin (including dmenu, rofi, and wofi), copy and past both images and text,
+and preserve leading and trailing whitespace.")
+ (home-page "https://github.com/sentriz/cliphist")
+ (license license:gpl3)))
--
2.45.2
Attachment: file
S
S
Sharlatan Hellseher wrote on 29 Jul 00:24 +0200
[PATCH 0/2] gnu: Add cliphist
(address . 72247@debbugs.gnu.org)
874j89noiw.fsf@gmail.com
Hi,

Thank you for the patches.

May you adjust indentation as a first part of improvement for v2, please?
If you are Emacs user, select the region and apply function
`indent-region' (C-M-\), or try to use `guix import go <module-name>`.

- Try to build with current default go version which is 1.21
- If it's an executable command, please add `#:install-source #f` and
place all Golang modules to [native-inputs]
- Do not start description with article
- Place [home-page] above [synopsis] field.

---
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmamxRcACgkQdtcnv/Ys
0rWasA/+JVgVpadXznNocgbO3h0Uijh4IzraFn+XRWNdCpOntrjof9tGznUIoGOE
BWUCor1oHvPt/so54oCKqXRopp8D5DxaaoG74TIRO2vmznLAmgPkeCShWS0K4ZzA
KJEVLhbYEzrIQa3fKjkcG5lCKGEBGgnGhgGzzxB6WNGaJXRrOYWGDlpK0t0NsCUi
GiO/4U/rVuLsy5G8t1fmUy05jXVohQwYlz2ywgBT70cFLO4n/4z7wh0vdWgrcu04
Dergtn6NYTQOi+sJ5ZugaBWOVfmuv9n18UlxOMxGEznUZeUgFOxuwl7gM1L50BDA
DtyJGXiPjqZ6TFKQVAURKSJRvPqKdplH1c+sPSjhR8JmizORnm1QjwqKfl3g7Xo/
t0ZNMVgg88GaEZ1THukwwm6ql4QZDpIwQ+wJR+TE2pZaJhZinUvxBir8oOGcgbDK
whKm3/39LT6VjDfGdxFO9pNKmxDQKh4Ou+GSsQAdp6E7bFhkGvZH0pg7YABZXS1e
yotkJLZ68GBEp1inBsHgq9a6UsAu4wmPaIwmflLQlEtSMePBzILO2Al6QFmsrt5/
6m7D0juFUtJSHWIIL5nMLf9sXtZPrB7ua2ugVtnsdC0XE0WABgS11U54tYkrDhJK
fpM/SGpmW7PlLZlc+92tUbWl2bn4/b4mPNRt9DKfMJBnrpuAnlQ=
=f0WP
-----END PGP SIGNATURE-----

S
S
spencerpeters wrote on 11 Aug 23:25 +0200
[PATCH 1/2] gnu: Add go-go-senan-xyz-flagconf
(name . 72247@debbugs.gnu.org)(address . 72247@debbugs.gnu.org)
GIazstlpNqB5rxdGo_SnQh3-IBuBwCXJJ-dbml8r2IKkLNQqj_VLFRbpNSRtOVczJgfZwG0wRmHTbhZu9mLvHfBnnP-y1d9V2J8w423deWo=@protonmail.com
I've fixed the inputs for go-go-senan-xyz-flagconf and cliphist and I've updated the build-system arguments as well as the [synopsis] and [description] fields for cliphist. I believe the formatting issues were caused by my email client--hopefully this time it doesn't mess up the indentation again.

Best, Spencer

* gnu/packages/golang-xyz.scm (go-go-senan-xyz-flagconf): New variable.

Change-Id: I3edcda63ca09e1370be4da8c6926bacde5d66cbf
---
gnu/packages/golang-xyz.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (49 lines)
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 32b904c59c..22f5124d7c 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -39,6 +39,7 @@
;;; Copyright © 2024 Jesse Eisses <jesse@eisses.email>
;;; Copyright © 2024 Luis Higino <luishenriquegh2701@gmail.com>
;;; Copyright © 2024 Troy Figiel <troy@troyfigiel.com>
+;;; Copyright © 2024 Spencer Peters <spencerpeters@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -5527,6 +5528,34 @@ (define-public go-go-etcd-io-bbolt
Postgres or MySQL.")
(license license:expat)))
+(define-public go-go-senan-xyz-flagconf
+ (package
+ (name "go-go-senan-xyz-flagconf")
+ (version "0.1.9")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sentriz/flagconf")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1rms7hj1cdi5gfyhf1am1f8c4lq9ll4ashqi87yc6aq93gqgkag0"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:go go-1.21
+ #:import-path "go.senan.xyz/flagconf"))
+ (propagated-inputs (list go-github-com-rogpeppe-go-internal
+ go-golang-org-x-sys
+ go-golang-org-x-tools))
+ (home-page "https://go.senan.xyz/flagconf")
+ (synopsis "Extensions to Go's flag package")
+ (description
+ "Flagconf provides extensions to Go's flag package to support prefixed
+environment variables and a simple config file format.")
+ (license license:expat)))
+
(define-public go-go-uber-org-atomic
(package
(name "go-go-uber-org-atomic")
--
2.45.2
S
S
spencerpeters wrote on 11 Aug 23:26 +0200
[PATCH 2/2] gnu: Add cliphist.
(name . 72247@debbugs.gnu.org)(address . 72247@debbugs.gnu.org)
_z2g87KPTaENt8vn0XD-oblOojO4svWJuzwsktu2q-6rBa_9HPEbGnEjLwqaad92DvgbjHJvV8AMVZEwhKoX7dAJ0it7r-TrBrwcmsaPGhU=@protonmail.com
* gnu/packages/xdisorg.scm (cliphist): New variable.


Change-Id: Ic165a6b92d7c30ee8d8ad9aa0f92cfdc198d94a5
---
gnu/packages/xdisorg.scm | 37 +++++++++++++++++++++++++++++++++++++
1 file changed, 37 insertions(+)

Toggle diff (61 lines)
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 4c12835b24..a9459440b0 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -63,6 +63,7 @@
;;; Copyright © 2022 Mehmet Tekman <mtekman89@gmail.com>
;;; Copyright © 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
;;; Copyright © 2024 Igor Goryachev <igor@goryachev.org>
+;;; Copyright © 2024 Spencer Peters <spencerpeters@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -116,6 +117,8 @@ (define-module (gnu packages xdisorg)
#:use-module (gnu packages gl)
#:use-module (gnu packages gl)
#:use-module (gnu packages glib)
+ #:use-module (gnu packages golang)
+ #:use-module (gnu packages golang-build)
#:use-module (gnu packages golang-xyz)
#:use-module (gnu packages gnome)
#:use-module (gnu packages gtk)
@@ -3852,3 +3855,37 @@ (define-public xxkb
accepts events from XKB. That means that it will work with the existing
setup of your X Server without any modifications.")
(license license:artistic2.0)))
+
+(define-public cliphist
+ (package
+ (name "cliphist")
+ (version "0.5.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sentriz/cliphist")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1cbhrw9vk8c0in9yyhlp0k9rldgjwbcj00d7vqh69p3igznhdgsk"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:install-source? #f
+ #:go go-1.21
+ #:import-path "go.senan.xyz/cliphist"))
+ (native-inputs (list go-github-com-rogpeppe-go-internal
+ go-go-etcd-io-bbolt
+ go-go-senan-xyz-flagconf
+ go-golang-org-x-image
+ go-golang-org-x-sys
+ go-golang-org-x-tools))
+ (home-page "https://github.com/sentriz/cliphist")
+ (synopsis "Clipboard history manager for wayland with support for images")
+ (description
+ "A Wayland clipboard history manager. It can write clipboard changes to a
++history file, recall history with any picker which accepts input from
++stdin (including dmenu, rofi, and wofi), copy and past both images and text,
++and preserve leading and trailing whitespace.")
+ (license license:gpl3)))
--
2.45.2
S
S
Sharlatan Hellseher wrote on 27 Aug 01:38 +0200
[PATCH 0/2] gnu: Add cliphist
(address . 72247-done@debbugs.gnu.org)
87h6b6c0s5.fsf@gmail.com
Pushed as a84f26f0af..61656d3f61 to master with minor modifications.

--
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmbNEgoACgkQdtcnv/Ys
0rV3yw/+KNCgNY3oaA2rItivPTo+XkdkcnWxOHYyICc8Hma03qQdam+g+ZMMaFvD
YYnY6yBxrEQ8Y4AtcEhfUNio95Zu1HsrgVTfoPAkB0bvUU2uGJBW8J5pg1oOf5O6
6NxVwBDL9WtzDFCpSPG3EG9025LcD7LH8HhROowNYk8ilo2rihMkW6peVK601vkd
bWnypdCQEsUW82I1YWWN8/HTQAnni10YpfDV1t5XyrwqpawtgvhV0f6lh1zAG1cn
Pla7FhG+l1DUbrQTWQ8yo/U0S7OknaXoKod7APzlFE9y4Gvbnve3eS0mHaH6JFD/
t0NtDzsE+Nn3NmTSznuFXvO4765wNabL3C84mnBA8F3KfVbSl1UejxI/SuDjmJ6d
YQNE6v7rSvVL6INP0jGd1hY/CFYZ2qohEg4yWNCyz1Gg5EAuvzX2Vj6A1YmEzTpL
sGTLDQjrNIgSDUbU06eDgesuXo24l8dMju5JZsnrbPcu07+tatNNgl4ZBeTdUmmh
bVYvkRjJUxvXskhVuzz/sPWpaeMXa+PjstKBwtWBBNXfi5d+AKT0KK0WesT/RSiS
IU+pTg4TQTdxzJg5lAh1T7mryL3w/m6IZdqjLNQiFnqA/Fn+PhUDtXC5ZpKOtk6U
+rVMHFuGxLXCPBkPOXhVxBjh5+v8HBK7Giv4r4Q7OpUbq4beHxo=
=1YGr
-----END PGP SIGNATURE-----

Closed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 72247@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 72247
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch