[PATCH] gnu: Add emacs-org-remark.

  • Done
  • quality assurance status badge
Details
2 participants
  • Juliana Sims
  • Vinicius Monego
Owner
unassigned
Submitted by
Vinicius Monego
Severity
normal
V
V
Vinicius Monego wrote on 21 Jul 18:11 +0200
(address . guix-patches@gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
adea8b6eb689cc1a08e8d383eb98e33d11f543c5.1721577724.git.monego@posteo.net
* gnu/packages/emacs-xyz.scm (emacs-org-remark): New variable.

Change-Id: If7c5cca824f9b9a0c3f7fb0d39d0f73f0fe52460
---
This package was also submitted in issue 54238.

gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 3f987f8ae6..12450e103f 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -15196,6 +15196,28 @@ (define-public emacs-centaur-tabs
efficient tabs plugin for Emacs with a lot of customization options.")
(license license:gpl3+)))
+(define-public emacs-org-remark
+ (package
+ (name "emacs-org-remark")
+ (version "1.2.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/nobiot/org-remark")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1b6nmd64jzy6a7fz4x5p276sl36xa72y3ajbl72vr5ndqp94rlz1"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ (list emacs-org))
+ (home-page "https://nobiot.github.io/org-remark/")
+ (synopsis "Highlight & annotate text using Org mode")
+ (description "Org-remark lets you highlight and annotate text files,
+websites, EPUB books and Info documentation with using Org mode.")
+ (license license:gpl3+)))
+
(define-public emacs-mocker
(package
(name "emacs-mocker")

base-commit: 81904c16aed72bb8ea1449587418d2a218d0b103
--
2.39.2
J
J
Juliana Sims wrote on 22 Jul 03:38 +0200
QA review for 72231
(address . monego@posteo.net)(address . 72231@debbugs.gnu.org)
SK40HS.DODK26GRZCYX@incana.org
Hello,

This patch looks pretty good! Things build fine, don't break pull,
etc. etc. QA has a failure applying the patch, but I had no issues
apply on top of e5c0b62debc. There is one small issue I see: the
description. That "with using" bit should be cleaned up. Also, it may
be worthwhile to include more information. There appears to be a
"Features" section of the README which can provide some ideas.

Also, feel free to update your license line if you like :)

Best,
Juli

PS this new QA web interface is snazzy! It even gave me a little
checklist :D

Items marked as checked: Lint warnings, Package builds, Commit
messages, New package licenses, New package tests
V
V
Vinicius Monego wrote on 28 Jul 17:37 +0200
(name . Juliana Sims)(address . juli@incana.org)(address . 72231-done@debbugs.gnu.org)
9a60170b48e37dfa031ea5829902f900f3a8544d.camel@posteo.net
Em dom, 2024-07-21 às 21:38 -0400, Juliana Sims escreveu:
Toggle quote (23 lines)
> Hello,
>
> This patch looks pretty good!  Things build fine, don't break pull,
> etc. etc.  QA has a failure applying the patch, but I had no issues
> apply on top of e5c0b62debc.  There is one small issue I see: the
> description.  That "with using" bit should be cleaned up.  Also, it
> may
> be worthwhile to include more information.  There appears to be a
> "Features" section of the README which can provide some ideas.
>
> Also, feel free to update your license line if you like :)
>
> Best,
> Juli
>
> PS this new QA web interface is snazzy!  It even gave me a little
> checklist :D
>
> Items marked as checked: Lint warnings, Package builds, Commit
> messages, New package licenses, New package tests
>
>

Hi Juli,

I applied your suggestions and pushed the patch, thanks.

Vinicius
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 72231@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 72231
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch