(address . guix-patches@gnu.org)(name . Gisement)(address . sisiutl@egregore.fun)
* gnu/packages/protobuf.scm (python-protobuf): Update to 5.27.2.
[arguments]: <#:configure-flags>: Remove cpp_implementation flag.
[arguments]: <#:tests>: Disable tests.
Change-Id: I80f94517603033d2176c9958a87fcea116747a5c
---
gnu/packages/protobuf.scm | 10 ++++------
1 file changed, 4 insertions(+), 6 deletions(-)
Toggle diff (34 lines)
diff --git a/gnu/packages/protobuf.scm b/gnu/packages/protobuf.scm
index d47b67fa61..75a5dc57ae 100644
--- a/gnu/packages/protobuf.scm
+++ b/gnu/packages/protobuf.scm
@@ -429,21 +429,19 @@ (define-public python-nanopb
(define-public python-protobuf
(package
(name "python-protobuf")
- (version "3.20.2")
+ (version "5.27.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "protobuf" version))
(sha256
(base32
- "0l0p2lczs5iahgkhzm3298pjl49bk9iiwngkglg7ll7fkqqwlbbi"))))
+ "0517bvr76daiwnz3jb099mckmklh5kzjg0pjfmh8bbxr4vrdxv7k"))))
(build-system python-build-system)
(inputs (list protobuf))
(arguments
- `(;; Favor C++ implementation from protobuf over the native Python
- ;; implementation. The additional dependency yields significant
- ;; performance improvements for some workloads.
- #:configure-flags '("--cpp_implementation")))
+ ;; There are no tests
+ '(#:tests? #f))
(home-page "https://github.com/google/protobuf")
(synopsis "Protocol buffers is a data interchange format")
(description
base-commit: 1fa4d658d808202f98003d1488f8e44daee370a9
--
2.45.2