(address . guix-patches@gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
* guix.lint.scm (check-inputs-should-not-be-an-input-at-all): Add
python-black, python-coverage, python-flake8, python-mypy, python-pycodestyle,
python-pyflakes, python-pylint, python-pytest-cov, python-yapf.
Change-Id: I4e7071f21b84313a117c4487d5977adbb91efe92
---
There are several flake8 extensions too which could be added.
guix/lint.scm | 13 +++++++++++--
1 file changed, 11 insertions(+), 2 deletions(-)
Toggle diff (29 lines)
diff --git a/guix/lint.scm b/guix/lint.scm
index 7612832a5a..49e9b73676 100644
--- a/guix/lint.scm
+++ b/guix/lint.scm
@@ -586,9 +586,18 @@ (define (check-inputs-should-be-native package)
(define (check-inputs-should-not-be-an-input-at-all package)
;; Emit a warning if some inputs of PACKAGE are likely to should not be
;; an input at all.
- (let ((input-names '("python-setuptools"
+ (let ((input-names '("python-black"
+ "python-coverage"
+ "python-flake8"
+ "python-mypy"
"python-pip"
- "python-pre-commit")))
+ "python-pre-commit"
+ "python-pycodestyle"
+ "python-pyflakes"
+ "python-pylint"
+ "python-pytest-cov"
+ "python-setuptools"
+ "python-yapf")))
(map (lambda (input)
(make-warning
package
base-commit: 9df5289c6687cd5688c275d16417389fbab6d384
--
2.39.2