[PATCH] lint: check-inputs-should-not-be-an-input-at-all: Add more packages.

  • Open
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Vinicius Monego
Owner
unassigned
Submitted by
Vinicius Monego
Severity
normal
V
V
Vinicius Monego wrote on 20 Jul 13:09 +0200
(address . guix-patches@gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
d94f5587e54d21e681f72bafaa3f9ec3552bc725.1721473565.git.monego@posteo.net
* guix.lint.scm (check-inputs-should-not-be-an-input-at-all): Add
python-black, python-coverage, python-flake8, python-mypy, python-pycodestyle,
python-pyflakes, python-pylint, python-pytest-cov, python-yapf.

Change-Id: I4e7071f21b84313a117c4487d5977adbb91efe92
---
There are several flake8 extensions too which could be added.

guix/lint.scm | 13 +++++++++++--
1 file changed, 11 insertions(+), 2 deletions(-)

Toggle diff (29 lines)
diff --git a/guix/lint.scm b/guix/lint.scm
index 7612832a5a..49e9b73676 100644
--- a/guix/lint.scm
+++ b/guix/lint.scm
@@ -586,9 +586,18 @@ (define (check-inputs-should-be-native package)
(define (check-inputs-should-not-be-an-input-at-all package)
;; Emit a warning if some inputs of PACKAGE are likely to should not be
;; an input at all.
- (let ((input-names '("python-setuptools"
+ (let ((input-names '("python-black"
+ "python-coverage"
+ "python-flake8"
+ "python-mypy"
"python-pip"
- "python-pre-commit")))
+ "python-pre-commit"
+ "python-pycodestyle"
+ "python-pyflakes"
+ "python-pylint"
+ "python-pytest-cov"
+ "python-setuptools"
+ "python-yapf")))
(map (lambda (input)
(make-warning
package

base-commit: 9df5289c6687cd5688c275d16417389fbab6d384
--
2.39.2
L
L
Ludovic Courtès wrote on 5 Sep 08:43 +0200
(name . Vinicius Monego)(address . monego@posteo.net)(address . 72206@debbugs.gnu.org)
87v7zaa9dq.fsf@gnu.org
Hi Vinicius,

Vinicius Monego <monego@posteo.net> skribis:

Toggle quote (8 lines)
> * guix.lint.scm (check-inputs-should-not-be-an-input-at-all): Add
> python-black, python-coverage, python-flake8, python-mypy, python-pycodestyle,
> python-pyflakes, python-pylint, python-pytest-cov, python-yapf.
>
> Change-Id: I4e7071f21b84313a117c4487d5977adbb91efe92
> ---
> There are several flake8 extensions too which could be added.

I’m not a Python person but I this looks reasonable to me. I think you
can go ahead and push.

Ludo’.
L
L
Ludovic Courtès wrote on 5 Sep 08:43 +0200
(name . Vinicius Monego)(address . monego@posteo.net)(address . 72206@debbugs.gnu.org)
87tteua9dg.fsf@gnu.org
Hi Vinicius,

Vinicius Monego <monego@posteo.net> skribis:

Toggle quote (8 lines)
> * guix.lint.scm (check-inputs-should-not-be-an-input-at-all): Add
> python-black, python-coverage, python-flake8, python-mypy, python-pycodestyle,
> python-pyflakes, python-pylint, python-pytest-cov, python-yapf.
>
> Change-Id: I4e7071f21b84313a117c4487d5977adbb91efe92
> ---
> There are several flake8 extensions too which could be added.

I’m not a Python person but this looks reasonable to me. I think you
can go ahead and push.

Ludo’.
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 72206@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 72206
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch