[PATCH] gnu: Add tree-sitter-prisma.

  • Done
  • quality assurance status badge
Details
2 participants
  • jgart
  • rprior
Owner
unassigned
Submitted by
rprior
Severity
normal
R
R
rprior wrote on 20 Jul 00:01 +0200
(address . guix-patches@gnu.org)(name . Ryan Prior)(address . rprior@protonmail.com)
cb118c649fdb316301956ccb3f6702839c48fa0a.1721423607.git.rprior@protonmail.com
From: Ryan Prior <rprior@protonmail.com>

* gnu/packages/tree-sitter.scm (tree-sitter-prisma): New variable.

Change-Id: I9ecc20053d498244ed5c41df9a03790a7d25b2b4
---
gnu/packages/tree-sitter.scm | 8 ++++++++
1 file changed, 8 insertions(+)

Toggle diff (23 lines)
diff --git a/gnu/packages/tree-sitter.scm b/gnu/packages/tree-sitter.scm
index eb72b415ee..2f6e6809d7 100644
--- a/gnu/packages/tree-sitter.scm
+++ b/gnu/packages/tree-sitter.scm
@@ -531,6 +531,14 @@ (define-public tree-sitter-php
(git-version "0.19.0" revision commit)
#:commit commit)))
+(define-public tree-sitter-prisma
+ (tree-sitter-grammar
+ "prisma" "Prisma"
+ "19zb3dkwp2kpyivygqxk8yph0jpl7hn9zzcry15mshn2n0rs9sih"
+ "1.4.0"
+ #:repository-url "https://github.com/victorhqc/tree-sitter-prisma"
+ #:license license:expat))
+
(define-public tree-sitter-python
(tree-sitter-grammar
"python" "Python"

base-commit: 158dc76f94fd7ffae2e31fb97619be4342bfed7b
--
2.45.2
J
(address . 72201-done@debbugs.gnu.org)(address . rprior@protonmail.com)
874j8luj6t.fsf@dismail.de
Hi Ryan,

Thanks for contributing to GNU Guix
--
all the best,
jgart
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 72201@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 72201
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch