[PATCH] gnu: services: power-profiles-daemon: Beautify service.

  • Open
  • quality assurance status badge
Details
One participant
  • Dariqq
Owner
unassigned
Submitted by
Dariqq
Severity
normal
D
D
Dariqq wrote on 18 Jul 21:28 +0200
(address . guix-patches@gnu.org)(name . Dariqq)(address . dariqq@posteo.net)
01c0b4ce7e4f714d1a4e79e33e9ee994effe567a.1721330886.git.dariqq@posteo.net
* gnu/services/pm.scm (power-profiles-daemon-shepherd-service): Change indentation.
[requirement]: Add user-processes.
[documentation]: Change name to Power Profiles Daemon.

(power-profiles-daemon-service-type)
[description]: Change name to Power Profiles Daemon.

Change-Id: Ibbd06cf1fbadd812ad3f0eac92b9772e3387f875
---

Addressing some of the feedpack I got after the original patch #70460 was already pushed: Changing power-profiles-daemon to Power Profiles Daemon in descriptons and make the service require user-processes. Also let the indentation of the shepherd service match other services.

gnu/services/pm.scm | 19 ++++++++++---------
1 file changed, 10 insertions(+), 9 deletions(-)

Toggle diff (41 lines)
diff --git a/gnu/services/pm.scm b/gnu/services/pm.scm
index 47f0bf7812..5e8e7efda2 100644
--- a/gnu/services/pm.scm
+++ b/gnu/services/pm.scm
@@ -52,14 +52,15 @@ (define (power-profiles-daemon-shepherd-service config)
(match-record
config <power-profiles-daemon-configuration>
(power-profiles-daemon)
- (list (shepherd-service
- (provision '(power-profiles-daemon))
- (requirement '(dbus-system))
- (documentation "Run the power-profiles-daemon.")
- (start #~(make-forkexec-constructor
- (list #$(file-append power-profiles-daemon
- "/libexec/power-profiles-daemon"))))
- (stop #~(make-kill-destructor))))))
+ (list
+ (shepherd-service
+ (provision '(power-profiles-daemon))
+ (requirement '(user-processes dbus-system))
+ (documentation "Run the Power Profiles Daemon.")
+ (start #~(make-forkexec-constructor
+ (list #$(file-append power-profiles-daemon
+ "/libexec/power-profiles-daemon"))))
+ (stop #~(make-kill-destructor))))))
(define %power-profiles-daemon-activation
#~(begin
@@ -83,7 +84,7 @@ (define power-profiles-daemon-service-type
(service-extension activation-service-type
(const %power-profiles-daemon-activation))))
(default-value (power-profiles-daemon-configuration))
- (description "Run the power-profiles-daemon"))))
+ (description "Run the Power Profiles Daemon"))))

base-commit: e3dfed59d39ac60dd2e2b9ef9f4ef63a2a081f41
--
2.45.2
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 72181@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 72181
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch