[PATCH 0/2] gnu: mpv: Update to 0.38.0 and include sixel support.

  • Done
  • quality assurance status badge
Details
3 participants
  • Z572
  • Nicolas Goaziou
  • Mathieu Laparie
Owner
unassigned
Submitted by
Mathieu Laparie
Severity
normal
M
M
Mathieu Laparie wrote on 18 Jul 19:55 +0200
(address . guix-patches@gnu.org)(name . Mathieu Laparie)(address . matf@disr.it)
20240718175531.14620-1-matf@disr.it
I needed sixel support in mpv and noticed our package did not include it, and updated to 0.38.0 while I was at it. This inmplied upgrading libplacebo to 6.338.2, but 7.349.0 is available and works too, so I jumped to that version. mpv 0.38.0 comes with a number of improvements on top of the sixel support included here, among which better playlist display in terminal (was previously garbled with broken character sequences hardcoded from the OSD), support for --input-commands to run commands at startup, zooming on Ctrl+wheel, etc.

The pkg-config name of libsixel seems to be gdk-pixbuf, and it appeared that adding just libsixel in inputs was not enough for mpv to build with sixel support.

Mathieu Laparie (2):
gnu: libplacebo: Update to 7.349.0.
gnu: mpv: Update to 0.38.0, include sixel support.

gnu/packages/video.scm | 10 ++++++----
1 file changed, 6 insertions(+), 4 deletions(-)

--
2.45.2
M
M
Mathieu Laparie wrote on 18 Jul 19:57 +0200
[PATCH 1/2] gnu: libplacebo: Update to 7.349.0.
(address . 72180@debbugs.gnu.org)(name . Mathieu Laparie)(address . mathieu.laparie@inrae.fr)
20240718175748.15598-1-matf@disr.it
From: Mathieu Laparie <mathieu.laparie@inrae.fr>

* gnu/pacakges/video.scm (libplacebo): Update to 7.349.0.
---
gnu/packages/video.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 8728da1775..c7470284dc 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1549,7 +1549,7 @@ (define-public libmatroska
(define-public libplacebo
(package
(name "libplacebo")
- (version "6.338.1")
+ (version "7.349.0")
(source
(origin
(method git-fetch)
@@ -1558,7 +1558,7 @@ (define-public libplacebo
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1miqk3gfwah01xkf4a6grwq29im0lfh94gp92y7js855gx3v169m"))))
+ (base32 "1q12yf04z570a2l3vkig2iqm7bgqr90hdxmn78sk2injrsyx124q"))))
(build-system meson-build-system)
(arguments
(list #:configure-flags
--
2.45.2
M
M
Mathieu Laparie wrote on 18 Jul 19:58 +0200
[PATCH 2/2] gnu: mpv: Update to 0.38.0, include sixel support.
(address . 72180@debbugs.gnu.org)(name . Mathieu Laparie)(address . mathieu.laparie@inrae.fr)
20240718175803.15719-1-matf@disr.it
From: Mathieu Laparie <mathieu.laparie@inrae.fr>

* gnu/packages/video.scm (mpv): Update to 0.38.0, include sixel support.
[inputs] Add gdk-pixbuf, libsixel.
---
gnu/packages/video.scm | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)

Toggle diff (36 lines)
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index c7470284dc..3a715cce6a 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -2618,7 +2618,7 @@ (define-public mplayer
(define-public mpv
(package
(name "mpv")
- (version "0.37.0")
+ (version "0.38.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -2626,7 +2626,7 @@ (define-public mpv
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1xcyfpd543lbmg587wi0mahrz8vhyrlr4432054vp6wsi3s36c4b"))))
+ (base32 "11l8b9cka81xwrcc148g6avj7jcz8khz3h3xpyadm5265afa6mkl"))))
(build-system meson-build-system)
(arguments
(list
@@ -2658,9 +2658,11 @@ (define-public mpv
;; Missing features: libguess, V4L2.
(inputs
(list enca
+ gdk-pixbuf
ladspa
lcms
libbs2b
+ libsixel
mpg123
rsound
vulkan-headers
--
2.45.2
Z
Re: [bug#72180] [PATCH 0/2] gnu: mpv: Update to 0.38.0 and include sixel support.
(name . Mathieu Laparie)(address . matf@disr.it)(address . 72180@debbugs.gnu.org)
tencent_172059417F073A84E558255CB5419BB5A908@qq.com
Mathieu Laparie <matf@disr.it> writes:

Toggle quote (4 lines)
> I needed sixel support in mpv and noticed our package did not include it, and updated to 0.38.0 while I was at it. This inmplied upgrading libplacebo to 6.338.2, but 7.349.0 is available and works too, so I jumped to that version. mpv 0.38.0 comes with a number of improvements on top of the sixel support included here, among which better playlist display in terminal (was previously garbled with broken character sequences hardcoded from the OSD), support for --input-commands to run commands at startup, zooming on Ctrl+wheel, etc.
>
> The pkg-config name of libsixel seems to be gdk-pixbuf, and it appeared that adding just libsixel in inputs was not enough for mpv to build with sixel support.

I think should move gdk-pixbuf to libsixel's propagated-inputs, and add
a comment say gdk-pixbuf pkg-config's “Requires.private” need
gdk-pixbuf, and add a TODO for "remove it when we use pkgconf."

Toggle quote (7 lines)
>
> Mathieu Laparie (2):
> gnu: libplacebo: Update to 7.349.0.
> gnu: mpv: Update to 0.38.0, include sixel support.
>
> gnu/packages/video.scm | 10 ++++++----
> 1 file changed, 6 insertions(+), 4 deletions(-)
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEfr6klGDOXiwIdX/bO1qpk+Gi3/AFAmaajGgACgkQO1qpk+Gi
3/C0fg/9EnVe/TYxwfFVuu4VpZ1I28latPzDgW2oV2MBCd9CljH4XbNPGcu9BAGM
74MrhN8JH14N+y3B1AgkcFZ3/X8Y33sEelTPBU07Fn+UWShHlu/iZnRbaqSnLz8D
kpXltjglGkgNTFCchoAxSJD42yFU0flvs2NlBlQJbOlq+n2wnYUhbg23oyKeZXDd
hzk8Dt6f67xBxclI77+s90y3mNSXQiCK31ntLukVrbqh5o7ghoeQZ9fkTPUFhpjg
5wrthNmi/gzqOJSTCWtwOVmlavQiou40Wj2l8F3rCvQzyruscRoq75XUGnGV4PpM
THhxd6nJ5sWgbeI3VxQVgrHsrnlrFsLhjgTOrqfGFB1dc1/blp2YoA93e/jGJNTV
nJXgBECLueFwvXbLIkoEgp9AHZIUvikD7ZMbAYb48w6KHgIp2okAlsNJ4cGZaJ2X
TsiD+65DI13LJkzKHVFZLmVVHQOqIckNwjuXXx6snry28ufq7KkslxBlX1VEgJo7
S2t3ms2AQn6s3tLv/MIfm2I3+KhlmDfeO9zJcCG/VFgjxYtODn8qkAnt+2X/fK9C
Oqv5jd69RuGSZNqi08z2J6oVpZFl7gnFfb7g3acooXHMbSYLRCPyKUkoIkvROFK8
Dw+3eQwaTId5QCbzf8SMYSKzzW8YG9DNZpg8mgjJLIpe20UDrHE=
=0SxO
-----END PGP SIGNATURE-----

N
N
Nicolas Goaziou wrote 2 days ago
Re: [PATCH 0/2] gnu: mpv: Update to 0.38.0 and include sixel support.
(address . 72180-done@debbugs.gnu.org)
878qw5q26o.fsf@nicolasgoaziou.fr
Hello,

Toggle quote (10 lines)
> Mathieu Laparie <matf@disr.it> writes:
>
> > I needed sixel support in mpv and noticed our package did not include it, and updated to 0.38.0 while I was at it. This inmplied upgrading libplacebo to 6.338.2, but 7.349.0 is available and works too, so I jumped to that version. mpv 0.38.0 comes with a number of improvements on top of the sixel support included here, among which better playlist display in terminal (was previously garbled with broken character sequences hardcoded from the OSD), support for --input-commands to run commands at startup, zooming on Ctrl+wheel, etc.
> >
> > The pkg-config name of libsixel seems to be gdk-pixbuf, and it appeared that adding just libsixel in inputs was not enough for mpv to build with sixel support.
>
> I think should move gdk-pixbuf to libsixel's propagated-inputs, and add
> a comment say gdk-pixbuf pkg-config's “Requires.private” need
> gdk-pixbuf, and add a TODO for "remove it when we use pkgconf."

Thank you. I applied the patch with the suggestions above. MPV had
already been updated, tho.

Regards,
--
Nicolas Goaziou
Closed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 72180@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 72180
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch