linux-libre packaging: Learn to apply deblob script "errata" patches

  • Open
  • quality assurance status badge
Details
One participant
  • Leo Famulari
Owner
unassigned
Submitted by
Leo Famulari
Severity
normal
L
L
Leo Famulari wrote on 17 Jul 21:59 +0200
(address . guix-patches@gnu.org)
ZpgionBKzgvcSNup@jasmine.lan
This adds the capability to apply "errata" patches to the linux-libre deblobbing scripts, which is necessary for linux-libre 6.10:

-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEaEByLu7k06ZO5T6saqwZY3V/R/8FAmaYIqIACgkQaqwZY3V/
R/9/NQ/8DI8mp3QwJ4mBiRrNdnkt1iY741Imfx+/G8I439gzfxV02SLQQ+BbyD/f
xtZ6pbHo03EsHLnRx+9okbbE9N0lHs5XADd4F0ZvWxtYACiVGjKqyVqkU8Hsqdx4
mxEevBi9YyuEyXzU04XGMmT4mGJXio6O45DheEQykYLlDmOJpU9N+G2N/8sG1liw
w+eicE0Jc0nl7KKWZhmx+9c9ghlMMXaR+Bbu6dqJhkt5vVrZP/3Kaz/HCOC6mW5+
9rYrXold/IA5+uGK2M5mIECYs2BKitXEFDsJabgsRlGMiDn7JtSI/h464B1t4VjF
3s2yikCGnBGE08/kuoJMQ97cwu0irpYjmctCH/pvn/mhb30mp8LvJlEcTa4SQNcd
ymkVBO74SVrltw8f8LAmSQDfxaCUrU7rjknG9hbwnO8FSla+nJDxsHzYA5sWvwiJ
MpOLF8HSnfJxyUTHDbaa4KoHDEpe8S48u7JFGbByptFuONXe8ggiX385J60hCshW
r+PYNWjD0hJa8I7l1OtY0NH2VdyN7AISe7kiBbzI7wjX142EskBuRPxBXlWBnYsT
VXqOld+izJXwW43A3o/p+fH4laehskb1QQJqyICOLD5UYX072CxPFZW5f2z7+pvo
eVsRuaffXdQ5odjt6DOvkoggPrEAnRtyLX7basRNb//Ks9JTiMc=
=3lVr
-----END PGP SIGNATURE-----


L
L
Leo Famulari wrote on 18 Jul 02:59 +0200
(address . 72164@debbugs.gnu.org)
Zpho8WL5gCqArpjW@jasmine.lan
I tested the build of linux-libre 6.10 with the attached patches, and it
failed as dariqq said it would on #guix, because this kernel series
requires an update to the 'dwarves' package. I'm building again with the
dwarves update now.


Also, these errata patches will only be required for 6.10, and not
subsequent releases in this series (6.10.1, etc).

We don't often end up including the mainline release in Guix, but rather
the subsequent stable releases, so in this case, it's not really
necessary to add this functionality. Although it would be nice.
From 3659eaef947623d502708441cfd6531acdc0fd90 Mon Sep 17 00:00:00 2001
Message-ID: <3659eaef947623d502708441cfd6531acdc0fd90.1721264342.git.leo@famulari.name>
From: Leo Famulari <leo@famulari.name>
Date: Wed, 17 Jul 2024 16:05:13 -0400
Subject: [PATCH 1/3] gnu: linux-libre: Add the ability to apply errata patches
to the deblobbing scripts.

* gnu/packages/linux.scm (linux-libre-deblob-scripts): Accept an optional
parameter DEBLOB-ERRATA-PATCHES.

Change-Id: If3c87f713637428e1cd2eaf5ef962b8005395805
---
gnu/packages/linux.scm | 8 ++++++--
1 file changed, 6 insertions(+), 2 deletions(-)

Toggle diff (32 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index e5aa712df7..0defc03e7a 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -359,9 +359,11 @@ (define-public (system->defconfig system)
;;; Kernel source code deblobbing.
;;;
-(define (linux-libre-deblob-scripts version gnu-revision
+(define* (linux-libre-deblob-scripts version gnu-revision
deblob-hash
- deblob-check-hash)
+ deblob-check-hash
+ #:optional
+ (deblob-errata-patches '()))
(list (version-major+minor version)
(origin
(method url-fetch)
@@ -370,6 +372,8 @@ (define (linux-libre-deblob-scripts version gnu-revision
"deblob-" (version-major+minor version)))
(file-name (string-append "linux-libre-deblob-"
version "-" gnu-revision))
+ (patches
+ (map search-patch deblob-errata-patches))
(sha256 deblob-hash))
(origin
(method url-fetch)

base-commit: 6cfc88e3be73904fc87443cdd5c7d7961923e848
prerequisite-patch-id: 58efdd6ff2418b91eae89e7964de00b95f83105f
--
2.45.2
From 1942a6c7340ee124313f65602dd218471ddbc193 Mon Sep 17 00:00:00 2001
Message-ID: <1942a6c7340ee124313f65602dd218471ddbc193.1721264342.git.leo@famulari.name>
In-Reply-To: <3659eaef947623d502708441cfd6531acdc0fd90.1721264342.git.leo@famulari.name>
References: <3659eaef947623d502708441cfd6531acdc0fd90.1721264342.git.leo@famulari.name>
From: Leo Famulari <leo@famulari.name>
Date: Wed, 17 Jul 2024 20:53:39 -0400
Subject: [PATCH 3/3] gnu: dwarves: Update to 1.27.

* gnu/packages/linux.scm (dwarves): Update to 1.27.

Change-Id: Id986fdd240a6619544ff6be93cce00afd9fc31bd
---
gnu/packages/linux.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index bef7803fb9..141aaf33f5 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2421,7 +2421,7 @@ (define-public dislocker
(define-public dwarves
(package
(name "dwarves")
- (version "1.26")
+ (version "1.27")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -2430,7 +2430,7 @@ (define-public dwarves
(file-name (git-file-name name version))
(sha256
(base32
- "0xfq0r3whc3dk922ss8i5vwyfcqhgc95dy27mm69j5niy7i5kzrd"))
+ "0qwc3772az1h3c78pyswawyvyq9spj5s1prj7ckfij9nazp3a007"))
(patches
(search-patches "dwarves-threading-reproducibility.patch"))))
(build-system cmake-build-system)
--
2.45.2
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEaEByLu7k06ZO5T6saqwZY3V/R/8FAmaYaO0ACgkQaqwZY3V/
R/8NsQ//ct3KIxoZUNC4aj5yCyN7xfmjCbIARLzEi1YeFhWprk4FKgGK8v/SxR7G
iMa57V7l0HNAHN3o+DLejRLE+T/x09RPP8PNnctai8Eu9D/bRj2sizp4qQmG4bZK
rHl7XRyDC7tDXgWms+/yxDfVyUSrGi+6v9f3C0rt3Jq3Rk6JW3rmS1jGL78cUZnO
JTDdO8SGMy7qP56sH4BhzrJ3nY+L6maafhjc/BvqTjYVotTPUeRDNOy+CuLodW5q
SnqFylp/cNmW/X54WYk2J3vph2mnSAyKSm56Nr5VOaGgSnyVr5gmw9GE3pfshSjz
K+ecnBZMSNwBxKwGL0CT47cGByxfFQ2NIXOQw4oG9beh2AT+prAVj5YAv90Uk8bq
kCpqUgISsbxmBhNNOVl9+hSB6xw1qinvsMRLrRxqhMB5hWaHCSpm2nwmL8XiD0TY
L2BnLZSlHaEeHsKg97tgra5hrv03xV6vsuDwly7hz3O71r4WDaFaRTKVJiyX4wZl
Mefc3XsrKZLrf865XmwpkVICqQ5RWwkjKNr5F6RnRwUD9WAG7CNygPHxFu38y+cd
KZFCegdofxODfMnqd1a5m7YOZTwApsfGeQm2MEPbeWi8RQ+Drr5nh81e4SU1+nqo
4V70lFnUXi2icIXCGu5cMX1xNZc8IfweArb9mKEZuxDZpSo05IM=
=tE1u
-----END PGP SIGNATURE-----


?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 72164@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 72164
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch