(address . bug-guix@gnu.org)
Hi,
As reported in [1], because of a change in ’guix git authenticate’ then
’git send-email’ needs more configuration than expected.
From ’(guix) Sending a Patch Series’ [2], it reads:
Assuming you have already configured Git according to ’Configuring
Git’, you can simply use:
$ git send-email --annotate -1
Where ’(guix) Configuring Git’ [3] reads:
Other important Git configuration will automatically be configured
when building the project (*note ’Building from Git’).
and ’(guix) Building from Git’ [4] suggests the sequence of commands:
git fetch origin keyring:keyring
(1) guix git authenticate 9edb3f66fd807b096b48283debdcddccfea34bad \
"BBB0 2DDF 2CEA F6A8 0D1D E643 A2A0 6DF2 A33A 54FA"
guix shell -D guix -CPW
./bootstrap
./configure
(2) make
make check
But the issue is that step (1) modifies the file ’.git/config’ and then
Makefile rule:
Toggle snippet (7 lines)
.git/config: etc/git/gitconfig
$(AM_V_at)if command -v git >/dev/null && test -d .git; then \
git config --fixed-value --replace-all include.path \
../etc/git/gitconfig ../etc/git/gitconfig; \
fi
does not apply because the file ’.git/config’ is newer than the file
’etc/git/gitconfig’. Therefore, the recommended Git configuration is
never locally installed. And the section ’Sending a Patch Series’ does
not work out of the box.
Well, from my point of view, the easiest seems to run ’touch
etc/git/gitconfig’ when running ’./bootstrap’. WDYT?
Cheers,
simon
1: Re: Did something with format-patch or send-email break?
Tomas Volf <~@wolfsden.cz>
Sun, 09 Jun 2024 12:51:44 +0200
id:ZmWJQLwXrPFtGlvu@ws