[PATCH] gnu: Add qute-gemini.

  • Open
  • quality assurance status badge
Details
One participant
  • gemmaro
Owner
unassigned
Submitted by
gemmaro
Severity
normal
G
G
gemmaro wrote on 17 Jul 14:06 +0200
(address . guix-patches@gnu.org)(name . gemmaro)(address . gemmaro.dev@gmail.com)
51cd0c18f08872163f2f44704de96e9fef067bbe.1721217976.git.gemmaro.dev@gmail.com
* gnu/packages/web-browsers.scm (qute-gemini): New variable.

Change-Id: I7832ab9fe29cd263b2c8728ee760f1fe6eef27e4
---
gnu/packages/web-browsers.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (56 lines)
diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index 4a2b28916d..5392c82236 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -22,6 +22,7 @@
;;; Copyright © 2020 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2021 Christopher Howard <christopher@librehacker.com>
;;; Copyright © 2023 Herman Rimm <herman@rimm.ee>
+;;; Copyright © 2024 gemmaro <gemmaro.dev@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -40,6 +41,7 @@
(define-module (gnu packages web-browsers)
#:use-module (guix build-system cmake)
+ #:use-module (guix build-system copy)
#:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system gnu)
#:use-module (guix build-system go)
@@ -555,6 +557,31 @@ (define-public qutebrowser
GUI. It is based on PyQt6 and QtWebEngine.")
(license license:gpl3+)))
+(define-public qute-gemini
+ (package
+ (name "qute-gemini")
+ (version "1.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~sotirisp/qute-gemini")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1cyx8q0yrppcfbs560wzzsa1bn1hmsjlv1llv50dpdagg2z07vfi"))))
+ (build-system copy-build-system)
+ (arguments
+ (list
+ #:install-plan #~(list (list "qute-gemini" "/share/qute-gemini/"))))
+ (inputs (list python))
+ (home-page "https://git.sr.ht/~sotirisp/qute-gemini")
+ (synopsis "qutebrowser userscript for Gemini pages")
+ (description "qute-gemini is a qutebrowser userscript that allows viewing Gemini
+pages by pressing a custom key. The pages are converted to HTML by
+the script and then displayed in qutebrowser.")
+ (license license:gpl3+)))
+
(define-public vimb
(package
(name "vimb")

base-commit: a800c49fb767f549fbc0eefe8dce6daa5da8604c
--
2.45.2
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 72155@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 72155
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch