[PATCH] file-systems: Skip checking the cifs file-system type.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Richard Sent
Owner
unassigned
Submitted by
Richard Sent
Severity
normal
R
R
Richard Sent wrote on 16 Jul 22:48 +0200
(address . guix-patches@gnu.org)(name . Richard Sent)(address . richard@freakingpenguin.com)
ca2432b07d88f378def33e951994f0fe2c4c0518.1721162924.git.richard@freakingpenguin.com
* gnu/build/file-systems.scm (check-file-system)[check-procedure]: Add cifs.

Change-Id: I891b18f03884ed45e92ac32556fe04b3087e20dd
---
gnu/build/file-systems.scm | 1 +
1 file changed, 1 insertion(+)

Toggle diff (16 lines)
diff --git a/gnu/build/file-systems.scm b/gnu/build/file-systems.scm
index ae29b36c4e..2076994e73 100644
--- a/gnu/build/file-systems.scm
+++ b/gnu/build/file-systems.scm
@@ -1083,6 +1083,7 @@ (define (check-file-system device type force? repair)
((string-prefix? "f2fs" type) check-f2fs-file-system)
((string-prefix? "ntfs" type) check-ntfs-file-system)
((string-prefix? "nfs" type) (const 'pass))
+ ((string-prefix? "cifs" type) (const 'pass))
((string-prefix? "xfs" type) check-xfs-file-system)
(else #f)))

base-commit: 325fed4c1514bffd084355455710fcc3f1c8da2c
--
2.45.2
L
L
Ludovic Courtès wrote on 20 Jul 11:51 +0200
(name . Richard Sent)(address . richard@freakingpenguin.com)(address . 72143-done@debbugs.gnu.org)
87ikx0qtlt.fsf@gnu.org
Richard Sent <richard@freakingpenguin.com> skribis:

Toggle quote (4 lines)
> * gnu/build/file-systems.scm (check-file-system)[check-procedure]: Add cifs.
>
> Change-Id: I891b18f03884ed45e92ac32556fe04b3087e20dd

Applied, thanks!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 72143@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 72143
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch