[PATCH 0/2] Add python-pandapower and python-pandapipes

  • Done
  • quality assurance status badge
Details
2 participants
  • jgart
  • Vinicius Monego
Owner
unassigned
Submitted by
Vinicius Monego
Severity
normal
V
V
Vinicius Monego wrote on 16 Jul 03:08 +0200
(address . guix-patches@gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
cover.1721091992.git.monego@posteo.net
Vinicius Monego (2):
gnu: Add python-pandapower.
gnu: Add python-pandapipes.

gnu/packages/engineering.scm | 59 ++++++++++++++++++++++++++++++++++++
1 file changed, 59 insertions(+)


base-commit: eb508e32d2d359c94d2cabebfe90dc32ca5dcf4f
--
2.39.2
V
V
Vinicius Monego wrote on 16 Jul 03:10 +0200
[PATCH 1/2] gnu: Add python-pandapower.
(address . 72133@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
6f763535fd29b3b0b82de04f8c6e4ccd0289c498.1721091992.git.monego@posteo.net
* gnu/packages/engineering.scm (python-pandapower): New variable.

Change-Id: I08bbb31df0e8c9918f331c420eb2f3ac136b69a8
---
gnu/packages/engineering.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index cc9020c6fd..6e204e6b6d 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -2627,6 +2627,40 @@ (define-public python-pyvisa
measurement devices and test equipment via GPIB, RS232, Ethernet or USB.")
(license license:expat)))
+(define-public python-pandapower
+ (package
+ (name "python-pandapower")
+ (version "2.14.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pandapower" version ".zip"))
+ (sha256
+ (base32 "0c5vgiq795kd5q4wcy2x7s3l7x9xdj2nqyfx188dmhgqckrym161"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-pyproj python-pytest unzip))
+ (propagated-inputs (list python-deepdiff
+ python-geojson
+ python-networkx
+ python-numpy
+ python-packaging
+ python-pandas
+ python-scipy
+ python-tqdm
+ python-typing-extensions))
+ (home-page "https://www.pandapower.org/")
+ (synopsis "Power system modelling and analysis")
+ (description "@code{pandapower} is an easy to use network calculation
+program aimed to automate the analysis and optimization of power systems.
+It uses the data analysis library @code{pandas} and is compatible with the
+commonly used @code{MATPOWER} / @code{PYPOWER} case format. @code{pandapower}
+allows using different solvers including an improved Newton-Raphson power flow
+implementation, all @code{PYPOWER} solvers, the C++ library solvers for fast
+steady-state distribution power system analysis of @code{PowerGridModel}, the
+Newton-Raphson power flow solvers in the C++ library lightsim2grid, and the
+@code{PowerModels.jl} library.")
+ (license license:bsd-3)))
+
(define-public python-scikit-rf
(package
(name "python-scikit-rf")
--
2.39.2
V
V
Vinicius Monego wrote on 16 Jul 03:10 +0200
[PATCH 2/2] gnu: Add python-pandapipes.
(address . 72133@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
4a31aeddd0a9029e9213e6602149060103c108aa.1721091992.git.monego@posteo.net
* gnu/packages/engineering.scm (python-pandapipes): New variable.

Change-Id: I5858f8a82ec6b351e14a03ecc52a0b9fef62f7c0
---
gnu/packages/engineering.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 6e204e6b6d..2875d45330 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -2661,6 +2661,31 @@ (define-public python-pandapower
@code{PowerModels.jl} library.")
(license license:bsd-3)))
+(define-public python-pandapipes
+ (package
+ (name "python-pandapipes")
+ (version "0.10.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pandapipes" version ".zip"))
+ (sha256
+ (base32 "06yqqd25hxa6q49qcbpy0njwxkqzfhbff4frrrxd84391njgvdhq"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-nbmake
+ python-pytest
+ python-pytest-xdist
+ unzip))
+ (propagated-inputs (list python-matplotlib
+ python-pandapower
+ python-shapely))
+ (home-page "http://www.pandapipes.org")
+ (synopsis "Simulation of multi energy grids")
+ (description
+ "This package provides a pipeflow calculation tool that complements
+@code{pandapower} in the simulation of multi energy grids.")
+ (license license:bsd-3)))
+
(define-public python-scikit-rf
(package
(name "python-scikit-rf")
--
2.39.2
J
Re: [PATCH 0/2] Add python-pandapower and python-pandapipes
(address . 72133-done@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
87v815dhk7.fsf@dismail.de
Thanks, applied!

--
all the best,
jgart
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 72133@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 72133
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch