[PATCH] gnu: rapidcheck: Disable failing tests on aarch64.

  • Open
  • quality assurance status badge
Details
One participant
  • Roman Scherer
Owner
unassigned
Submitted by
Roman Scherer
Severity
normal
R
R
Roman Scherer wrote on 14 Jul 17:17 +0200
(address . guix-patches@gnu.org)
9dc8fe32352253e6980b6cf295cca147a0759e88.1720969713.git.roman@burningswell.com
* gnu/packages/check.scm (rapidcheck): Disable failing tests on aarch64.

Change-Id: I9b4e7be2acad615cc1586adb37cc39b43590b2d8
---
gnu/packages/check.scm | 8 +++++++-
1 file changed, 7 insertions(+), 1 deletion(-)

Toggle diff (34 lines)
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 3bfcf5a37e..412b94569c 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -3500,7 +3500,13 @@ (define-public rapidcheck
(display "find_package(Boost GLOBAL)\n" out)))
(substitute* "extras/boost/test/CMakeLists.txt"
(("^([ ]*)boost" all spaces)
- (string-append spaces "Boost::boost")))))))
+ (string-append spaces "Boost::boost")))
+ ;; Disable tests failing on Apple M1 and Hetzner CAX41 (aarch64).
+ ;; Upstream issue: https://github.com/emil-e/rapidcheck/issues/328
+ (substitute* "test/gen/NumericTests.cpp"
+ (("forEachType<SignedProperties.*") ""))
+ (substitute* "test/shrink/ShrinkTests.cpp"
+ (("forEachType<SignedIntegralProperties.*") ""))))))
(arguments
(list
#:configure-flags #~(list "-DCMAKE_POSITION_INDEPENDENT_CODE=ON"

base-commit: bcd627f58e74ce44cc96a9aac37c6d9e9e3c0dcc
prerequisite-patch-id: 3a2f57a0138610e70093333bbb19bcd9c909e7b9
prerequisite-patch-id: 09e6b4e8c70f5eb7996f78194c59245f38d3241b
prerequisite-patch-id: a12882ccf5bbef1edbd1110f128cd107f84a1377
prerequisite-patch-id: 2c83a46f3bcf9d3e153e2543fe9a57e5f33af286
prerequisite-patch-id: c6c55378dfbf74f5862c5b5609fe7cc3dc4b52d7
prerequisite-patch-id: 6307af77f1d5ccaef3accfce06479f604cdfd260
prerequisite-patch-id: 1f06621d95d4b22729a1461bca01feeb0d491324
prerequisite-patch-id: 2b5ca4e046c327f00c14fb9a0b7a08b6e4014bcb
prerequisite-patch-id: 7ebd64a45f6032d0fa2317d3b276cd93544ea187
prerequisite-patch-id: 88dd65ca157f484e2d13782d183ec6df8c3f57f0
prerequisite-patch-id: dfb3375fc8db76bd6d25723f27b53c551157c312
--
2.45.2
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 72113@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 72113
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch