[PATCH] gnu: Add emacs-consult-projectile

  • Open
  • quality assurance status badge
Details
One participant
  • Daniel Szmulewicz
Owner
unassigned
Submitted by
Daniel Szmulewicz
Severity
normal
D
D
Daniel Szmulewicz wrote on 14 Jul 17:10 +0200
(address . guix-patches@gnu.org)(name . Daniel Szmulewicz)(address . daniel.szmulewicz@gmail.com)
3f058a33f744c72e0c69038e99c326d82bf4da85.1720969831.git.daniel.szmulewicz@gmail.com
* gnu/packages/emacs-xyz.scm (emacs-consult-projectile): New variable.

Change-Id: Id7de103e052b0900069757fe56ddc1b10a875660
---
gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 0f5318a949..3b0d4c17cd 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -39866,6 +39866,30 @@ (define-public emacs-consult-lsp
by leveraging @code{emacs-consult} APIs.")
(license license:expat)))
+(define-public emacs-consult-projectile
+ (package
+ (name "emacs-consult-projectile")
+ (version "0.7")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/OlMon/consult-projectile")
+ (commit "400439c56d17bca7888f7d143d8a11f84900a406")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1abd2dw3zpiln9pd7l3j78wl3lwapcmf1ilijv3vin9g0wqb7hmn"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-consult emacs-projectile))
+ (home-page "https://gitlab.com/OlMon/consult-projectile")
+ (synopsis "Consult integration for projectile")
+ (description
+ "This package provides a multiview for displaying open buffers, files and
+directories accociated with a project. When no project is open in the current
+buffer display a list of known project and select a file from the selected
+project. Additionally seperate single source function are available.")
+ (license license:gpl3+)))
+
(define-public emacs-context-transient
(package
(name "emacs-context-transient")

base-commit: bcd627f58e74ce44cc96a9aac37c6d9e9e3c0dcc
prerequisite-patch-id: a806956c71c0cff17c07a84b45beded622ad41c2
--
2.45.2
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 72112@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 72112
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch