[PATCH 0/2] Update LibrePCB

  • Open
  • quality assurance status badge
Details
One participant
  • Vinicius Monego
Owner
unassigned
Submitted by
Vinicius Monego
Severity
normal
V
V
Vinicius Monego wrote on 14 Jul 15:33 +0200
(address . guix-patches@gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
cover.1720963911.git.monego@posteo.net
Vinicius Monego (2):
gnu: Add fontobene-qt.
gnu: librepcb: Update to 1.1.0.

gnu/packages/engineering.scm | 11 ++++++-----
gnu/packages/fontutils.scm | 21 ++++++++++++---------
2 files changed, 18 insertions(+), 14 deletions(-)


base-commit: bcd627f58e74ce44cc96a9aac37c6d9e9e3c0dcc
--
2.39.2
V
V
Vinicius Monego wrote on 14 Jul 15:35 +0200
[PATCH 1/2] gnu: Add fontobene-qt.
(address . 72108@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
d6d41dfa9c747defad2e4730bab163c7e6d31a95.1720963911.git.monego@posteo.net
* gnu/packages/fontutils.scm (fontobene-qt): New variable.
(fontobene-qt5): Deprecate package in favor of fontobene-qt.

Change-Id: I2177ff292a1b71d212fb0b03d772808d7525b039
---
gnu/packages/fontutils.scm | 21 ++++++++++++---------
1 file changed, 12 insertions(+), 9 deletions(-)

Toggle diff (54 lines)
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index f82b7d1bf9..a09c1dbaf9 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -999,20 +999,20 @@ (define-public python-ufonormalizer
@end itemize")
(license license:bsd-3)))
-(define-public fontobene-qt5
+(define-public fontobene-qt
(package
- (name "fontobene-qt5")
- (version "0.2.0")
+ (name "fontobene-qt")
+ (version "1.0.0")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/fontobene/fontobene-qt5")
+ (url "https://github.com/fontobene/fontobene-qt")
(commit version)))
(file-name (git-file-name name version))
(sha256
(base32
- "0gy3sfraf23k7dm4ha8nqpd6madzk0zmxkcb204micyn5b5l8ljg"))))
- (inputs (list qtbase-5))
+ "098ys33l563hjyzm6azzw8kmlybja374vacakczwhh2k3ifn37r9"))))
+ (inputs (list qtbase))
(build-system cmake-build-system)
(arguments
`(#:phases
@@ -1020,14 +1020,17 @@ (define-public fontobene-qt5
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
(when tests?
- (invoke "./tests/fontobene-qt5-tests")))))))
+ (invoke "./tests/fontobene-qt-tests")))))))
(home-page "https://github.com/fontobene/fontobene-qt5")
(synopsis "Parser for FontoBene stroke fonts")
- (description "FontoBene-Qt5 is a header-only library to parse FontoBene
-stroke fonts with C++11/Qt5.")
+ (description "FontoBene-Qt is a header-only library to parse FontoBene
+stroke fonts with C++11/Qt.")
;; Dual-licensed, either license applies.
(license (list license:asl2.0 license:expat))))
+(define-public fontobene-qt5
+ (deprecated-package "fontobene-qt5" fontobene-qt))
+
(define-public ttfautohint
(package
(name "ttfautohint")
--
2.39.2
V
V
Vinicius Monego wrote on 14 Jul 15:35 +0200
[PATCH 2/2] gnu: librepcb: Update to 1.1.0.
(address . 72108@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
201cefcf5aca586664c0513b0534cc4745ced274.1720963911.git.monego@posteo.net
* gnu/packages/engineering.scm (librepcb): Update to 1.1.0.
[source, arguments]: Rename "fontobene-qt5" to "fontobene-qt".
<#:phases>: Skip a failing test in the check phase.
[inputs]: Replace fontobene-qt5 by fontobene-qt.

Change-Id: I5baa341f52a265ab487248a61d7ef8890af09b07
---
gnu/packages/engineering.scm | 11 ++++++-----
1 file changed, 6 insertions(+), 5 deletions(-)

Toggle diff (56 lines)
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index cc9020c6fd..f90ec64d27 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -2309,7 +2309,7 @@ (define-public freehdl
(define-public librepcb
(package
(name "librepcb")
- (version "1.0.0")
+ (version "1.1.0")
(source
(origin
(method url-fetch)
@@ -2320,7 +2320,7 @@ (define-public librepcb
;; Delete libraries that we already have or don't need.
;; TODO: try to unbundle more (see lib/).
`(begin
- (let ((third-parties '("fontobene-qt5"
+ (let ((third-parties '("fontobene-qt"
"googletest"
"hoedown"
"muparser"
@@ -2331,12 +2331,12 @@ (define-public librepcb
(delete-file-recursively third-party))
third-parties)))))
(sha256
- (base32 "02qfwyhdq1pklb5gkwn3rbsdhwvcgiksd21swaphz3kw6s4p9i8v"))))
+ (base32 "10wfjmzaghg5k3fvpxa610rxjnfcj9si8pkbw8iaz6gq7iqwsb8h"))))
(build-system cmake-build-system)
(inputs
(list clipper
fontconfig
- fontobene-qt5
+ fontobene-qt
glu
hoedown
muparser
@@ -2354,7 +2354,7 @@ (define-public librepcb
unzip))
(arguments
`(#:configure-flags (list
- "-DUNBUNDLE_FONTOBENE_QT5=ON"
+ "-DUNBUNDLE_FONTOBENE_QT=ON"
"-DUNBUNDLE_GTEST=ON"
"-DUNBUNDLE_HOEDOWN=ON"
"-DUNBUNDLE_MUPARSER=ON"
@@ -2367,6 +2367,7 @@ (define-public librepcb
(let ((test-include (list "*"))
(test-exclude
(list
+ "ApplicationTest.testGetCacheDir"
;; These tests all fail when run by the build
;; process even though they pass when manually
;; run as a normal user.
--
2.39.2
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 72108@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 72108
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch