[PATCH] gnu: python-emoji: Update to 2.12.1.

  • Done
  • quality assurance status badge
Details
2 participants
  • jgart
  • Gisement
Owner
unassigned
Submitted by
Gisement
Severity
normal

Debbugs page

Gisement wrote 8 months ago
(address . guix-patches@gnu.org)(name . Gisement)(address . sisiutl@egregore.fun)
ec0bb558dc40a1753740dafbab99a604b1dde18b.1720907340.git.sisiutl@egregore.fun
Change-Id: Id262ba7f05f5fa6205bc19709442e62c1856f8a9
---
gnu/packages/python-xyz.scm | 19 ++++++-------------
1 file changed, 6 insertions(+), 13 deletions(-)

Toggle diff (39 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 983d8d73b6..ece0e5ded6 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -14100,26 +14100,19 @@ (define-public python-immutabledict
(define-public python-emoji
(package
(name "python-emoji")
- (version "1.6.1")
+ (version "2.12.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "emoji" version))
(sha256
- (base32 "0923mpixwq6hdpkgvi4r46alfvf608iq975rb8lnqpq29j71mmjk"))))
- (build-system python-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "python" "-m" "pytest")))))))
- (native-inputs
- (list python-pytest))
+ (base32 "1svk94pad8gcvjwd329zmfrw09wakwh6qjvnhf6sa6k92y44i82a"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-pytest python-typing-extensions))
(home-page "https://github.com/carpedm20/emoji/")
(synopsis "Emoji terminal output for Python")
- (description "This package provides Emoji terminal output for Python. The
+ (description
+ "This package provides Emoji terminal output for Python. The
entire set of Emoji codes as defined by the Unicode Consortium is supported in
addition to a bunch of aliases.")
(license license:bsd-3)))
--
2.45.2
jgart wrote 8 months ago
(address . 72102-done@debbugs.gnu.org)(name . Gisement)(address . sisiutl@egregore.fun)
87y162cm1v.fsf@dismail.de
Hi,

Thank you for your contribution!

I applied your patch with commit message modifications and some
adjustments.

Please review them for your next contribution in order to learn the
commit message style, etc.
--
all the best,
jgart
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 72102@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 72102
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help