[PATCH 0/2] Add perl-minimumversion.

  • Done
  • quality assurance status badge
Details
3 participants
  • gemmaro
  • Ludovic Courtès
  • Nicolas Graves
Owner
unassigned
Submitted by
gemmaro
Severity
normal
G
G
gemmaro wrote on 14 Jul 04:57 +0200
(address . guix-patches@gnu.org)(name . gemmaro)(address . gemmaro.dev@gmail.com)
cover.1720925376.git.gemmaro.dev@gmail.com
gemmaro (2):
gnu: Add perl-ppix-utils.
gnu: Add perl-minimumversion.

gnu/packages/perl.scm | 64 ++++++++++++++++++++++++++++++++++++++++++-
1 file changed, 63 insertions(+), 1 deletion(-)


base-commit: c1d367f57e89c3f2efd964e6d638bd89b0b1df97
prerequisite-patch-id: 62fc54ed554df985530503c8e8c5b718c16b709b
prerequisite-patch-id: c22785847e70bf2f4c94547dd7851ad7de06b92a
prerequisite-patch-id: 36850492cd3b84d7f353cc8c923a667c1b0271bc
prerequisite-patch-id: 4cf00e93b12f66ef5e385a693bfdb81e4b558388
--
2.45.2
G
G
gemmaro wrote on 14 Jul 05:10 +0200
[PATCH 1/2] gnu: Add perl-ppix-utils.
(address . 72101@debbugs.gnu.org)(name . gemmaro)(address . gemmaro.dev@gmail.com)
8140a2841516fa2f8f4423c4a4bf913201af2190.1720925376.git.gemmaro.dev@gmail.com
* gnu/packages/perl.scm (perl-ppix-utils): New variable.

Change-Id: Idaa31e9eb628d5175a2b20ee6fac67427e6cf425
---
gnu/packages/perl.scm | 24 +++++++++++++++++++++++-
1 file changed, 23 insertions(+), 1 deletion(-)

Toggle diff (44 lines)
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 0abf3f7fd1..fe75ffa4c4 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -33,7 +33,7 @@
;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
;;; Copyright © 2022, 2023 Evgeny Pisemsky <evgeny@pisemsky.com>
-;;; Copyright © 2022, 2023 gemmaro <gemmaro.dev@gmail.com>
+;;; Copyright © 2022, 2023, 2024 gemmaro <gemmaro.dev@gmail.com>
;;; Copyright © 2023 M?d?lin Ionel Patra?cu <madalinionel.patrascu@mdc-berlin.de>
;;; Copyright © 2023 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2023 Jake Leporte <jakeleporte@outlook.com>
@@ -9148,6 +9148,28 @@ (define-public perl-ppix-utilities
in @code{PPIx::Utilities::Node}.")
(license license:perl-license)))
+(define-public perl-ppix-utils
+ (package
+ (name "perl-ppix-utils")
+ (version "0.003")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/D/DB/DBOOK/PPIx-Utils-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "04dszlp7yas3yi7gm1l2g47h88i52n7gwj3jnq0vw0xdivycr6ra"))))
+ (build-system perl-build-system)
+ (propagated-inputs (list perl-b-keywords perl-ppi))
+ (home-page "https://metacpan.org/release/PPIx-Utils")
+ (synopsis "Utility functions for Perl PPI")
+ (description
+ "@samp{PPIx::Utils} is a collection of utility functions for working
+with @samp{PPI} documents. The functions are organized into
+submodules, and may be imported from the appropriate submodules or via
+this module.")
+ (license license:perl-license)))
+
(define-public perl-probe-perl
(package
(name "perl-probe-perl")
--
2.45.2
G
G
gemmaro wrote on 14 Jul 05:10 +0200
[PATCH 2/2] gnu: Add perl-minimumversion.
(address . 72101@debbugs.gnu.org)(name . gemmaro)(address . gemmaro.dev@gmail.com)
9df71471e436e654ee2793ecc6e64c53bba9ab25.1720925376.git.gemmaro.dev@gmail.com
* gnu/packages/perl.scm (perl-minimumversion): New variable.

Change-Id: I731567f257d8415b4cf834ab22c7e64699a8b28f
---
gnu/packages/perl.scm | 40 ++++++++++++++++++++++++++++++++++++++++
1 file changed, 40 insertions(+)

Toggle diff (53 lines)
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index fe75ffa4c4..bbc06d320c 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -6877,6 +6877,46 @@ (define-public perl-mime-types
knowledge of Apache.")
(license (package-license perl))))
+(define-public perl-minimumversion
+ (package
+ (name "perl-minimumversion")
+ (version "1.40")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/D/DB/DBOOK/Perl-MinimumVersion-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "145yl4qv14xcrr74w1qvdb6s0h5lj8smnfawfnj0rmv0rdwab2bm"))))
+ (build-system perl-build-system)
+ (arguments
+ (list
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'install 'wrap-programs
+ (lambda _
+ (wrap-program (string-append #$output "/bin/perlver")
+ (list "PERL5LIB" ":"
+ 'prefix
+ (list (string-append (getenv "PERL5LIB") ":"
+ #$output
+ "/lib/perl5/site_perl")))))))))
+ (inputs (list bash-minimal))
+ (propagated-inputs (list perl-file-find-rule
+ perl-file-find-rule-perl
+ perl-params-util
+ perl-ppi
+ perl-ppix-regexp
+ perl-ppix-utils))
+ (home-page "https://metacpan.org/release/Perl-MinimumVersion")
+ (synopsis "Find a minimum required version of perl for Perl code")
+ (description
+ "@samp{Perl::MinimumVersion} takes Perl source code and calculates the
+minimum version of perl required to be able to run it. Because it is
+based on @samp{PPI}, it can do this without having to actually load
+the code. The distribution comes with a script called @samp{perlver}.")
+ (license license:perl-license)))
+
(define-public perl-mixin-linewise
(package
(name "perl-mixin-linewise")
--
2.45.2
N
N
Nicolas Graves wrote on 15 Aug 15:48 +0200
QA review for 72101
87frr5gams.fsf@ngraves.fr
user guix
usertag 72101 + reviewed-looks-good
thanks

Guix QA review form submission:
Looks good to me.
A nitpick: Maybe you can use also use &quot;PPI documents&quot; in the description of perl-minimumversion to make that a bit clearer.

Items marked as checked: Lint warnings, Package builds, Commit messages, New package licenses, New package tests, New package synopsis and descriptions

--
Best regards,
Nicolas Graves
G
G
gemmaro wrote on 21 Aug 13:59 +0200
[PATCH v2 1/2] gnu: Add perl-ppix-utils.
(address . 72101@debbugs.gnu.org)(name . gemmaro)(address . gemmaro.dev@gmail.com)
077ad9cf0e6ccfc44dffaacb7f949902aa715ac8.1724241566.git.gemmaro.dev@gmail.com
* gnu/packages/perl.scm (perl-ppix-utils): New variable.

Change-Id: I9548c693aa6f54bd53662374f77b2fbd1ca3f485
---
gnu/packages/perl.scm | 24 +++++++++++++++++++++++-
1 file changed, 23 insertions(+), 1 deletion(-)

Toggle diff (46 lines)
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index a0eec2baed..46de612234 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -33,7 +33,7 @@
;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
;;; Copyright © 2022, 2023 Evgeny Pisemsky <mail@pisemsky.site>
-;;; Copyright © 2022, 2023 gemmaro <gemmaro.dev@gmail.com>
+;;; Copyright © 2022, 2023, 2024 gemmaro <gemmaro.dev@gmail.com>
;;; Copyright © 2023 M?d?lin Ionel Patra?cu <madalinionel.patrascu@mdc-berlin.de>
;;; Copyright © 2023 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2023 Jake Leporte <jakeleporte@outlook.com>
@@ -9148,6 +9148,28 @@ (define-public perl-ppix-utilities
in @code{PPIx::Utilities::Node}.")
(license license:perl-license)))
+(define-public perl-ppix-utils
+ (package
+ (name "perl-ppix-utils")
+ (version "0.003")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/D/DB/DBOOK/PPIx-Utils-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "04dszlp7yas3yi7gm1l2g47h88i52n7gwj3jnq0vw0xdivycr6ra"))))
+ (build-system perl-build-system)
+ (propagated-inputs (list perl-b-keywords perl-ppi))
+ (home-page "https://metacpan.org/release/PPIx-Utils")
+ (synopsis "Utility functions for Perl PPI")
+ (description
+ "@samp{PPIx::Utils} is a collection of utility functions for working
+with @samp{PPI} documents. The functions are organized into
+submodules, and may be imported from the appropriate submodules or via
+this module.")
+ (license license:perl-license)))
+
(define-public perl-probe-perl
(package
(name "perl-probe-perl")

base-commit: 127592bc0fd7f5deb79ea05dd9e7d3bfdb3c2a1d
--
2.45.2
G
G
gemmaro wrote on 21 Aug 13:59 +0200
[PATCH v2 2/2] gnu: Add perl-minimumversion.
(address . 72101@debbugs.gnu.org)(name . gemmaro)(address . gemmaro.dev@gmail.com)
d28396fa5bac8803b946f294c39ffa563db791d9.1724241566.git.gemmaro.dev@gmail.com
* gnu/packages/perl.scm (perl-minimumversion): New variable.

Change-Id: Iad3c22936c07b7430525ad9827b6703d4ea9ce9c
---
I added "Perl Parsing Interface"[1] in the description to make it clearer.


gnu/packages/perl.scm | 40 ++++++++++++++++++++++++++++++++++++++++
1 file changed, 40 insertions(+)

Toggle diff (53 lines)
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 46de612234..816aca2d59 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -6877,6 +6877,46 @@ (define-public perl-mime-types
knowledge of Apache.")
(license (package-license perl))))
+(define-public perl-minimumversion
+ (package
+ (name "perl-minimumversion")
+ (version "1.40")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/D/DB/DBOOK/Perl-MinimumVersion-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "145yl4qv14xcrr74w1qvdb6s0h5lj8smnfawfnj0rmv0rdwab2bm"))))
+ (build-system perl-build-system)
+ (arguments
+ (list
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'install 'wrap-programs
+ (lambda _
+ (wrap-program (string-append #$output "/bin/perlver")
+ (list "PERL5LIB" ":"
+ 'prefix
+ (list (string-append (getenv "PERL5LIB") ":"
+ #$output
+ "/lib/perl5/site_perl")))))))))
+ (inputs (list bash-minimal))
+ (propagated-inputs (list perl-file-find-rule
+ perl-file-find-rule-perl
+ perl-params-util
+ perl-ppi
+ perl-ppix-regexp
+ perl-ppix-utils))
+ (home-page "https://metacpan.org/release/Perl-MinimumVersion")
+ (synopsis "Find a minimum required version of perl for Perl code")
+ (description
+ "@samp{Perl::MinimumVersion} takes Perl source code and calculates the minimum
+version of perl required to be able to run it. Because it is based on the @samp{PPI}
+(Perl Parsing Interface), it can do this without loading the code. The distribution
+comes with a script called @samp{perlver}.")
+ (license license:perl-license)))
+
(define-public perl-mixin-linewise
(package
(name "perl-mixin-linewise")
--
2.45.2
L
L
Ludovic Courtès wrote on 21 Aug 19:00 +0200
Re: [bug#72101] [PATCH v2 1/2] gnu: Add perl-ppix-utils.
(name . gemmaro)(address . gemmaro.dev@gmail.com)
87ttfdretm.fsf@gnu.org
gemmaro <gemmaro.dev@gmail.com> skribis:

Toggle quote (4 lines)
> * gnu/packages/perl.scm (perl-ppix-utils): New variable.
>
> Change-Id: I9548c693aa6f54bd53662374f77b2fbd1ca3f485

[...]

Toggle quote (4 lines)
> * gnu/packages/perl.scm (perl-minimumversion): New variable.
>
> Change-Id: Iad3c22936c07b7430525ad9827b6703d4ea9ce9c

Applied! Thank you, and thanks Nicolas.

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 72101@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 72101
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch