[PATCH] gnu: gpxsee: Update to 13.22.

  • Done
  • quality assurance status badge
Details
2 participants
  • Morgan Smith
  • Ludovic Courtès
Owner
unassigned
Submitted by
Morgan Smith
Severity
normal

Debbugs page

Morgan Smith wrote 8 months ago
(address . guix-patches@gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
CH3PR84MB3424364918258728EA88946DC5A62@CH3PR84MB3424.NAMPRD84.PROD.OUTLOOK.COM
* gnu/packages/gps.scm (gpxsee): Update to 13.22.
Use qt-build-system. Use qt6 instead of qt5.

Change-Id: I9101a6f763be198549aca8e5aea95987b14e58e4
---
gnu/packages/gps.scm | 53 ++++++++++++++++++++++----------------------
1 file changed, 27 insertions(+), 26 deletions(-)

Toggle diff (81 lines)
diff --git a/gnu/packages/gps.scm b/gnu/packages/gps.scm
index 09a419d7e9..d78c581ad0 100644
--- a/gnu/packages/gps.scm
+++ b/gnu/packages/gps.scm
@@ -31,6 +31,7 @@ (define-module (gnu packages gps)
#:use-module (guix git-download)
#:use-module (guix build-system gnu)
#:use-module (guix build-system scons)
+ #:use-module (guix build-system qt)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix utils)
#:use-module (gnu packages)
@@ -51,6 +52,7 @@ (define-module (gnu packages gps)
#:use-module (gnu packages qt)
#:use-module (gnu packages serialization)
#:use-module (gnu packages sqlite)
+ #:use-module (gnu packages xdisorg)
#:use-module (gnu packages xml))
(define-public gpsbabel
@@ -179,33 +181,32 @@ (define-public gama
(define-public gpxsee
(package
(name "gpxsee")
- (version "11.1")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/tumic0/GPXSee")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1klpjiqsvpvhlg5hsfjaszsyqr817hig9r7y7w4cp0kyn8z5fzfj"))))
- (build-system gnu-build-system)
+ (version "13.22")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tumic0/GPXSee")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "15m5rqky2fwsq5n6x531350x39wwhpv1hz56m1yfaxj7acxhb2p5"))))
+ (build-system qt-build-system)
(arguments
- '(#:phases
- (modify-phases %standard-phases
- (replace 'configure
- ;; Use lrelease to convert TS translation files into QM files.
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (for-each (lambda (file)
- (invoke "lrelease" file))
- (find-files "lang" "\\.ts"))
- (invoke "qmake"
- (string-append "PREFIX="
- (assoc-ref outputs "out"))))))))
- (inputs
- (list qtbase-5 qtlocation qtsvg-5))
- (native-inputs
- (list qttools-5))
+ (list
+ #:qtbase qtbase
+ #:tests? #f
+ #:phases #~(modify-phases %standard-phases
+ (replace 'configure
+ ;; Use lrelease to convert TS translation files into QM files.
+ (lambda _
+ (apply invoke "lrelease"
+ (find-files "lang" ".*\\.ts"))
+ (invoke "qmake"
+ (string-append "PREFIX="
+ #$output)))))))
+ (inputs (list libxkbcommon qtbase qtpositioning qtserialport qtsvg))
+ (native-inputs (list qttools))
(home-page "https://www.gpxsee.org")
(synopsis "GPS log file viewer and analyzer")
(description
--
2.45.2
Ludovic Courtès wrote 8 months ago
(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)(address . 72082@debbugs.gnu.org)
871q3qwxi9.fsf@gnu.org
Hi Morgan,

Morgan Smith <Morgan.J.Smith@outlook.com> skribis:

Toggle quote (5 lines)
> * gnu/packages/gps.scm (gpxsee): Update to 13.22.
> Use qt-build-system. Use qt6 instead of qt5.
>
> Change-Id: I9101a6f763be198549aca8e5aea95987b14e58e4

[...]

Toggle quote (4 lines)
> + (list
> + #:qtbase qtbase
> + #:tests? #f

In general we avoid disabling tests. Could you investigate a bit as to
why tests are failing? Then the usual approach is to tweak or skip
individual tests, and only as a last resort use #:tests? #f. In either
case, there should be a comment explaining why we’re doing this.

Thanks,
Ludo’.
Morgan Smith wrote 8 months ago
[PATCH v2] gnu: gpxsee: Update to 13.22.
(address . ludo@gnu.org)
CH3PR84MB34242B68E327C92D5A2AB451C5AC2@CH3PR84MB3424.NAMPRD84.PROD.OUTLOOK.COM
* gnu/packages/gps.scm (gpxsee): Update to 13.22.
Use qt-build-system. Use qt6 instead of qt5.

Change-Id: I9101a6f763be198549aca8e5aea95987b14e58e4
---
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (9 lines)
>
> In general we avoid disabling tests. Could you investigate a bit as to
> why tests are failing? Then the usual approach is to tweak or skip
> individual tests, and only as a last resort use #:tests? #f. In either
> case, there should be a comment explaining why we’re doing this.
>
> Thanks,
> Ludo’.

I added a comment explaining that there are no tests. I greped the source code
for "test" and "check" and found nothing of interest. The project does have
some continuous integration stuff but all it does is build. It does not run
tests.

Thanks,

Morgan

gnu/packages/gps.scm | 53 ++++++++++++++++++++++----------------------
1 file changed, 27 insertions(+), 26 deletions(-)

Toggle diff (81 lines)
diff --git a/gnu/packages/gps.scm b/gnu/packages/gps.scm
index 09a419d7e9..a908744c73 100644
--- a/gnu/packages/gps.scm
+++ b/gnu/packages/gps.scm
@@ -31,6 +31,7 @@ (define-module (gnu packages gps)
#:use-module (guix git-download)
#:use-module (guix build-system gnu)
#:use-module (guix build-system scons)
+ #:use-module (guix build-system qt)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix utils)
#:use-module (gnu packages)
@@ -51,6 +52,7 @@ (define-module (gnu packages gps)
#:use-module (gnu packages qt)
#:use-module (gnu packages serialization)
#:use-module (gnu packages sqlite)
+ #:use-module (gnu packages xdisorg)
#:use-module (gnu packages xml))
(define-public gpsbabel
@@ -179,33 +181,32 @@ (define-public gama
(define-public gpxsee
(package
(name "gpxsee")
- (version "11.1")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/tumic0/GPXSee")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1klpjiqsvpvhlg5hsfjaszsyqr817hig9r7y7w4cp0kyn8z5fzfj"))))
- (build-system gnu-build-system)
+ (version "13.22")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tumic0/GPXSee")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "15m5rqky2fwsq5n6x531350x39wwhpv1hz56m1yfaxj7acxhb2p5"))))
+ (build-system qt-build-system)
(arguments
- '(#:phases
- (modify-phases %standard-phases
- (replace 'configure
- ;; Use lrelease to convert TS translation files into QM files.
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (for-each (lambda (file)
- (invoke "lrelease" file))
- (find-files "lang" "\\.ts"))
- (invoke "qmake"
- (string-append "PREFIX="
- (assoc-ref outputs "out"))))))))
- (inputs
- (list qtbase-5 qtlocation qtsvg-5))
- (native-inputs
- (list qttools-5))
+ (list
+ #:qtbase qtbase
+ #:tests? #f ; no tests
+ #:phases #~(modify-phases %standard-phases
+ (replace 'configure
+ ;; Use lrelease to convert TS translation files into QM files.
+ (lambda _
+ (apply invoke "lrelease"
+ (find-files "lang" "\\.ts"))
+ (invoke "qmake"
+ (string-append "PREFIX="
+ #$output)))))))
+ (inputs (list libxkbcommon qtbase qtpositioning qtserialport qtsvg))
+ (native-inputs (list qttools))
(home-page "https://www.gpxsee.org")
(synopsis "GPS log file viewer and analyzer")
(description
--
2.45.2
Ludovic Courtès wrote 8 months ago
(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)(address . 72082-done@debbugs.gnu.org)
877cdgqso1.fsf@gnu.org
Hello,

Morgan Smith <Morgan.J.Smith@outlook.com> skribis:

Toggle quote (21 lines)
> * gnu/packages/gps.scm (gpxsee): Update to 13.22.
> Use qt-build-system. Use qt6 instead of qt5.
>
> Change-Id: I9101a6f763be198549aca8e5aea95987b14e58e4
> ---
> Ludovic Courtès <ludo@gnu.org> writes:
>
>>
>> In general we avoid disabling tests. Could you investigate a bit as to
>> why tests are failing? Then the usual approach is to tweak or skip
>> individual tests, and only as a last resort use #:tests? #f. In either
>> case, there should be a comment explaining why we’re doing this.
>>
>> Thanks,
>> Ludo’.
>
> I added a comment explaining that there are no tests. I greped the source code
> for "test" and "check" and found nothing of interest. The project does have
> some continuous integration stuff but all it does is build. It does not run
> tests.

OK, that makes sense to me.

I applied it (it did not apply cleanly but with a bit of help it was
fine).

Thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 72082@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 72082
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help