(address . guix-patches@gnu.org)(name . Efraim Flashner)(address . efraim@flashner.co.il)
* guix/build/go-build-system.scm (setup-go-environment): When building
for windows override the inherited GOOS and set it to 'windows'.
Change-Id: I310aa490bb010370112cfa00c69df2d36387c323
---
guix/build/go-build-system.scm | 9 ++++++---
1 file changed, 6 insertions(+), 3 deletions(-)
Toggle diff (33 lines)
diff --git a/guix/build/go-build-system.scm b/guix/build/go-build-system.scm
index d95262bd6c..e0de2308f2 100644
--- a/guix/build/go-build-system.scm
+++ b/guix/build/go-build-system.scm
@@ -4,7 +4,7 @@
;;; Copyright © 2019 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2020 Jack Hill <jackhill@jackhill.us>
;;; Copyright © 2020 Jakub K?dzio?ka <kuba@kadziolka.net>
-;;; Copyright © 2020, 2021, 2023 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2020, 2021, 2023, 2024 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
;;; Copyright © 2024 Ekaitz Zarraga <ekaitz@elenq.tech>
;;; Copyright © 2024 Picnoir <picnoir@alternativebit.fr>
@@ -175,8 +175,11 @@ (define* (setup-go-environment #:key inputs outputs goos goarch #:allow-other-ke
;; that Guix targets.
(setenv "GOARCH" (or goarch
(getenv "GOHOSTARCH")))
- (setenv "GOOS" (or goos
- (getenv "GOHOSTOS")))
+ (setenv "GOOS" (cond ((and goos
+ (string=? "mingw" goos))
+ "windows")
+ (goos goos)
+ (else (getenv "GOHOSTOS"))))
(match goarch
("arm"
(setenv "GOARM" "7"))
base-commit: 2eb7cc2677272fe099e5aeef7a75c381776aaf0e
--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted