[PATCH] installer: Create ext4 file systems with ‘-O large_dir’.

  • Done
  • quality assurance status badge
Details
One participant
  • Ludovic Courtès
Owner
unassigned
Submitted by
Ludovic Courtès
Severity
normal
L
L
Ludovic Courtès wrote on 10 Jul 15:23 +0200
[PATCH] installer: Create ext4 file systems w ith ‘-O large_dir’.
(address . guix-patches@gnu.org)(name . Ludovic Courtès)(address . ludo@gnu.org)
7976069f078b5ba5c7d75e4a427f35f06c70c058.1720617776.git.ludo@gnu.org
* gnu/installer/parted.scm (create-ext4-file-system): Pass
‘-O large_dir’ to ‘mkfs.ext4’.

Change-Id: Ie34039ed03f273505e7f7fb5c3241120e3395ba2
---
gnu/installer/parted.scm | 10 ++++++++--
1 file changed, 8 insertions(+), 2 deletions(-)

Toggle diff (31 lines)
diff --git a/gnu/installer/parted.scm b/gnu/installer/parted.scm
index 51fa7cf9d9c..dbdec1bba82 100644
--- a/gnu/installer/parted.scm
+++ b/gnu/installer/parted.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2018, 2019 Mathieu Othacehe <m.othacehe@gmail.com>
-;;; Copyright © 2019, 2020, 2022 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2019-2020, 2022, 2024 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2022 Josselin Poiret <dev@jpoiret.xyz>
;;;
@@ -1187,7 +1187,13 @@ (define (create-btrfs-file-system partition)
(define (create-ext4-file-system partition)
"Create an ext4 file-system for PARTITION file-name."
- ((run-command-in-installer) "mkfs.ext4" "-F" partition))
+ ;; Enable the 'large_dir' feature so users can have a store of several TiBs.
+ ;; Failing to do that, the directory index (enabled by 'dir_index') can fill
+ ;; up and adding new files would fail with ENOSPC despite there being plenty
+ ;; of free space and inodes:
+ ;; <https://blog.merovius.de/posts/2013-10-20-ext4-mysterious-no-space-left-on/>.
+ ((run-command-in-installer) "mkfs.ext4" "-F" partition
+ "-O" "large_dir"))
(define (create-fat16-file-system partition)
"Create a fat16 file-system for PARTITION file-name."

base-commit: 922e943059050f05532ac8274e55e25ebe711cf5
--
2.45.2
L
L
Ludovic Courtès wrote on 31 Aug 19:09 +0200
control message for bug #72035
(address . control@debbugs.gnu.org)
87h6b0hb4w.fsf@gnu.org
close 72035
quit
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 72035@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 72035
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch