[PATCH] gnu: emacs-lsp-mode: Enable plists.

  • Done
  • quality assurance status badge
Details
3 participants
  • Danny Milosavljevic
  • Liliana Marie Prikler
  • Ludovic Courtès
Owner
unassigned
Submitted by
Danny Milosavljevic
Severity
normal

Debbugs page

Danny Milosavljevic wrote 8 months ago
(address . guix-patches@gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
5a373bca3b425b39f4fdfae6d4a7e3c03a26e961.1720525931.git.dannym@scratchpost.org
* gnu/packages/emacs-xyz.scm (emacs-lsp-mode)[arguments]<#:phases>
[enable-plists]: New phase.

Change-Id: I5088954b683b23ab51bd5d6adc09dcc9a1c85ec1
---
gnu/packages/emacs-xyz.scm | 8 ++++++++
1 file changed, 8 insertions(+)

Toggle diff (23 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index d5257f16a9..fd04e2432b 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -31169,6 +31169,14 @@ (define-public emacs-lsp-mode
(for-each (lambda (f)
(install-file f "."))
(find-files "clients/" "\\.el$"))))
+ (add-after 'unpack 'enable-plists
+ (lambda _
+ (substitute* "lsp-protocol.el"
+ ;; This is faster, and it's officially recommended,
+ ;; and it's required by emacs-lsp-booster.
+ ;; See also:
+ ;; <https://emacs-lsp.github.io/lsp-mode/page/performance/>.
+ (("\\(getenv \"LSP_USE_PLISTS\"\\)") "t"))))
(add-before 'move-clients-libraries 'fix-patch-el-files
;; /bin/ksh is only used on macOS, which we don't support, so we
;; don't want to add it as input.

base-commit: 13f0f52314244f08eb9fdd626d907c0c3976e06a
--
2.45.2
Ludovic Courtès wrote 8 months ago
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
875xt2wxmh.fsf@gnu.org
Hey Danny!

Danny Milosavljevic <dannym@scratchpost.org> skribis:

Toggle quote (25 lines)
> * gnu/packages/emacs-xyz.scm (emacs-lsp-mode)[arguments]<#:phases>
> [enable-plists]: New phase.
>
> Change-Id: I5088954b683b23ab51bd5d6adc09dcc9a1c85ec1
> ---
> gnu/packages/emacs-xyz.scm | 8 ++++++++
> 1 file changed, 8 insertions(+)
>
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index d5257f16a9..fd04e2432b 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -31169,6 +31169,14 @@ (define-public emacs-lsp-mode
> (for-each (lambda (f)
> (install-file f "."))
> (find-files "clients/" "\\.el$"))))
> + (add-after 'unpack 'enable-plists
> + (lambda _
> + (substitute* "lsp-protocol.el"
> + ;; This is faster, and it's officially recommended,
> + ;; and it's required by emacs-lsp-booster.
> + ;; See also:
> + ;; <https://emacs-lsp.github.io/lsp-mode/page/performance/>.
> + (("\\(getenv \"LSP_USE_PLISTS\"\\)") "t"))))

I’m know next to nothing about LSP, but that sounds reasonable to me!

Ludo’.
Liliana Marie Prikler wrote 8 months ago
0bd98ebbe17ad210aa43aa9fd442a0307bc5f182.camel@gmail.com
Am Donnerstag, dem 18.07.2024 um 17:03 +0200 schrieb Ludovic Courtès:
Toggle quote (32 lines)
> Hey Danny!
>
> Danny Milosavljevic <dannym@scratchpost.org> skribis:
>
> > * gnu/packages/emacs-xyz.scm (emacs-lsp-mode)[arguments]<#:phases>
> > [enable-plists]: New phase.
> >
> > Change-Id: I5088954b683b23ab51bd5d6adc09dcc9a1c85ec1
> > ---
> >  gnu/packages/emacs-xyz.scm | 8 ++++++++
> >  1 file changed, 8 insertions(+)
> >
> > diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-
> > xyz.scm
> > index d5257f16a9..fd04e2432b 100644
> > --- a/gnu/packages/emacs-xyz.scm
> > +++ b/gnu/packages/emacs-xyz.scm
> > @@ -31169,6 +31169,14 @@ (define-public emacs-lsp-mode
> >                (for-each (lambda (f)
> >                            (install-file f "."))
> >                          (find-files "clients/" "\\.el$"))))
> > +          (add-after 'unpack 'enable-plists
> > +            (lambda _
> > +              (substitute* "lsp-protocol.el"
> > +               ;; This is faster, and it's officially recommended,
> > +               ;; and it's required by emacs-lsp-booster.
> > +               ;; See also:
> > +               ;;
> > <https://emacs-lsp.github.io/lsp-mode/page/performance/>.
> > +               (("\\(getenv \"LSP_USE_PLISTS\"\\)") "t"))))
>
> I’m know next to nothing about LSP, but that sounds reasonable to me!
I agree. Pushed.

Cheers
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 72016@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 72016
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help