[PATCH] gnu: Add emacs-casual-info.

  • Open
  • quality assurance status badge
Details
One participant
  • peter
Owner
unassigned
Submitted by
peter
Severity
normal
P
(address . guix-patches@gnu.org)(name . Peter Polidoro)(address . peter@polidoro.io)
69e021ab8b5a161c7034fb9344184187b03b0b68.1720535057.git.peter@polidoro.io
From: Peter Polidoro <peter@polidoro.io>

* gnu/packages/emacs-xyz.scm (emacs-casual-info): New variable.

Change-Id: I673aab9621f897aa42e04937697c02294cb12cd6
---
gnu/packages/emacs-xyz.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index ae588f4913..184348f3c0 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -33160,6 +33160,33 @@ (define-public emacs-casual-dired
"Casual Dired is an opinionated Transient-based porcelain for Emacs Dired.")
(license license:gpl3+)))
+(define-public emacs-casual-info
+ (package
+ (name "emacs-casual-info")
+ (version "1.3.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/kickingvegas/casual-info")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1a74njjp7vqvl4jnmrzqjpgpvgy66p11a47hx51mydyxayp4nwmr"))))
+ (build-system emacs-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'chdir
+ (lambda _ (chdir "lisp"))))))
+ (propagated-inputs (list emacs-casual-lib))
+ (home-page "https://github.com/kickingvegas/casual-info")
+ (synopsis "Transient-based porcelain for info reader")
+ (description
+ "Casual Info is an opinionated Transient-based porcelain for Emacs Info reader.")
+ (license license:gpl3+)))
+
(define-public emacs-casual-lib
(package
(name "emacs-casual-lib")

base-commit: c6f4757ed2c78c63e642703805867caf5d0ab277
--
2.45.2
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 72011@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 72011
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch