* gnu/packages/ruby.scm (ruby-libxml)[arguments]:
Convert to list of G-Expressions.
Use #$output rather than the outputs alist.
Change-Id: If46c6d1a28358be03f854082570c913ee7f80cc7
---
gnu/packages/ruby.scm | 65 ++++++++++++++++++++++---------------------
1 file changed, 33 insertions(+), 32 deletions(-)
Toggle diff (78 lines)
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 74877ac4a9..fa2d474e4c 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -3224,38 +3224,39 @@ (define-public ruby-libxml
(inputs
(list zlib libxml2))
(arguments
- '(#:gem-flags
- (list "--no-document" ; TODO: Re-enable when documentation
- ; generation works
- "--"
- (string-append "--with-xml2-include="
- (assoc-ref %build-inputs "libxml2")
- "/include/libxml2"))
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'skip-failing-tests
- (lambda _
- (for-each
- (lambda (method)
- (substitute* "test/test_canonicalize.rb"
- (((string-append "def " method) def)
- (string-append def "; skip \"CR/LF mismatch\";"))))
- '("test_canonicalize_with_w3c_c14n_3_1"
- "test_canonicalize_with_w3c_c14n_3_2"
- "test_canonicalize_with_w3c_c14n_3_3"
- "test_canonicalize_with_w3c_c14n_3_4"))
- (substitute* "test/test_schema.rb"
- (("def test_schema_load_from_uri" def)
- (string-append def "; skip \"missing XLink schema\";")))))
- (delete 'check)
- (add-after 'install 'set-gem-path
- (lambda* (#:key outputs #:allow-other-keys)
- (setenv "GEM_PATH"
- (string-append
- (getenv "GEM_PATH") ":"
- (assoc-ref outputs "out") "/lib/ruby/vendor_ruby"))))
- (add-after 'set-gem-path 'check
- (assoc-ref %standard-phases 'check)))))
+ (list
+ #:gem-flags #~(list
+ ;; TODO: Re-enable when documentation generation works
+ "--no-document" "--"
+ (string-append "--with-xml2-include="
+ (assoc-ref %build-inputs "libxml2")
+ "/include/libxml2"))
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'skip-failing-tests
+ (lambda _
+ (for-each (lambda (method)
+ (substitute* "test/test_canonicalize.rb"
+ (((string-append "def " method)
+ def)
+ (string-append def
+ "; skip \"CR/LF mismatch\";"))))
+ '("test_canonicalize_with_w3c_c14n_3_1"
+ "test_canonicalize_with_w3c_c14n_3_2"
+ "test_canonicalize_with_w3c_c14n_3_3"
+ "test_canonicalize_with_w3c_c14n_3_4"))
+ (substitute* "test/test_schema.rb"
+ (("def test_schema_load_from_uri" def)
+ (string-append def
+ "; skip \"missing XLink schema\";")))))
+ (delete 'check)
+ (add-after 'install 'set-gem-path
+ (lambda _
+ (setenv "GEM_PATH"
+ (string-append (getenv "GEM_PATH") ":"
+ #$output "/lib/ruby/vendor_ruby"))))
+ (add-after 'set-gem-path 'check
+ (assoc-ref %standard-phases
+ 'check)))))
(synopsis "Ruby bindings for GNOME Libxml2")
(description "The Libxml-Ruby project provides Ruby language bindings for
the GNOME Libxml2 XML toolkit.")
--
2.45.2