[PATCH core-updates] gnu: gd: Skip failing test on i686-linux.

  • Done
  • quality assurance status badge
Details
One participant
  • Ludovic Courtès
Owner
unassigned
Submitted by
Ludovic Courtès
Severity
normal
L
L
Ludovic Courtès wrote on 8 Jul 2024 15:21
(address . guix-patches@gnu.org)(name . Ludovic Courtès)(address . ludo@gnu.org)
4f2316fd90495dff085061ff05cb001d8de63a87.1720444887.git.ludo@gnu.org
* gnu/packages/gd.scm (gd)[arguments]: Add “XFAIL_TESTS” to #:make-flags
on i686-linux.

Change-Id: I52a9cfeb352b0ec3fce4ff1f82f43c5f7bef6ef0
---
gnu/packages/gd.scm | 12 ++++++++++--
1 file changed, 10 insertions(+), 2 deletions(-)

Toggle diff (32 lines)
diff --git a/gnu/packages/gd.scm b/gnu/packages/gd.scm
index 2c5ba599154..98d34cfa71e 100644
--- a/gnu/packages/gd.scm
+++ b/gnu/packages/gd.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2016, 2023 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2016, 2023-2024 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015, 2016 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2016, 2017 Leo Famulari <leo@famulari.name>
@@ -61,7 +61,15 @@ (define-public gd
(arguments
;; As recommended by github.com/libgd/libgd/issues/278 to fix rounding
;; issues on aarch64 and other architectures.
- (list #:make-flags #~(list "CFLAGS=-ffp-contract=off")
+ (list #:make-flags #~(list "CFLAGS=-ffp-contract=off"
+
+ ;; XXX: This test fails on i686-linux.
+ ;; See <https://issues.guix.gnu.org/71996>.
+ #$@(if (and (not (%current-target-system))
+ (string-prefix? "i686"
+ (%current-system)))
+ #~("XFAIL_TESTS=gdimagegrayscale/basic")
+ #~()))
#:configure-flags #~(list "--disable-static")
#:phases
#~(modify-phases %standard-phases

base-commit: e4da066f0029ef38f6a791f6f9d4cfdb8b39b6a3
--
2.45.2
L
L
Ludovic Courtès wrote on 21 Aug 2024 17:39
control message for bug #71997
(address . control@debbugs.gnu.org)
87jzg9sx5s.fsf@gnu.org
close 71997
quit
?
Your comment

This issue is archived.

To comment on this conversation send an email to 71997@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 71997
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch