[PATCH] gnu: Add emacs-ob-racket.

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Goaziou
  • Sergiu Ivanov
Owner
unassigned
Submitted by
Sergiu Ivanov
Severity
normal
S
S
Sergiu Ivanov wrote on 8 Jul 11:57 +0200
(address . guix-patches@gnu.org)
8734oktddm.fsf@colimite.fr
Dear Guix,

Here's a patch packaging emacs-ob-racket for Guix.

Thanks!

-
Sergiu
From cb0fc5e27c8fc8a6158fd3d3d8f046994b28f72f Mon Sep 17 00:00:00 2001
Message-ID: <cb0fc5e27c8fc8a6158fd3d3d8f046994b28f72f.1720287408.git.sivanov@colimite.fr>
From: Sergiu Ivanov <sivanov@colimite.fr>
Date: Sat, 6 Jul 2024 18:34:22 +0100
Subject: [PATCH] gnu: Add emacs-ob-racket.

* gnu/packages/emacs-xyz.scm (emacs-ob-racket): New variable.

Change-Id: I54e96f51f1615b737f34fb729da6f872e64c2ebe
---
gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 76cd340e5e..91fa4e6dc7 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -26400,6 +26400,30 @@ (define-public emacs-racket-mode
It follows DrRacket concepts where applicable.")
(license license:gpl2+))))
+(define-public emacs-ob-racket
+ (let ((commit "c7b7eee58fcde2ad515b72288742e555e7ec7915")
+ (version "1.3.0")
+ (revision "0"))
+ (package
+ (name "emacs-ob-racket")
+ (version (git-version version revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hasu/emacs-ob-racket")
+ (commit commit)))
+ (sha256
+ (base32
+ "0bqhxi1nikxwc0gyqsnxc7ya2s41vc06w39s24qz64kja8zqzzya"))
+ (file-name (git-file-name name version))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/hasu/emacs-ob-racket")
+ (synopsis "Org-babel support for Racket")
+ (description
+ "This package adds spport for working with Racket code blocks with
+Org-babel in Org-mode.")
+ (license license:gpl3+))))
+
(define-public emacs-grep-context
(let ((commit "5a4e3efdf775755c1bbefcfe4b461c1166d81d7d")
(revision "1"))

base-commit: 5ee2799cabba4b2d462ac064a98789d7bca07923
--
2.45.2
N
N
Nicolas Goaziou wrote on 8 Jul 12:51 +0200
(name . Sergiu Ivanov)(address . sivanov@colimite.fr)(address . 71994@debbugs.gnu.org)
87sewktavs.fsf@nicolasgoaziou.fr
Hello,

Sergiu Ivanov <sivanov@colimite.fr> writes:
Toggle quote (3 lines)
>
> Here's a patch packaging emacs-ob-racket for Guix.

Thank you. Some comments follow.

Toggle quote (8 lines)
> +(define-public emacs-ob-racket
> + (let ((commit "c7b7eee58fcde2ad515b72288742e555e7ec7915")
> + (version "1.3.0")
> + (revision "0"))
> + (package
> + (name "emacs-ob-racket")
> + (version (git-version version revision commit))

There's a "1.3.0" tag, so you can drop COMMIT and REVISION and use
(version "1.3.0").

Toggle quote (6 lines)
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/hasu/emacs-ob-racket")
> + (commit commit)))

Here that will be (commit version).

Toggle quote (8 lines)
> + (sha256
> + (base32
> + "0bqhxi1nikxwc0gyqsnxc7ya2s41vc06w39s24qz64kja8zqzzya"))
> + (file-name (git-file-name name version))))
> + (build-system emacs-build-system)
> + (home-page "https://github.com/hasu/emacs-ob-racket")
> + (synopsis "Org-babel support for Racket")

Nitpick Org Babel support for Racket

Toggle quote (4 lines)
> + (description
> + "This package adds spport for working with Racket code blocks with
> +Org-babel in Org-mode.")

Likewise, Org Babel and Org mode.

I know, not every package definition follows that convention, but they
ARE WRONG! ;)

Could you send an updated patch?

Regards,
--
Nicolas Goaziou
S
S
Sergiu Ivanov wrote on 8 Jul 19:09 +0200
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)(address . 71994@debbugs.gnu.org)
87cynnajz7.fsf@colimite.fr
Hello Nicolas,

Thank you for your comments! I am attaching the updated patch to
this mail.


Nicolas Goaziou <mail@nicolasgoaziou.fr> [2024-07-08T11:51:19+0100]:
Toggle quote (6 lines)
>
> Likewise, Org Babel and Org mode.
>
> I know, not every package definition follows that convention, but they
> ARE WRONG! ;)

I am happy to follow this convention!

I never know myself how to spell Org Babel and Org mode, and if both
were Emacs functions or variables, I would just write org-babel and
org-mode :-D

-
Sergiu
From a5632cda19d42cf0c631dcbe5fa71e65e63d4be7 Mon Sep 17 00:00:00 2001
Message-ID: <a5632cda19d42cf0c631dcbe5fa71e65e63d4be7.1720458373.git.sivanov@colimite.fr>
From: Sergiu Ivanov <sivanov@colimite.fr>
Date: Sat, 6 Jul 2024 18:34:22 +0100
Subject: [PATCH] gnu: Add emacs-ob-racket.

* gnu/packages/emacs-xyz.scm (emacs-ob-racket): New variable.

Change-Id: I54e96f51f1615b737f34fb729da6f872e64c2ebe
---
gnu/packages/emacs-xyz.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 76cd340e5e..366efa0778 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -26400,6 +26400,27 @@ (define-public emacs-racket-mode
It follows DrRacket concepts where applicable.")
(license license:gpl2+))))
+(define-public emacs-ob-racket
+ (package
+ (name "emacs-ob-racket")
+ (version "1.3.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hasu/emacs-ob-racket")
+ (commit version)))
+ (sha256
+ (base32
+ "0bqhxi1nikxwc0gyqsnxc7ya2s41vc06w39s24qz64kja8zqzzya"))
+ (file-name (git-file-name name version))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/hasu/emacs-ob-racket")
+ (synopsis "Org Babel support for Racket")
+ (description
+ "This package adds spport for working with Racket code blocks with
+Org Babel in Org mode.")
+ (license license:gpl3+)))
+
(define-public emacs-grep-context
(let ((commit "5a4e3efdf775755c1bbefcfe4b461c1166d81d7d")
(revision "1"))

base-commit: 5ee2799cabba4b2d462ac064a98789d7bca07923
--
2.45.2
N
N
Nicolas Goaziou wrote on 9 Jul 10:06 +0200
(name . Sergiu Ivanov)(address . sivanov@colimite.fr)(address . 71994-done@debbugs.gnu.org)
875xtft2el.fsf@nicolasgoaziou.fr
Hello,

Sergiu Ivanov <sivanov@colimite.fr> writes:

Toggle quote (3 lines)
> Thank you for your comments! I am attaching the updated patch to
> this mail.

Applied. Thank you!

Toggle quote (4 lines)
> I never know myself how to spell Org Babel and Org mode, and if both
> were Emacs functions or variables, I would just write org-babel and
> org-mode :-D

Yes, that's the source of the confusion. Elisp symbols use hyphens, and
it is easy to conflate the language symbol with the concept. But the
Emacs manual is unambiguous about it. For example, its menu contains the
following entry:

* Major Modes:: Text mode vs. Lisp mode vs. C mode...

Regards,
--
Nicolas Goaziou
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 71994@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 71994
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch