[PATCH] gnu: Add emacs-empv.

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Goaziou
  • Thanos Apollo
Owner
unassigned
Submitted by
Thanos Apollo
Severity
normal
T
T
Thanos Apollo wrote on 8 Jul 08:27 +0200
(address . guix-patches@gnu.org)(name . Thanos Apollo)(address . public@thanosapollo.org)
a5ea83d2ef14dacce239e98f88ec6be487b4f4ae.1720419862.git.public@thanosapollo.org
* gnu/packages/emacs-xyz.scm (emacs-empv): New variable.

Change-Id: Ibfb0fca623a536e8db27b15b87e76ef9d7d5a742
---
gnu/packages/emacs-xyz.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index c82e264930..0bb115ee42 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -3730,6 +3730,34 @@ (define-public emacs-emprise
Selectrum.")
(license license:gpl3+)))
+(define-public emacs-empv
+ (let ((commit "631299ae2a918b4af17ae94eddcde4c9451235bb"))
+ (package
+ (name "emacs-empv")
+ (version "v4.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/isamert/empv.el")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0njqzri2qvpsdbkrkr1lidg2zc2742nzapwgdjaf5ms3rl8kc898"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ (list emacs-compat
+ emacs-s))
+ (home-page "https://github.com/isamert/empv.el")
+ (synopsis "An Emacs media player, media library manager, radio player, YouTube frontend ")
+ (description
+ "An Emacs media player, based on mpv. More precisely this package
+provides somewhat comprehensive interface to mpv with bunch of
+convenient functionality like an embedded radio manager, YouTube
+interface, local music/video library manager etc.")
+ (license license:gpl3+))))
+
(define-public emacs-marginalia-emprise
(package
(name "emacs-marginalia-emprise")

base-commit: 5217ea6d45bef053844d8360a06252b9436783b3
--
2.45.2
N
N
Nicolas Goaziou wrote on 8 Jul 10:02 +0200
(name . Thanos Apollo)(address . public@thanosapollo.org)
8734okuxaa.fsf@nicolasgoaziou.fr
Hello,

Thanos Apollo <public@thanosapollo.org> writes:

Toggle quote (2 lines)
> * gnu/packages/emacs-xyz.scm (emacs-empv): New variable.

Thank you. Some comments follow.

Toggle quote (6 lines)
> +(define-public emacs-empv
> + (let ((commit "631299ae2a918b4af17ae94eddcde4c9451235bb"))
> + (package
> + (name "emacs-empv")
> + (version "v4.2.0")

Upstream version is confusing. The main file says its 4.3.0, but last
tag, created one day before bumping to 4.3.0, mentions 4.2.0-RC1.

Moreover, commit 631299... does not match a version bump. So, you should
also bind `revision' to, e.g., "0". and use `git-file-name'.

Eventually, you need to remove the "v" from the version string. It
belongs to the tag, not the version.

Toggle quote (15 lines)
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/isamert/empv.el")
> + (commit commit)))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> + "0njqzri2qvpsdbkrkr1lidg2zc2742nzapwgdjaf5ms3rl8kc898"))))
> + (build-system emacs-build-system)
> + (propagated-inputs
> + (list emacs-compat
> + emacs-s))

You can write propagated inputs on a single line.

(propagated-inputs (list emacs-compat emacs-s))

Toggle quote (3 lines)
> + (synopsis "An Emacs media player, media library manager, radio player, YouTube frontend ")

Please remove the article "An" and the trailing white space.

Toggle quote (7 lines)
> + (description
> + "An Emacs media player, based on mpv. More precisely this package
> +provides somewhat comprehensive interface to mpv with bunch of
> +convenient functionality like an embedded radio manager, YouTube
> +interface, local music/video library manager etc.")
> + (license license:gpl3+))))

Description should consist of complete sentences. I suggest something
like:

"This package is an Emacs player, based on MPV. More precisely, it
[...], local music and video library manager, etc."

Could you send an updated patch?

Regards,
--
Nicolas Goaziou
T
T
Thanos Apollo wrote on 8 Jul 18:41 +0200
[PATCH 1/2] gnu: Add emacs-empv.
(address . 71990@debbugs.gnu.org)(name . Thanos Apollo)(address . public@thanosapollo.org)
4e16cb0ed765c0bab5ea8e504d6ddf444cec2a6a.1720456887.git.public@thanosapollo.org
* gnu/packages/emacs-xyz.scm (emacs-empv): New variable.

Change-Id: Ibfb0fca623a536e8db27b15b87e76ef9d7d5a742
---
gnu/packages/emacs-xyz.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index d5257f16a9..97d13e4635 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -3730,6 +3730,34 @@ (define-public emacs-emprise
Selectrum.")
(license license:gpl3+)))
+(define-public emacs-empv
+ (let ((commit "631299ae2a918b4af17ae94eddcde4c9451235bb")
+ (revision "0"))
+ (package
+ (name "emacs-empv")
+ (version (git-version "4.3.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/isamert/empv.el")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0njqzri2qvpsdbkrkr1lidg2zc2742nzapwgdjaf5ms3rl8kc898"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ (list emacs-compat emacs-s))
+ (home-page "https://github.com/isamert/empv.el")
+ (synopsis "Emacs media player, media library manager, radio player, YouTube frontend")
+ (description
+ "Emacs multimedia player based on MPV. This package offers a
+comprehensive interface to mpv, including convenient features such as an
+embedded radio manager, YouTube integration, and a local music/video library
+manager.")
+ (license license:gpl3+))))
+
(define-public emacs-marginalia-emprise
(package
(name "emacs-marginalia-emprise")

base-commit: 13f0f52314244f08eb9fdd626d907c0c3976e06a
--
2.45.2
N
N
Nicolas Goaziou wrote on 9 Jul 10:07 +0200
(name . Thanos Apollo)(address . public@thanosapollo.org)
871q43t2cg.fsf@nicolasgoaziou.fr
Hello,

Thanos Apollo <public@thanosapollo.org> writes:

Toggle quote (2 lines)
> * gnu/packages/emacs-xyz.scm (emacs-empv): New variable.

I bumped it to the (very recent) latest upstream commit and applied your
patch. Thank you!

Regards,
--
Nicolas Goaziou
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 71990@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 71990
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch