Hi,
Thank you for your patience and work on nicely crafted patches!
I've reviewed them, applied some relaxation to description of jjson and
pushed as:
- 7eb3a5ac7dd * master gnu: fastfetch: Add more configure flags.
- a0b40f26cf4 * gnu: fastfetch: Update to 2.34.1.
- ab73372eec4 * gnu: Add yyjson.
Toggle snippet (29 lines)
> $(./pre-inst-env guix build fastfetch)/bin/fastfetch
.. `. sharlatan@guxtil
`--..```..` `..```..--` ----------------
.-:///-:::. `-:::///:-. OS: Guix System x86_64
````.:::` `:::.```` Kernel: Linux 6.11.10
-//:` -::- Uptime: 10 days, 35 mins
://: -::- Packages: 237 (guix-system), 156 (guix-user)
`///- .:::` Shell: bash 5.1.16
-+++-:::. Display (DELL U2412M): 1920x1200 @ 60 Hz in 24" [External] *
:+/:::- Display (DELL U2412M): 1920x1200 @ 60 Hz in 24" [External]
`-....` DE: GNOME 44.10
WM: Mutter (X11)
WM Theme: Adwaita
Theme: Adwaita [GTK2/3/4]
Icons: Adwaita [GTK2/3/4]
Font: Sans (11pt) [GTK2/3/4]
Cursor: Adwaita (24px)
Terminal: guix
CPU: AMD Ryzen 7 3800X (16) @ 4.56 GHz
GPU: AMD Radeon Pro WX 4100 [Discrete]
Memory: 10.10 GiB / 62.73 GiB (16%)
Swap: 744.75 MiB / 3.72 GiB (20%)
Disk (/): 150.90 GiB / 453.71 GiB (33%) - ext4
Disk (/mnt/library): 806.87 GiB / 5.46 TiB (14%) - xfs
**********************************
Locale: en_GB.utf8
Toggle snippet (51 lines)
@@ -1784,21 +1784,26 @@ (define-public yyjson
"-DYYJSON_BUILD_TESTS=ON")))
(build-system cmake-build-system)
(home-page "https://github.com/ibireme/yyjson")
- (synopsis "High performance JSON library written in ANSI C")
+ (synopsis "C implementation of JSON RFC 8259")
(description
- "Yyjson is a high performance JSON library written in ANSI C. Some features include
+ "This package provides an implementation of JSON in ANSI C as specified
+in RFC 8259.
+Features:
@itemize
@item Fast: can read or write gigabytes per second JSON data on modern CPUs.
@item Portable: complies with ANSI C (C89) for cross-platform compatibility.
-@item Strict: complies with RFC 8259 JSON standard, ensuring strict
-number format and UTF-8 validation.
+@item Strict: complies with
+@url{https://datatracker.ietf.org/doc/html/rfc8259,RFC 8259} JSON standard,
+ensuring strict number format and UTF-8 validation.
@item Extendable: offers options to allow comments, trailing commas, NaN/Inf,
and custom memory allocator.
-@item Accuracy: can accurately read and write int64, uint64, and double numbers.
-@item Flexible: supports unlimited JSON nesting levels, \\u0000 characters,
-and non null-terminated strings.
+@item Accuracy: can accurately read and write @code{int64}, @code{uint64}, and
+@code{double} numbers.
+@item Flexible: supports unlimited JSON nesting levels, @code{\\u0000}
+characters, and non null-terminated strings.
@item Manipulation: supports querying and modifying using JSON Pointer,
JSON Patch and JSON Merge Patch.
-@item Developer-Friendly: easy integration with only one .h and one .c file.
+@item Developer-Friendly: easy integration with only one @code{.h} and one
+@code{.c} file.
@end itemize")
(license license:expat)))
@@ -1779,11 +1779,11 @@ (define-public yyjson
(file-name (git-file-name name version))
(sha256
(base32 "0kmzgs24v0rxlibg4qwlm6yplzs96pgxb1gyviijhkra9z7lx7ws"))))
+ (build-system cmake-build-system)
(arguments
(list
#:configure-flags #~(list "-DBUILD_SHARED_LIBS=ON"
"-DYYJSON_BUILD_TESTS=ON")))
- (build-system cmake-build-system)
(home-page "https://github.com/ibireme/yyjson")
(synopsis "C implementation of JSON RFC 8259")
(description