[PATCH] services: web: Return success from nginx-action.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Tomas Volf
Owner
unassigned
Submitted by
Tomas Volf
Severity
normal

Debbugs page

Tomas Volf wrote 8 months ago
(address . guix-patches@gnu.org)(name . Tomas Volf)(address . ~@wolfsden.cz)
400feb0255e86efee23f561e97bc53c6818c3bb0.1720191689.git.~@wolfsden.cz
Previous value of #f lead to `head reload nginx' returning exit code 1,
complicating usage from scripts (and other actions). Returning #t fixes that.
Any actual failures are still covered by the invoke call above.

* gnu/services/web.scm (nginx-shepherd-service)[nginx-action]<-s>: Return #t.

Change-Id: I4ce1645798a85baddeb0f5bd702a2567db3c7aaa
---
gnu/services/web.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/services/web.scm b/gnu/services/web.scm
index b73cd30fe7..af4d6de658 100644
--- a/gnu/services/web.scm
+++ b/gnu/services/web.scm
@@ -831,7 +831,7 @@ (define (nginx-shepherd-service config)
#~(lambda _
(invoke #$nginx-binary "-c" #$config-file #$@args)
(match '#$args
- (("-s" . _) #f)
+ (("-s" . _) #t)
(_
;; When FILE is true, we cannot be sure that PID-FILE will
;; be created, so assume it won't show up. When FILE is
--
2.45.1
Ludovic Courtès wrote 8 months ago
(name . Tomas Volf)(address . ~@wolfsden.cz)(address . 71950-done@debbugs.gnu.org)
87o7755oky.fsf@gnu.org
Tomas Volf <~@wolfsden.cz> skribis:

Toggle quote (8 lines)
> Previous value of #f lead to `head reload nginx' returning exit code 1,
> complicating usage from scripts (and other actions). Returning #t fixes that.
> Any actual failures are still covered by the invoke call above.
>
> * gnu/services/web.scm (nginx-shepherd-service)[nginx-action]<-s>: Return #t.
>
> Change-Id: I4ce1645798a85baddeb0f5bd702a2567db3c7aaa

Applied, thanks!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 71950@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 71950
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help