[PATCH 0/2] gnu: distrobox: Update to 1.7.2.1.

  • Done
  • quality assurance status badge
Details
2 participants
  • Jean-Pierre De Jesus DIAZ
  • Ludovic Courtès
Owner
unassigned
Submitted by
Jean-Pierre De Jesus DIAZ
Severity
normal
J
J
Jean-Pierre De Jesus DIAZ wrote on 4 Jul 2024 12:09
[PATCH 0/2] gnu: distrobox: Update to 1.7.2.1.
(address . guix-patches@gnu.org)(name . Jean-Pierre De Jesus DIAZ)(address . jean@foundation.xyz)
cover.1720087651.git.jean@foundation.xyz
Updates distrobox to latest release and also fixes an existing problem
with the package as when creating a distrobox container it generates a
desktop file, but quickly breaks if the store path of distrobox changes.

So this patchset fixes that by only using `distrobox' command as
available on the environment.

Jean-Pierre De Jesus DIAZ (2):
gnu: distrobox: Update to 1.7.2.1.
gnu: distrobox: Patch distrobox-generate-entry.

gnu/packages/containers.scm | 12 ++++++++++--
1 file changed, 10 insertions(+), 2 deletions(-)


base-commit: 3979812d4923e980f0069ad99332e2df7c033769
--
2.45.2
J
J
Jean-Pierre De Jesus DIAZ wrote on 4 Jul 2024 12:11
[PATCH 1/2] gnu: distrobox: Update to 1.7.2.1.
(address . 71937@debbugs.gnu.org)(name . Jean-Pierre De Jesus DIAZ)(address . jean@foundation.xyz)
ed166ce58febf6ef9a4f4ac67b7386e8dc6f80f3.1720087651.git.jean@foundation.xyz
* gnu/packages/containers.scm (distrobox): Update to 1.7.2.1.

Change-Id: If0d644b013ddc4f63bf6b6e549f19845626ba60d
---
gnu/packages/containers.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/containers.scm b/gnu/packages/containers.scm
index 72acfaba45..9b17f6601e 100644
--- a/gnu/packages/containers.scm
+++ b/gnu/packages/containers.scm
@@ -160,7 +160,7 @@ (define-public conmon
(define-public distrobox
(package
(name "distrobox")
- (version "1.7.0")
+ (version "1.7.2.1")
(source
(origin
(method git-fetch)
@@ -168,7 +168,7 @@ (define-public distrobox
(url "https://github.com/89luca89/distrobox")
(commit version)))
(sha256
- (base32 "1g14q1sm3026h9n85v1gc3m2v9sgrac2mr9yrkh98qg5yahzmpc3"))
+ (base32 "0q0m3x1984kc5g7pihlwmnmrnnxnx6c0givx7wf91q91rlmdws0z"))
(file-name (git-file-name name version))))
(build-system copy-build-system)
(arguments
--
2.45.2
J
J
Jean-Pierre De Jesus DIAZ wrote on 4 Jul 2024 12:11
[PATCH 2/2] gnu: distrobox: Patch distrobox-generate-entry.
(address . 71937@debbugs.gnu.org)(name . Jean-Pierre De Jesus DIAZ)(address . jean@foundation.xyz)
83b646b35ad823da12214add2855c89b4c89ab80.1720087651.git.jean@foundation.xyz
Avoids keeping store references in generated desktop files.

* gnu/packages/containers.scm (distrobox)<arguments>: add
'patch-distrobox-generate-entry phase.

Change-Id: Ib1bffaefa1805accb5227c289c9fc985853bc675
---
gnu/packages/containers.scm | 8 ++++++++
1 file changed, 8 insertions(+)

Toggle diff (21 lines)
diff --git a/gnu/packages/containers.scm b/gnu/packages/containers.scm
index 9b17f6601e..1bfa18b4b9 100644
--- a/gnu/packages/containers.scm
+++ b/gnu/packages/containers.scm
@@ -174,6 +174,14 @@ (define-public distrobox
(arguments
(list #:phases
#~(modify-phases %standard-phases
+ ;; This script creates desktop files but when the store path for
+ ;; distrobox changes it leaves the stale path on the desktop
+ ;; file, so remove the path to use the profile's current
+ ;; distrobox.
+ (add-after 'unpack 'patch-distrobox-generate-entry
+ (lambda _
+ (substitute* "distrobox-generate-entry"
+ (("\\$\\{distrobox_path\\}/distrobox") "distrobox"))))
;; Use WRAP-SCRIPT to wrap all of the scripts of distrobox,
;; excluding the host side ones.
(add-after 'install 'wrap-scripts
--
2.45.2
L
L
Ludovic Courtès wrote on 20 Jul 2024 12:16
Re: [bug#71937] [PATCH 0/2] gnu: distrobox: Update to 1.7.2.1.
(name . Jean-Pierre De Jesus DIAZ)(address . jean@foundation.xyz)(address . 71937-done@debbugs.gnu.org)
8734o4qsfa.fsf@gnu.org
Jean-Pierre De Jesus DIAZ <jean@foundation.xyz> skribis:

Toggle quote (11 lines)
> Updates distrobox to latest release and also fixes an existing problem
> with the package as when creating a distrobox container it generates a
> desktop file, but quickly breaks if the store path of distrobox changes.
>
> So this patchset fixes that by only using `distrobox' command as
> available on the environment.
>
> Jean-Pierre De Jesus DIAZ (2):
> gnu: distrobox: Update to 1.7.2.1.
> gnu: distrobox: Patch distrobox-generate-entry.

Applied, thanks!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 71937@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 71937
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch